Tagged: 

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #628737

    Hello to everyone.

    The close-button for a portfolio, opening in ajax, isn´t working anymore and I need to refresh the page if I want to close it.
    And after clicking on the button, the arrows and the other portfolio entries aren´t working either.

    This you can see here:
    http://www.koelner-musikakademie.de/dozenten-1/ (Please visit from desktop. Mobile version is different!).

    Could you please have a look on that? You might have an idea what is happening.

    Thank you in advance.

    Best Regards
    Asterios

    • This topic was modified 8 years ago by Asterios.
    #629050

    Hey asterios,

    Are you using any minify plugins on the site? If so try to disable it to see if that helps. If not then please post admin login details in private and we’ll have a closer look.

    Regards,
    Rikard

    #629119

    Hello Rikard and thank you for your reply.

    I am using minify through the W3TC Plugin. I just deactivated it, but it didn´t help.

    Could you please have a look on that? The credentials were sent in the private section.

    Best Regards
    Asterios

    #630395

    Hi,

    We can see the following errors when we click the close button:

    jquery.js:1 Uncaught Error: Syntax error, unrecognized expression: .main_menu .menu li > a[href*=#]
    3jquery.js:1 Uncaught Error: Syntax error, unrecognized expression: [href*=#]
    

    Please update the theme to version 3.5.4 if you haven’t done so. If it’s still not working, please follow the instructions here: https://kriesi.at/support/topic/plugin-shortcode-not-working-in-portfolio-item/#post-628065

    Best regards,
    Ismael

    #630688

    Hi Ismael,
    thank you for the reply.
    The theme is already updated in the latest version and the code you sent me didn´t help.
    The problem is stil there.

    A few hours ago, I edited this text saying that it works.
    I really don´t know what to say, but it doesn´t again.
    Sorry for this, could you please have another look?

    Best Regards
    Asterios

    • This reply was modified 8 years ago by Asterios.
    #631159

    Hi,

    Could you try clearing all cache from the caching plugin and deactivate it to see if that helps?

    Thanks,
    Rikard

    #631334

    Hi Rikard,

    I tried the cache from W3TC at least 50 times. Since I am using CloudFlare (CDN), I also deactivated their cache but it didn´t help.
    One funny thing, is that it seems to be working from my office but only with Firefox. It doesn´t in Chrome.
    When I am at home, nothing works.
    I am totally confused and I wish I could help you guys more but I don´t know how.

    Best Regards
    Asterios

    #631822

    Hi Asterios,

    It would be good if you could keep your caching plugin deactivated while we try to help you, the error message which is coming from the minified version of jQuery is still there and that is the first red flag we will wave at you.

    Please try adding the following to the bottom of your functions.php file under Appearance–>Editor:

    function modify_jquery() {
    if (!is_admin()) {
    	wp_deregister_script('jquery');
    	wp_register_script('jquery', 'https://code.jquery.com/jquery-1.11.3.min.js');
    	wp_enqueue_script('jquery');
    }
    }
    add_action('init', 'modify_jquery');

    Thanks,
    Rikard

    #631961

    Good mornig Rikard,

    I am sorry for the misunderstanding about the cache.

    I did everything as you said and voilá, it works now!
    Thank you all for the great support.

    One small question: Do you know what caused the problem?

    Best Regards
    Asterios

    #631999

    Hi,

    All browsers usually cache the files to speed up load time and this cache expires automatically after a short duration in the mean time if there are any changes made one has to manually clear it.

    Glad it’s working for you now :)

    Thank you for using Enfold.

    Best regards,
    Vinay

Viewing 10 posts - 1 through 10 (of 10 total)
  • The topic ‘Close Button not working’ is closed to new replies.