Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1325182

    Hi guys,

    Disabled CSS and Javascript merging and compression, Changed Child Theme Stylesheet (style.css) and cleared the site’s cache (Kinsta), cleared browser’s (both Safari and Chrome) tried Incognito mode. And even the support at Kinsta cannot see the changes made to the CSS.

    It’s as if it stopped working altogether and showing old code.

    It looks like cache but I do not see anything cached. Kinsta support says there is a problem with the code.

    This works on staging but not on the live site. When you look at the code on the url itself you can see that the H2 is not Muli but Open Sans Condensed and it’s not recognizing the stylesheet. Same goes for the hyperlink decoration on the post (link I shared)

    Added findings: On the Live Site, every single CSS is calling line 1. And different files

    This is a screenshot on Staging=- calling style.css:31 and enfold_child.css:99
    Staging

    And this is on the Live site: calling enfold_child.css:1 and enfold_child.css:1:124049 << ADDING: /wp-content/uploads/dynamic_avia/enfold_child.css why is it pointing to the Uploads folder? And why does this file not get properly updated and has old CSS?

    Live site

    Why is it calling the wrong line?

    Thank you!!

    Havi

    This is my stylesheet.css
    /*underline links body*/
    .entry-content p a {
    color: #1e4766 !important;
    border-bottom: 3px dotted #ea526f !important;
    }
    .entry-content p a:hover {
    color: #6a6797 !important;
    text-decoration: none !important;
    border-bottom: 3px dotted #163248 !important;
    }
    /* H3 style*/
    #top #wrap_all .main_color h3, #top #wrap_all .alternate_color h3 {
    line-height: 1.1em !important;
    font-family: ‘Muli’, ‘HelveticaNeue’, ‘Helvetica Neue’, ‘Helvetica-Neue’, Helvetica, sans-serif !important;
    font-weight: light !important;
    text-transform: uppercase !important;
    }
    /* H2 style*/
    #top #wrap_all .main_color h2, #top #wrap_all .alternate_color h2 {
    color: #514e78 !important;
    line-height: 1.1em !important;
    font-family: ‘Muli’, ‘HelveticaNeue’, ‘Helvetica Neue’, ‘Helvetica-Neue’, Helvetica, sans-serif !important;
    font-weight: normal !important;
    text-transform: none !important;
    }

    • This topic was modified 2 years, 7 months ago by havi. Reason: More info found
    #1325220

    Hey havi,

    Please send us a temporary WordPress admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #1325245

    Hi Rikard,

    I found the problem. You won’t believe what it was. My client’s sysadmin (they maintain a pretty large IT center) changed the DNS settings for this subdomain on Cloudflare to Proxied. That’s why the cache was not clearing up. When I asked for a screenshot of the DNS records, the Proxied status was there on the screenshot and he kept saying that nothing was being cached on his end.

    Sometimes I don’t know how some people keep their jobs. He removed the Proxy caching at midnight (my time) last night and I just got up and wanted to let you know.

    Feel free to close this ticket. Nothing was wrong on this end. Heads up to others, if it looks like something has been cached, and the same code works on an uncached environment, you cleared the server’s cache, the browser’s cache and even gone incognito, don’t let host support people tell you otherwise. It’s cached somewhere.

    Thank you so much!

    Havi

    #1325295

    Hi Havi,

    Great, I’m glad that you found the problem, and thanks for sharing your experience :-)

    I’ll close this thread for now then, please open a new thread if you should have any further questions or problems.

    Best regards,
    Rikard

Viewing 4 posts - 1 through 4 (of 4 total)
  • The topic ‘Child Theme Stylesheet not Picking up’ is closed to new replies.