Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #1146201

    Hey guys,
    I spent HOURS trying to figure this out not knowing it was related to your child theme since I upgraded the parent theme.

    I know for sure now because when I set the theme to the default WordPress Nineteen theme, it works.
    When I set the parent theme of Enfold to the website, the CDN works

    As soon as I set the Child theme, it no longer works.

    Can you help?

    Thanks

    #1146204

    maybe this is a start? The error I get when the parent theme is activated: https://prnt.sc/pghd58

    #1146364

    Removed old Child theme.
    Created new child theme.
    The CDN only works with the parent theme.

    #1147114
    #1147673

    Hi,

    Sorry for the delay. Looks like an issue with the theme’s file compression generating incorrect paths for the resource files. Does it work properly when the theme’s compression feature is disabled? If you really need to use the theme’s file compression settings, try to correct the file path using the “avf_compress_file_content_path” filter.

    Best regards,
    Ismael

    #1147873

    Hey Ismael, Thanks….those are all disabled. Have been for a while. See here: https://prnt.sc/pj4okl

    When the child theme is off and I am using the parent theme – it works….?

    When the child theme is active it does not work.

    #1148118

    Hi,

    Thank you for the info.

    Try to use this filter in the functions.php file to remove the unwanted URL in the file path.

    add_filter('avf_compress_file_content_path', function($check_path, $path , $file_type , $fallback_url) {
    	$checkpath = str_replace('https://cdn.js-interactive.com/', "", $check_path);
    	return $check_path;
    }, 10, 4);
    

    After adding the snippet, don’t forget to toggle the Performance > File Compression settings and remove the cache.

    Best regards,
    Ismael

    #1148127

    Ismael, before I do anything else. I have had other websites that have a similar configuration to my own – and it has worked for years. I updated another website to the latest theme, and now I am experiencing the same challenge where the CDN rewrite no longer works. :/

    #1148453

    Hi,

    I’m not entirely sure what changed after the update, so I’m going to tag one of our developers to check the thread. Please wait for his response. Did you try the filter above?

    Thank you for the update.

    Best regards,
    Ismael

    #1148454

    I did try that Ismael, thank you.
    It had no affect.

    Justin

    #1148949

    I spent a couple more hours on this. Removed the theme. Reinstalled the theme. Removed the child theme. Reinstalled a new child theme. Stripped all custom CSS and PHP from the style and functions file/

    None of that fixed the issue I am having with the CSS rewrite not working.

    • This reply was modified 1 year ago by  Justin.
    #1148993

    Also….since the update…I click developer and I get this: https://prnt.sc/pknkhe

    A blank section.

    #1149109

    Hi,

    Thank you for the update.

    Can we access the dashboard and the file server? We have to check the settings and edit a few files in order to debug the issue. Please provide the WP and FTP login details in the private field.

    Best regards,
    Ismael

    #1149318

    See below please

    #1149849

    Hi,

    Thank you for the update.

    Where do you see these errors (https://prnt.sc/pghd58)? We enabled the debug mode and the theme’s file compression settings, but we didn’t see any errors in the site. We also confirmed that WP Rocket’s CDN option is enabled, and that the resources (css, js, images) are loaded from CDN.

    Screenshot: https://imgur.com/a/Tv5FULw

    Best regards,
    Ismael

    #1150209

    Ismael. Take a look at my clients website here: https://fosterdanowsky.com/ Look at the source code carefully – particularly all the images that are coming from the wp-content/ folder: https://drive.google.com/open?id=15tC0Ert_7Jx-UllILpzhT-brsrY9rXN7

    Now please do the same for https://js-interactive.com. Look at the source code: https://drive.google.com/open?id=1XUmKgXmr1lP0fqc__8spV_WT5VRSIEwD

    Both sites have the same configuration. The JS site doesn’t appear to be rewriting any images coming from the wp-content folder.

    Justin

    #1150445

    Hi,

    Sorry about that. We only checked the stylesheets and external resources from the network tab, but forgot to inspect the markup. Unfortunately, we are still not sure why the rewrites are not working. Did you contact the WP Rocket support yet? They might be able to help us figure out the issue.

    Do you have a dev version of the js-interactive site? Have you tried disabling some of the plugins to rule out incompatibility? I will ask the rest of the team to check the thread. Please wait for their response.

    Thank you for your patience.

    Best regards,
    Ismael

    #1150536

    Ismael, I do know it’s Enfold child theme related.
    When I select a default WordPress theme, the rewrite works.
    When I activate the Enfold parent theme, the rewrite works.
    I have stripped all CSS and custom PHP from the child theme before – and there was no change.

    The only thing to date, that changes things – is deactivating the child theme.
    Is there a setting I am overlooking in the child theme that cold be causing this or…?

    #1150712

    So Ismael. After hours on this and being back and forth with WP Rocket on this… I decided to try a plugin…. just for the CDN part: https://wordpress.org/plugins/cdn-enabler/ And guess what? It worked.

    I spent hours with support for the original Caching plugin solution I was using for the CDN, and they kept saying it was theme related.

    #1150780

    Hi Justin,

    That’s great! Glad to know that it’s working again now. Please let us know in another thread if you need anything else. We’ll close this one for now.

    Have a nice day.

    Regards,
    Ismael

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.