Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #436144

    Is it possible to leave out the featured image on a single post page. Now it shows up top left besides the article, if it can be removed it would leave more space for the blog text.

    • This topic was modified 8 years, 12 months ago by raymondleever.
    #436422

    Hi raymondleever!

    Switch to the Text editor and add this inside.

    <style type = "text/css">
    .big-preview { display: none !important; }
    </style>

    That should hide the featured image on the post.

    Cheers!
    Elliott

    #436431

    Thanks for your reply Elliot,
    But when I copy the code above the text the image is still visible. I did found an option with the featured image to hide it in the single post. Then only the pencil block is visible. Is there another way to hide both image and pencil block and is it possible to do so without changing all individual blog posts.

    Thanks!

    #436903

    Hey!

    Please add following code to Quick CSS in Enfold theme options under General Styling tab

    .single .big-preview.single-small, .single .blog-meta {
      display: none!important;
    }

    If that does not help, please post the link to your blog page

    Regards,
    Yigit

    #1126692

    Hi there,
    As I could not find anywhere any thread on what I am after, could you maybe assist with below on this thread:
    I have a page with 2 blog posts elements with1 featured post and a 3rd blog post element which shows 4 posts and have selected the pagination. However if you go the second pages the first 2 featured image are loaded again. A solution would be probably to create a second page with just blog posts elements without the featured elements and create a link on the first page, but is there any way to hide the featured posts after pagination on the same page?
    I could find a thread which has been closed but participant did not share how he solved the issue -> https://kriesi.at/support/topic/hide-elements-in-pagination-pages/.
    Thank you!

    • This reply was modified 4 years, 8 months ago by Vasilis.
    #1128140

    Hi,
    Sorry for the late reply, in the thread you linked to the solution was:

    .page-id-2957.paged #layer_slider_1{
        display: none; 
    }

    It looks like after he tested and cleared his cache he found it worked. But this won’t work for you because the css has a page ID so it will only work on one page.
    To adjust to your page please include a link to it so we can examine.
    This would help because I can’t imagine what you are trying to achieve, perhaps it will make sense after we see your page.

    Typically, it’s a good idea to open your own threads for support because anything you add into the Private Content area will be seen by the thread’s opening poster, and you would not see anything we add to the Private Content area.
    We are happy to help here, just wasn’t sure if you knew this.

    Best regards,
    Mike

    #1128403

    Hi Mike,
    thank you for your reply.
    I actually created a new thread https://kriesi.at/support/topic/remove-featured-image-on-next-page-after-pagination/#post-1128337 and Basilis repied that it would not be possible and I would need to hire a freelancer? would it not possible with a customization as the one you posted. I will send you the link in the private area. Could you reply either on this thread or on the new that I started?

    Thank you,
    Vasilis

    #1128439

    Hi,
    Thanks for the link, as I understand, when you click the pagination that is below the grid blog element, the top two post will be hidden. Please try this code in the General Styling > Quick CSS field or in the WordPress > Customize > Additional CSS field:

    .page-id-15.paged .post-entry-type-standard {
        display: none !important;  
    }

    Best regards,
    Mike

    #1255354

    Hi everyone,
    I am glad that this thread is still open. I had fixed this issue with @Mike’s assistance, but now seem to have the same issue on 2 pages:
    https://aimonas.gr/news/ -< on this site I have 2 categories showing on this page
    https://aimonas.grπροσωπικότητες/πρόσωπα-του-αΐμονα/ -> here I got just 1 category.
    On both sites I have the same issue, the first featured articles show again on the next pages.
    What has changed since last time:
    Wordpress v5.5.1 & Enfold v 4.7.6.4

    Thank you for your assistance!

    #1255442

    Hi,
    Try adding this code to the end of your functions.php file in Appearance > Editor:

    function custom_script(){
      ?>
      <script>
    (function($){
      $(document).ready(function(){
      var url = location.pathname;
      if (window.location.href.indexOf('avia-element-paging=') > -1) {
        $(".post-entry-type-standard").css({ 'display': 'none' });
      } 
      });
    })(jQuery);
    </script>
    <?php
    }
    add_action('wp_footer', 'custom_script');

    Then clear your browser cache and check.

    Best regards,
    Mike

    #1255473

    HI Mike,
    Thank you for your reply.
    I do not seem to have editor on under appearance.
    My only options are Themes, Customize, Widget & Menus. Any idea where I can find the Editor?

    Thank you!

    #1255503

    Hi,
    Typically plugins such as WordFence have an option to hide the Theme Editor option, also known as the “file editor” option, for WordFence it is in the “WordPress Tweaks” option.
    It can also be disabled via the wp-config.php file via ftp, with this code:
    define( 'DISALLOW_FILE_EDIT', true );
    so if you find that you could remove it, but it is most likely a plugin.
    Probably the easiest solution is to add the code above to the functions.php file via ftp.

    Best regards,
    Mike

    #1255686

    Hi Mike,
    define( ‘DISALLOW_FILE_EDIT’, true );
    did not work.
    I put the code under wp-content/themes/enfold-child/functions.php since I am using a child theme, Is this correct?
    I have refreshed the page but nothing yet.
    Maybe I need to wait a bit?

    Thank you!

    #1255693

    Hi,
    You would want to look in the wp-config.php file via ftp, and if you see define( 'DISALLOW_FILE_EDIT', true ); then change to define( 'DISALLOW_FILE_EDIT', false ); but adding to your functions.php will not work.
    Try posting ftp access to your site, in the Private Content area, and I can add the script for you to your functions.php, if you wish.

    Best regards,
    Mike

    #1255936

    Hi Mike,
    thank you for clarifying. I did everything as asked and the Editor option is now there!
    I added the code under Appearance > Theme editor > functions.php (not through ftp) but nothing has changed on the website.
    Maybe I need to give it couple of hours?

    Thank you!

    #1256044

    Hi,
    Please check that the code you pasted does not have “curly quotes” they should all be straight.
    Otherwise, try including an admin login in the Private Content area so we can take a look.

    Best regards,
    Mike

    #1256279

    Hi Mike,
    Looks fine for me. I have copied and pasted it.
    Find login in private area.

    Thank you!

    #1256663

    UPDATED 30 OCTOBER 2020:
    MY APOLOGIES SINCE I HAD CONFUSED 2 DIFFERENT THREADS THAT I HAD STARTED AT THE SAME TIME FOR MY OTHER WEBSITE.
    MIKE’S SOLUTION WAS ALREADY SOLVED ABOVE ON https://kriesi.at/support/topic/change-raster-layout-in-blog-style-2/#post-1255442.
    MY BELOW ANSWER WAS REGARDING ANOTHER POST REGARDING MASSONRY GALLERY: https://kriesi.at/support/topic/masonry-gallery-not-loading-properly-3/#post-1255114.
    MY APOLOGIES,
    VASILIS

  • Hi there,
    I found what the issue was.
    I have installed Enhanced Media Library plugin which I find great as I like having my images in folders. I deactivated it and it now seem to be working fine. I should have thought earlier about it!
    The same plugin has caused me an issue with another website with much more images but with a different issue – it was showing me double image on galleries.
    I still like this plugin and I am uploading images, sort them by folders and then deactivate it, so that the websites work smooth.

    Thank you,
    Vasilis

    • This reply was modified 3 years, 5 months ago by Vasilis. Reason: correction that solution was for another thread
#1256695

Hi,
Glad to hear you have sorted this out, just to clarify for future users, are you using this plugin: Enhanced Media Library, and the workaround is to active the plugin to upload images, and then deactivate it to use the images and avoid the error?
I’m sure this tip will be helpful, thank you.
Unless there is anything else we can assist with on this issue, shall we close this then?

Best regards,
Mike

#1256711

Hi Mike,
Yes this is what I do especially with the second website where I have many photos see here otherwise I would be loosing the plot on how to filter and find them. These issues started after latest updates some months ago after WordPress & Enfold updates.
Just to let users know that I am using the PRO version as this gives you the option to select images in bulk categorize or delete them.
I do not if there any other plugin similar but for sure on the one above it would be too difficult to go through the whole process again.

You can close this thread now.

Thank you,
Vasilis

#1256716

Hi,
Thank you for the feedback and glad we were able to help, we will close this now. Thank you for using Enfold.

For your information, you can take a look at Enfold documentation here
For any other questions or issues, feel free to start new threads in the Enfold forum and we will gladly try to help you :)

Best regards,
Mike

Viewing 21 posts - 1 through 21 (of 21 total)
  • The topic ‘Remove featured image single post page’ is closed to new replies.