Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #374821

    Hello and thanks again for your great theme!
    Question: right now when I set a masonry portfolio grid to ‘automatic’ it will always show the portfolio items in 2 columns – always!
    even if the screen is wide (lets say 1920 px) it will still arrange the items in 2 columns, why?
    shouldn’t ‘automatic’ means changing the number of columns according to screen size
    (e.g 1024 px will show 2 or 3 columns and 1920 px will show 4 or 5 columns etc…)?

    to get around this problem for now I have set it to 5 columns which looks good on wide screens
    but not so cool on small screens (like iPad)
    so to fix that I added

    @media only screen and (max-width: 990px) {
    .av-masonry-entry {
    width: 50% !important;
    }
    }

    to the quick css and now Ipad looks o.k but in landscape mode it still not very good (still 5 columns instead of 3 or 2 and so the pictures are way too small)
    can you help me make ‘automatic, based on screen width’ to be really automatic?

    • This topic was modified 6 years, 5 months ago by  Doron.
    #375239

    Hey doronwo!

    Set it back to automatic and remove your custom CSS and let us know when your done so we can take a look.

    Also be sure to deactivate all plugins while testing and make sure your using at least version 3.0.4 of Enfold. I couldn’t check your version because of your plugins.

    Regards,
    Elliott

    #375393

    Hi Elliott
    Done! I removed all custom CSS, disabled all plugins, set the masonry back to automatic -just as you asked
    please take a look (same URL from the first post)
    as you can see.. only 2 columns – no matter how wide the screen is – once I set the masonry to automatic all I get is 2 columns :(
    thank you for taking a look, I hope You can solve this mystery
    I am running the latest Enfold version (3.0.4)
    please let me know how can I fix this?

    Thank you so much
    Doron

    #375802

    Hey!

    It looks like you have it inside a 1/1 column. Remove the column.

    Cheers!
    Elliott

    #375915

    O.K
    I took it out of the 1/1 column and removed the column …it’s still the same
    all I get is 2 columns of pictures even in wide screen :(

    #376385

    Hi!

    You have a div with a class of “container” surrounding the shortcode which shouldn’t be there. Are you sure the Masonry is not nested inside some other elements?

    Completely delete Enfold from your WordPress theme directory before downloading + uploading a fresh copy from themeforest and then deactivate all plugins.

    If your still having problems then send us a WordPress login.

    Best regards,
    Elliott

    #376515

    O.K
    1. all plugins already deactivated..
    2. deleted current theme
    3. unzipped and uploaded the original ‘themeforest-enfold-responsive-multipurpose-theme.zip’ I Bought and downloaded from themeforest
    4. still no joy….

    5. created an new WordPress user with Admin privileges (log in details are in the following private replay)
    6. crossing fingers..

    #376517
    This reply has been marked as private.
    #376522

    update:
    It’s working!!
    thanks!

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘change masonry columns number according to screen size’ is closed to new replies.