Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #612443

    I use media to upload some pictures. I tried different sizes (below 1 mb), different types (jpg and png), but it says “HTTP error.” However sometimes I am able to upload even larger sizes of images. Can’t really understand why sometimes it doesn’t work and what it depends on.
    I uploaded 6-7 pictures to product page to the product gallery and some on them had this error, some -no.

    Please help.

    Thank you

    #612457

    Hey comelen!

    Have you checked with your hosting company and increased the php memory? Most of the time is is the reason why you get error sometimes while uploading the media.

    Best regards,
    Vinay

    #612814

    thank you for the answer, but as I mentioned before, it’s not the problem of the size. as I was able to upload larger pictures.
    I am going to contact the hosting company today.
    Thank you

    #612817

    Hey!

    Please do so and let us know. We will keep the thread open and wait to hear from you and thread will be on hold. You can simply re-open it by simply replying to this thread

    Best regards,
    Yigit

    #613126

    there should be an issue with the user permissions.
    Godaddy were not able to help. I noticed when I upload the first time – it doesn’t work, the second time it works sometimes.

    #613127

    Hi!

    cab u please share ftp access with us, on private area?

    Cheers!
    Basilis

    #613131

    here it is

    #614130

    HI, I just talked to godaddy again.
    We have tried to disable all pluggings – the problem was not solved. Then we tried to change the theme and I was able to upload pictures without any problem. So there is a problem in the theme that sometimes gives me HTTP error.
    The strange thing for me is that sometimes I can upload and sometimes – no…

    #614482

    I can confirm this issue. Uploading an average size image results in this error in the browser console:
    POST http://mydomain.com/wp-admin/async-upload.php 500 (Internal Server Error)

    PHP Logged this error within 5-10 seconds after starting the upload – NOT 30 seconds:

    [14-Apr-2016 22:32:29 UTC] PHP Fatal error:  Maximum execution time of 30 seconds exceeded in /home/content/path/to/my/html/wp-includes/class-wp-image-editor-imagick.php on line 370
    

    When switching to Twenty-Sixteen there were no upload errors on any image uploads (including very large images).

    I was able to verify the following:

    • Image does get uploaded to the correct year/month folder
    • Images do get crunched into 16 various sizes
    • In Media Library, image receives default placeholder icon (gray page)
    • Clicking the icon and then “Edit more details” link, the image is displayed on the image on the Edit Media page
    • Clicking the “Edit Image” button below the image results in “Image data does not exist. Please re-upload the image.

    Memory Increase & Other Hacks
    I’ve completed all the requisite settings:

    // .user.ini
    upload_max_filesize = 128M
    post_max_size = 256M
    

    And tried all the .htaccess tips from these posts with no success:
    Here
    And Here
    – Also tried disabling all Plugins

    Upload Scenarios
    Here are a couple image scenarios that threw errors when using the Enfold theme but upload with no problem with default WP theme. As with comelen, sometimes larger images work where smaller files do not (both file size and image dimensions).

    Scenario 1
    Image type: png or jpg
    File size: 24kb
    Dimensions: 1600×900 @72dpi
    Work-around: After much experimentation with dimensions, I discovered the file would only upload if under 1200px, so I upload the file 1199×674.

    Scenario 2
    Image type: png or jpg
    File size: 173kb
    Dimensions: 480×854 @72dpi
    Work-around: none (other than switch to Twenty-sixteen)

    • Enfold v3.4.7 (although I’ve experienced this issue on several previous versions)
    • PHP v5.4.42
    • WordPress v4.5
    • MySql v5.5.43

    Honestly, the last place I suspected was the Enfold theme because it’s always been rock-solid! Let me know if there is anything else I can do to help resolve this issue.

    Thanks,

    Jeff Boothe

    ** UPDATE 4/15 **
    Just got this PHP error when attempting upload:

    
    [15-Apr-2016 22:31:34 UTC] PHP Fatal error:  Maximum execution time of 30 seconds exceeded in /home/content/p3pnexwpnas10_data01/24/2579924/html/wp-includes/class-wp-image-editor.php on line 423
    
    • This reply was modified 8 years ago by topearn.
    #614550

    We are experiencing similar issues re: uploading images to the Media Library. We did find that we were able to upload an image if we first removed all non-alphanumeric characters from the image file name (for example, changed “Ultimate-5-Plus-5.jpg” to “Ultimate5Plus5.jpg”). Prior to WordPress 4.5 we didn’t experience this problem. We will keep an eye on the thread for a resolution, thanks!
    *****UPDATE: The fix for us was found in the following thread: https://kriesi.at/support/topic/upload-image-giving-http-error-theme-error/
    See Josue code fix, reply #514811
    Thank you Kriesi for the great support forum!

    • This reply was modified 8 years ago by twitzel.
    #615379

    Hi @twitzel,

    Thanks for the feedback and glad you got it fixed! Could the rest of the users having this problem try the same thing to see if it helps them as well?

    Best regards,
    Rikard

    #615481

    Hi @Rikard ~ I think it’s definitely worth it for them to try that fix, I’ve now seen it work on three different sites!

    #615617

    I was able to solve this using this solution from the above mentioned thread.

    #616141

    Hi,

    Great, glad you got it working and thanks for letting us know!

    Regards,
    Rikard

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.