Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1153869

    I just started managing a new website that had Enfold installed. I’m trying to update it, it’s missing a LOT of updates, but it gives errors constantly. The current error is “Fatal error: Class ‘avia_auto_toc’ not found in /home/content/13/6335713/html/wp-includes/class-wp-widget-factory.php on line 100”

    I currently have the new version in the wp-content folder as “enfold-new” and the old version as “enfold” so I can just rename them to try the update.

    I’ve tried deactivating all plugins and it didn’t fix the error.

    #1153936

    Hey Greenshields,

    The child theme will pick the folder which is called Enfold, so that is likely why you are getting that error. What happens if you name the new folder Enfold and the rename the old one to something else?

    Also please consider updating your PHP version: https://wordpress.org/support/update-php/

    Best regards,
    Rikard

    #1153941

    The error doesn’t occur when the old theme is used. It only occurs I rename the updated version to enfold.

    I’m working with the host to update php but I’m using the highest version they are currently offering.

    #1154137

    Hi,

    Thanks for the update, so which is the highest PHP version your hosting provider can offer? Please note that the minimum recommended version for running WordPress on is 5.6.2.

    I see that you have some files included in your child theme, what exactly are you overriding from the child theme? Do you get the same problem if you activate the parent theme?

    Best regards,
    Rikard

    #1154142

    I’m running some version of 5.6, which is the highest the web host is providing and they aren’t specifying what version of 5.6 it’s using. I’m currently looking into changing web hosts as well. I’m getting the same error on a self hosted development environment using PHP 7.

    Yes, I get the same error when activating the current version of Enfold with no modifications.

    #1154394

    Hi Greenshields,

    Credentials did not work for me. Could you please update the credentials?

    Best regards,
    Victoria

    #1154507

    Updated credentials

    • This reply was modified 1 week, 3 days ago by  Greenshields.
    #1154910

    Hi Greenshields,

    Well, this version of Enfold will not work with WordPress 5.2.4, and a higher version of Enfold requires php5.6.3 or php7.
    You need to update Enfold and php, you might run into some issues along the way but you can always write to us.

    Best regards,
    Victoria

    #1154917

    I am TRYING to update enfold. That’s the whole reason why I’m posting here. It throws the original error whenever I try to update enfold. Was I not clear about this? The whole reason I’m posting here is that enfold won’t update. 3 days later I’m not closer to getting the theme updated. Fix it. Now.

    Sincerely,
    An extremely unhappy customer

    #1154935

    For the record, I’ve now cloned the website into multiple testing environments running php7 and it still won’t work with the updated version of enfold. It just displays “the site is experiencing technical difficulties”

    • This reply was modified 1 week, 2 days ago by  Greenshields.
    • This reply was modified 1 week, 2 days ago by  Greenshields.
    #1155150

    Hi,

    Thanks for the update. Could we get access to your test environment so that we can see the problem?

    Best regards,
    Rikard

    #1155804

    Just made this public. It is a clone of the live site. The only change is that it’s using the latest version of Enfold as it’s theme. The site is running on PHP 7.3.

    #1156628

    Hi,

    Thank you for the update.

    Are you using the Table of Contents widget anywhere in the site? We disabled it temporarily from the functions.php file, line 708.

    //register_widget( 'avia_auto_toc' );
    

    You should be able to access the dashboard now without the error.

    Best regards,
    Ismael

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.