Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #415477

    my configuration: enfold woocommerce and WooCommerce Tab Manager

    what i have done in a product-page:

    – activatet the checkbox: „Override default tab layout“
    – edit the tabs
    – then „update“ the product page by clicking the „update“ button.

    what i would expect
    – the induvidual tabs are shown

    what is happend:
    – the global default tab is shown [!]
    – in the edit-mode: the checkbox: „Override default tab layout“ is deactivatet [!]

    what i have tested:
    Twenty TwelveVersion: 1.6 instead of Enfold: everything is ok

    #415861

    Hi xianeK!

    Thank you for using Enfold.

    I cannot see any tabs in the page. Where is the actual product page? Note that you can use the advance layout builder for products. Add the tab element.

    Cheers!
    Ismael

    #415912
    This reply has been marked as private.
    #416529
    This reply has been marked as private.
    #417607

    Hey!

    Sorry for the delay. We don’t have the plugin at our disposal so we need to access the site. Please post the login details here. Set it as a private reply. If possible, please contact the plugin author for more info regarding the issue.

    Regards,
    Ismael

    #417617
    This reply has been marked as private.
    #418944

    Hey!

    I don’t really know what this happens only with Enfold but i think i found a fix, open /wp-content/plugins/woocommerce-tab-manager/admin/woocommerce-tab-manager-admin-functions.php and look for this line 102:

    <label for="_override_tab_layout"><?php _e( 'Override default tab layout:', WC_Tab_Manager::TEXT_DOMAIN ); ?></label> <input type="checkbox" name="_override_tab_layout" id="_override_tab_layout" <?php checked( $override_tab_layout, "yes" ); ?> />
    

    Replace it by:

    <label for="_override_tab_layout"><?php _e( 'Override default tab layout:', WC_Tab_Manager::TEXT_DOMAIN ); ?></label> <input type="checkbox" name="_override_tab_layout" id="_override_tab_layout" <?php checked( $override_tab_layout, "on" ); ?> />
    

    Regards,
    Josue

    #420287
    This reply has been marked as private.
    #420833

    Hi!

    Do they show up if you activate Twenty Fifteen?

    Cheers!
    Josue

    #420919
    This reply has been marked as private.
    #422227

    Hey!

    Yes, it’s tricky. I think i managed to make it work now, please check it.

    I had to edit /woocommerce-tab-manager/woocommerce-tab-manager.php too (changed all iterances of “yes” to “on”).

    Best regards,
    Josue

    #425189

    hi josue, thanks for your help! your support is great!
    xiane

    #425703

    Hi!

    Great, glad we could help :)

    Cheers!
    Rikard

    #487455

    Same issue here!

    I solved the problem as well … with replacing all ‘yes’ to ‘on’.
    /woocommerce-tab-manager/woocommerce-tab-manager.php

    There still issues.
    Every time you change something in the product detail page such as prices, you need to tick “Override default tab layout” .
    It doesn’t save it. Kind of annoying.
    If it is an Enfold problem, i would be really glad if the issue is addressed in future updates.

    Never the less, *Thumbs up* for the Kriesi Support Team.

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Cant edit the WooCommerce Tab Manager’ is closed to new replies.