Viewing 24 posts - 1 through 24 (of 24 total)
  • Author
    Posts
  • #334501

    Hi there,
    I just bought your theme a few days ago and after setting everything up I seem to be having issues with editing. I’ve tried editing the parent theme through the theme options and also additional CSS and I’ve also installed your child theme version and tried both ways there. Nothing seems to update when I change colors etc.

    I installed the demo content but no colours really seem to load and a lot of styling seems to be missing from it. It said installed successfully but maybe I have done something wrong.

    I also tried to upload my logo and insert it but it never appears it just has a link saying my website. I have the logo at the required size.
    UPDATE: The theme wouldn’t recognise a logo that was uploaded and stored in the gallery but it did allow me to enter a URL and display it that way,

    I also tried to do what you have in your documents to add another Google font but after adding the function to child them and testing and then parent theme neither seem to work.

    My site is listed below

    Thanks
    Michael

    • This topic was modified 3 years, 1 month ago by  mrussell1984.
    #334791

    Also can’t insert any media that is uploaded. It gives an error saying it can’t find the URL

    #335385

    Hi!

    Thank you for using Enfold.

    The wp-content folder does not have the correct file permission. Please contact your host then ask them to change it. After that, toggle any theme options then save changes. It should be working by then.

    Regards,
    Ismael

    #335606

    Hi Ismael,

    I have been onto my hosting company but they weren’t sure what you wanted me to do. They said “what are they saying the permissions should be set as”, “you don’t need to change the permissions to upload the correct files” and “ok so I reviewed this with one of our hosting representatives and they said you can changed the permissions on that folder but they strongly recommend not because the 777 permissions will leave it open for anyone to access and make changes to”. some other moderator suggested the 777 thing.

    What do you want me to tell them? they dont seem to think its an issue with permissions to the folder? they said currently the folder is set to 705 permissions

    #335796

    I’ve created the folder dynamic_avia like you said but what is suppose to be in that folder?

    This is getting ridiculous now, I bought this theme 5 days ago and it still doesn’t work! Why do people have to change permissions just to get a theme to work anyway? I’ve used plenty of WordPress themes before and never had this issue.
    There are quite a few people with this same issue so clearly it’s a problem within the theme.
    If this isn’t working in the next few days I want a refund because you’ve sold me a product that doesn’t even work

    #335821

    Hi!

    Unfortunately I cant reproduce the issue in any way so please post me your login credentials to your wordpress installation as well as for your ftp so I can see if there is something I can do.

    Best regards,
    Kriesi

    #335840
    This reply has been marked as private.
    #335975

    Hi!

    When you check the site there’s an error directly related to enfold.css file located on dynamic_avia folder and other content inside the wp-content folder: Failed to load resource: the server responded with a status of 404 (Not Found)

    This is usually cause by incorrect folder and file permission or the files doesn’t exist. Please try to set those to 755 or higher. Toggle any theme options then save changes. Please post the FTP login details here. Set it as a private reply. We would like to check it.

    Regards,
    Ismael

    #335977

    Hey!

    The thing is: if this was a common issue we would have thousands of users complaining about it and I would also have noticed it in my own backend. Since thats not the case, and since I cant reproduce it in any way on my own installation there has to be something on your installation that is unique. Either a plugin, a server settings, a ftp problem etc, so we will check all of that :)

    Thanks for the login credentials, as said above I would be glad if you could drop me the FTP credentials as well since right now it sounds like that might be the problem…

    Cheers!
    Kriesi

    #336035
    This reply has been marked as private.
    #336208

    Sorry for the confusion. I have already logged in to your backend and can see the problem, so yes of course: on your server I can see the issue.

    Unfortunately the login credentials for the ftp server dont quite work for me. I can somewhat login but end up in an empty folder. I need at least access to the wp-content folder though :)

    #336215

    can you try again I changed the path it was incorrect.

    Is the issue that there is no enfold.css the problem?

    #336238

    Thanks!

    Just checked it again and at this point I am pretty sure that this is nothing related to enfold. I checked your ftp server and every operation that creates a file fails.

    2 examples:
    Once you save the enfold options WordPress creates a stylesheet in the uploads folder. But on your server that does not work. So I switched to the WordPress default theme and tried to upload an image, which also fails. The database entry is set in both cases and there are no visible errors (which is odd) but neither the stylesheet nor the uploaded image are created by WordPress, no matter the theme.

    Permissions look fine for me, but since I am not really a server-guru there might be other settings that prevent WordPress from creating files on your server. Do you have any idea why this might happen? It seems it has worked at some point in the past, since I can find a few images in the uploads folder, as well as an Avada stylesheet…

    #336249

    I’ve had several themes just as test sites and I’ve also other themes installed on separate sites which are on the same server with no issue so i dont really understand how it cant be this specific theme?

    As I said in my other comment when i unzip the theme there’s files that appear to be missing according to other posts. Like there’s no enfold.css? there’s no dynamic stylesheet that seems to be needed?

    I’ll contact godaddy again anyway and see what they say

    #336271

    If you want to, I can try to upload wordpress and the theme again but I am not sure if this is going to help. As I said, this does not appear to be an issue related to the theme since I cant upload images even if switching to the default theme…

    A “enfold.css” file is not in the upload package. The file is generated once you save the theme options and then usually saved in the uploads folder, since this is the only folder that should be writeable for wordpress by default. For a unknown reason that upload folder is not writeable for any theme. Truth to be told, I cant really imagine why but my best guess is that it has something to do with the permissions that the php-user has in those folders…

    #336279

    Do you think installing a fresh copy of WordPress with a new database and uploading the theme would solve this issue? I dont have any content on the site yet so i wouldnt be losing anything

    #336283

    Well, we can give it a shot since it only takes a fe minutes but I am not sure if it will help. Its more likely that the godaddy staff has experience with non-writeable folders and can tell us what to do…

    #336285

    Hey!

    That might fix it and its worth a shot if you have a host with one-click WordPress installation capabilities.

    With that said, before installing Enfold make sure you can upload images on the new installation and those standard WordPress functions are all working. Then upload the theme over FTP following the steps here: http://kriesi.at/documentation/enfold/install-enfold-over-ftp/

    Cheers!
    Devin

    #336286

    Thanks guys I’ll give it a try

    #336303

    k ;)

    #336682

    It seems to be taking the theme option changes now :D

    Just to check though there’s no images with the demo content is there? They’re still seems to be a few things that look out of sync but it mostly seems to be working ok now

    Thank you for your help and also anyone else that replied

    #336746

    Hey!
    Good to hear that we are making some progress.
    There should by a few images when installing the demo content but not the same amount of images as we use in the actual demo because of licensing reasons and amount of time it takes to import them…

    Regards,
    Kriesi

    #337020

    Unfortunately I can’t see any because I contacted godaddy and it seems there’s another problem :( I can upload images but once they are uploaded I can’t see the preview of them in the media library. Godaddy said a lot of people have had this problem since moving to WordPress 4.0. They want me to uninstall the theme and reinstall

    #337049

    Hey!

    Would recommend to do that then and also check if this happens with the default theme

    Cheers!
    Kriesi

Viewing 24 posts - 1 through 24 (of 24 total)

The topic ‘Can't edit aspects of theme’ is closed to new replies.