Tagged: 

Viewing 28 posts - 1 through 28 (of 28 total)
  • Author
    Posts
  • #23552

    Hi,

    on trying to open pages overview / pages list, i receive a blank page in FF, the following error message in Chrome:

    “Serverfehler

    Beim Abrufen von http://www.musikzentrale.net/wp-admin/edit.php?post_type=page ist auf der Website ein Fehler aufgetreten. Möglicherweise wird sie gerade gewartet oder ist falsch konfiguriert.

    Vorschläge:

    Laden Sie diese Webseite später erneut.

    HTTP-Fehler 500 (Internal Server Error): Beim Versuch des Servers, die Anforderung zu verarbeiten, ist eine unerwartete Bedingung aufgetreten.”

    Since we went online with the new site on Friday, I only installed three plugins: W3 Total Cache (to adjust Caching and Minify), Duplicate Post to set up our 40 landing pages and Redirection to manage the redirects from our old Joomla page.

    The error occured when I alreay set up around 30 of them, all of a sudden WP did not accept the permalink, than resulting in the white screen. I can access all other areas of the site, pages are accessable from the frontend, so i could at least finish my work.

    what i did so far: disabled the three plugins mentioned, cleared cache, login, but the problem persists.

    Any idea what has gone wrong? Thanks for your help! URL is http://www.musikzentrale.net

    Cheers,

    Sebastian

    #120242

    Hi Sebastian,

    I’m not really sure what the issue could be. You can try switching to one of the default wordpress themes to see if its a theme specific issue but it sounds like an issue with your database/wordpress installation.

    In that case, there isn’t much we would be able to do unfortunately. You would check the general wordpress support forums and try for an answer there.

    If it is a theme specific issue, we can dig deeper and see what might be happening.

    Regards,

    Devin

    #120243

    I think it will be related to the cache plugin, as I think that inserts code into the sites config files or the ,htaccess file. I don’t use those plugins myself, as I find they cause too many problems.

    #120244

    Thanks for your answers, i was afraid that it is a DB or plugin related issue. So i disabled the Cache plugin, without any success. I do not dare to switch template (newbie to wordpress), because i am afraid to loose my modifications? Can you confirm that they will be kept when returning to Enfold?

    #120245

    Just to make clear, when the error occured:

    – created the new website on a production server

    – moved the site to the main domain with duplicator (http://www.lifeinthegrid.com/duplicator/) – which really worked in 5 minutes

    – adjusted links

    – installed W3 Total Cache

    – installed Post Duplicator Plugin

    – after duplicating and editing a bunch of pages, the opened page refused to save

    – trying to get back to pager overview i received the white page

    – disabling all freshly installed plugins did not solve the problem

    – all other parts of the WP installation do work as supposed to

    – editing a page is still possible from the frontend.

    WP Forum did not held a solution yet, i will keep you updated. If there is any idea around, i would really appreciate your help, thanks!

    Cheers, Sebastian.

    #120246

    Hi,

    Try to add this on your wp-config.php

    define('WP_MEMORY_LIMIT', '96M');

    This might not work if your host doesn’t allow the option, in that case contact your host to increase the PHP memory limit.

    Update us if it helps.

    Cheers,

    Ismael

    #120247

    Hi Ismael,

    thanks for coming back on my issue. Does this option makes sense, althoug the memory_limit is already set to 512MB in the server`s php config?

    Cheers, Sebastian

    Edith says: No, this one did not the trick. Pages are still not visible in the backend.

    #120248

    Ok, in this case please try to switch to the default TwentyTwelve theme. You won’t loose any modifications as long as you don’t uninstall the theme (just activating another theme won’t change or delete the settings). Does the problem still persist afterwards?

    #120249

    Hi Dude,

    thanks for getting this clear – still new to WP and happy to got that far.

    Just checked your idea, enabled twenty eleven, but the problem still occurs, unfortunately. Since the site is almost done as far as pages are concerned, i could live with that for a while. But if there is one problem yet, the next one is just around the corner … i am afraid.

    So, any other ideas? A corrupt installation?, DB errors? BTW: I am receiving the next error message on saving new menu items, is this somehow related?

    MENU ITEM LIMIT WARNING

    You are approaching the post variable limit imposed by your server configuration. Exceeding this limit may automatically delete menu items when you save. Please increase your max_input_vars directive in php.ini. More information

    max_input_vars :: 1000

    Menu Item Post variable count on last save :: 856

    Approximate remaining menu items :: 9

    #120250

    Hi,

    Contact your host, tell them to increase max_input_vars.

    If you have access to php.ini file, you can add this lines

    max_input_vars = 3000
    suhosin.post.max_vars = 3000
    suhosin.request.max_vars = 3000

    Regards,

    Ismael

    #120251

    Hi Ismael,

    thanks for your tipp. Where do i find the php.ini file or do i have so set one up?

    Searching for this issue, I came across the idea of setting up a user.ini, containing this entries. Could this fix the problem as well?

    So i do a new text file, save it as user.ini, ftp it to the root direction of the WP installation? Sorry for asking that basic questions, but my php knowledge is really poor ;-)

    Cheers, Sebastian

    #120252

    Hi,

    I think user.ini is almost the same as .htaccess. Please contact your host to make the certain changes for you.

    Regards,

    Ismael

    #120253

    Hi out there,

    any idea on how to solve the initial problem?

    Describe it again: I cannot access the pages overview site from the backend via pages –> pages / All pages. I am still able to create a new page or access existing ones from the frontend, but on trying to call the overview, i receive a white post_page type in FF, Chrome encounters a “internal Server error 500 due to an unexpected condition”.

    Disabling all plugins did not solve the problem, since i have got quite a few, this was my only idea.

    Your help is higly appreciated, for i am afraid there is a deeper error somewhere inside my WP installation that might ruin my site someday …

    Have a nice day,

    Sebastian.

    PS: Hoster set max_var to 5000, this is solved anyway.

    #120254

    Hi,

    Enfold 1.5 has been release. Maybe that will solve the issue.

    Regards,

    Ismael

    #120255

    Hi Ismael,

    I updated to 1.5 yesterday morning, this fixed my overlapping portfolio items issue, but the pages-page lost problem still exists. I saw in Devins Video on how to update Enfold there might be a version 1.5.1, but the download from themeforest is still 1.5. Did i miss an update?

    Regards,

    Sebastian

    #120256

    Hi Sebastian,

    If the issue is still happening when you switch to Twenty Twelve or Twenty Eleven it means there is an issue with your wordpress installation unfortunately.

    You can try asking about the issue on the wordpress support forums or even contacting the hosting provider to see if they have ever come across it with someone on their server before.

    From the theme side of things there just isn’t much we can do with wordpress issues.

    And yes, I believe there will be another update soon if it isn’t live already. The 1.5.1 was the version I pulled from our git repo which is the current iteration Kriesi is working on.

    Regards,

    Devin

    #120257

    Hi again,

    after updating to Enfold 1.5.1 the problem with the pages overview persists. My hoster checked log files and confirmed, server errors are not produced serverside, but from a WP scipt. Since i do not know any better, i have to trust him. Following his advice, i checked the pages overview loading with http live headers, that is the log:

    HTTP/1.1 500 Internal Server Error

    Date: Fri, 31 May 2013 13:05:51 GMT

    Server: Apache

    X-Powered-By: PHP/5.3.24

    x-frame-options: SAMEORIGIN

    X-Pingback: http://www.musikzentrale.net/xmlrpc.php

    Expires: Wed, 11 Jan 1984 05:00:00 GMT

    Cache-Control: no-cache, must-revalidate, max-age=0

    Pragma: no-cache

    Content-Length: 0

    Connection: close

    Content-Type: text/html; charset=UTF-8

    Again, since i am a complete Server/ Php/ dummie, i have absolutely no idea, what else i can do to access pages.

    Regards, Sebastian

    #120258

    1. Open up wp-config.php in a texteditor.

    2. Locate the line with define(‘WP_DEBUG’, false);

    3. and set it to define(‘WP_DEBUG’, true);

    While editing the config file, you may also insert these lines:

    /** Extending the autosave feature */
    define('AUTOSAVE_INTERVAL', 1200 );

    /** Limit draft count */
    define('WP_POST_REVISIONS', 3);

    The first setting raises the autosave feature up to 20 minutes. The second one limits the number of revisions to 3 (instead of unlimited)… this will prevent a lot of database entries.

    After that, have a look at your backend. Common probs and errors are shown at the top of each page. Have a look at the footer of the pages – any errors related to PHP memory are shown there. In addition, you may check your memory allocation with this plugin: http://wordpress.org/plugins/wp-memory-usage/

    And finally, install this plugin (or any other you may prefer): http://wordpress.org/plugins/wp-clean-up/

    If you are unsure, back up your database first. I’m using this plugin quite a lot in development and it cleans the db very reliable from orphans & co.

    Good luck!

    PS: Grüße aus Weilmünster! ;)

    #120259

    Hi from Wetzlar to Weilmünster (die Welt ist ein Puff – gerade in Mittelhessen*ggg*)

    thanks for pointing me to the debug direction, here is what it says:

    “Notice: bbp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init(). Please see Debugging in WordPress for more information. (This message was added in version 2.3.) in /usr/www/users/musikzr/wp-includes/functions.php on line 2959

    Notice: Constant AUTOSAVE_INTERVAL already defined in /usr/www/users/musikzr/wp-config.php on line 94

    Notice: Constant WP_POST_REVISIONS already defined in /usr/www/users/musikzr/wp-config.php on line 97″

    As far as the memory is concerned:

    “Mem: WP 40M Usage 38% 96.79M Limit 256M *”

    What does these entries tell the artist regarding the Pages-Problem?

    Guude,

    Sebastian

    #120260

    Guude aach! :)

    After a little bit of investigation there seems to be a defect (http://bbpress.trac.wordpress.org/ticket/2309). It may be fixed with a future release of bbPress. This may be the one leading to your pages error.

    The two other notices belong to a double declaration of a constant – you may remove one of them. :)

    Memory ain’t a prob, but this should ALWAYS be checked when running wordpress. You have a total of 256M – remove any limitations you have inserted before (WP_MEMORY_LIMIT).

    I would encourage you to set up a new and fresh install of wordpress on the same server. Create a subdirectory (like ‘wp-test’) in your home directory. Configure WordPress and install Enfold right after that. Setup your Permalinks as desired and create a few pages. If everything is okay, enable the debugging in wp-config. After that, go ahead with your plugins – one by one. Try to reproduce the misbehaviour. bbPress should be the last…

    If you are still stuck, one of the moderators here may have a look to your installation.

    Best wishes!

    #120261

    I would recommend formateins’s advice and set up a test install on the same server. Then do a very basic installation with no plugins and test as you add in each after that.

    It very well could be a rogue setting in the wp_options table relating to the enfold theme install specifically or even with the wordpress install overall.

    Regards,

    Devin

    #120262

    Hi all,

    thanks for forming a team fighting my site`s issue ;-)

    Sorry, that it take me a week, but we did have visiting guest from LA and lots of music to play with them. So, as adviced, i set up an installation, using the same content, same plugins activating one ofter another – and look: The website AND the backend both work as supposed to. The main issue is opening pages overview, no problem with the test environment you can find @ mz.muze1.de.

    So what can i do next, since obviously the issue is not caused by any bad coded plugin (to be honest: i even used some more on the test server than on the live site, for i wanted to crash it and see where the problem derives – no chance, enfold seems to be a quite solid one)

    Thanks for taking care of http://www.musikzentrale.net

    Cheers, Sebastian.

    #120263

    Hi,

    “Resolving 500 errors – general: this error can only be resolved by fixes to the Web server software. It is not a client-side problem. It is up to the administrators of your Web server site to locate and analyse the logs which should give further information about the error.”

    Reset your plugin folders.

    1.) Via FTP or your host’s file manager, navigate to the wp-contents folder (directory)

    2.) Rename the folder “plugins” to “plugins.hold”

    3.) Login to your WordPress administration menus (/wp-admin)

    4.) Via FTP or your host’s file manager, rename “plugins.hold” back to “plugins”

    Reinstall WordPress.

    1.) Download the latest version of wordpress.

    2.) Override your installation except the wp-content folder.

    Regards,

    Ismael

    #120264

    Hi Ismael,

    okay, plugin folder resetting did not solve the problem, so reinstalling seems to be the mean of choice. Just to make sure i get you right:

    – of course i do a complete backup first by downloading the whole site via ftp

    – DB backup via phpmyadmin export and download

    – then: should i delete all files & folders except wp-content? and how about the wp-config.php?

    – get a fresh copy of WP, unzipp locally and FTP all files & folders via ftp, except wp-content (and wp-config.php)

    Any experiences if the site including the enfold theme is working as before – in the best case with pages overview being accessable again – or do i have to do major adjustments?

    Thanks for your kind help.

    Cheers, Sebastian.

    #120265

    You don’t need to delete the wp files. I’d recommend to download a fresh copy of WP and then use a ftp client like filezilla to upload these files. Confirm the “overwrite files” dialog. Filezilla will then overwrite all files except wp-config.php and the plugin/theme files.

    #120266

    Okay, thanks for explaining. So reinstalling is good practice to solve issues like the one i am facing? I just want to be sure not to loose the work of some weeks … ;-)

    #120267

    So here we are with a fresh WP installation, but the same issue: edit.php?post_type=page calls a white page in FF and a HTTP-Fehler 500 (Internal Server Error) in Chrome.

    What could be the next step?

    Cheers, Sebastian.

    #120268

    Hi!

    Did you try to contact the hoster – maybe they can provide a detailed error log.

    Regards,

    Peter

Viewing 28 posts - 1 through 28 (of 28 total)

The topic ‘Calling post_type=page i receive a blank page’ is closed to new replies.