Tagged: 

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #1147098

    I have been experiencing a strange caching issue.
    When my caching plugin (WPROCKET) is active, it prevents fonts and videos loading even with ‘All cookies and services are accepted on first page load…’ active in ‘Privacy and Cookies’ if I deactivate WPROCKET I get the expected result. I.E. fonts and videos load without the user needing to accept or click on dialogue button.

    I have also seen this happen on another Caching Plugin I user on a different site. So it doesn’t seem to be only related to WPRocket.

    Any ideas on how to fix.

    #1147360

    Hey eddygame,

    Where can we see and reproduce the problem you are having?

    Best regards,
    Rikard

    #1147784

    Hi Rikard,

    I have provided details for you to take a look.

    • This reply was modified 4 years, 8 months ago by eddygame.
    #1148737

    Hi,

    Thank you for the update.

    We can’t seem to reproduce the issue on our end. The cookies are set properly as shown in the screenshot below once we gave our consent to enable them. And we are also able to play the video.

    Screenshot: https://imgur.com/a/9q7qjxC

    Best regards,
    Ismael

    #1148916

    Hi, my understanding was that if I selected in the ENFOLD THEME the option for ‘All cookies and services are accepted on first page load’ in the privacy & coolie section, that this would mean that the fonts and videos would load WITHOUT the user having to click on accept the cookies? am I wrong in this assumption?

    #1149223

    Hi,

    that this would mean that the fonts and videos would load WITHOUT the user having to click on accept the cookies?

    Yes, that is correct. Sorry about that. I got a little confuse. We tested the site again, removed everything in the local storage and refreshed the page. The fonts are still loaded even if we didn’t accept the cookie because the “aviaCookieSilentConsent” cookie is still added to the local storage. All services will be enabled by default regardless of the cookie consent status as long as the cookie (aviaCookieSilentConsent) is present.

    Example of the script where this condition can be seen at work:

    		var allow_continue = true;
    					var silent_accept_cookie = document.cookie.match(/aviaCookieSilentConsent/);
    
    					if( cookie_check && ! silent_accept_cookie )
    					{
    

    Best regards,
    Ismael

    #1149484

    Hi Ismael, when I view the site in incognito/private mode with a clean browser cache etc. The custom google font (used for headlines etc) and video don’t load, even with the correct option selected in the backend… ‘All cookies and services are accepted on first page load’.

    #1149921

    I’m pretty sure that there is something in the theme/code which isn’t working correctly when a caching plugin is present. Or a file needs excluding from caching.

    I’ve been running Enfold and WP Rocket on 10+ sites for a couple of years without issue. But since the last update, this problem has appeared.

    #1150361

    Hi,

    Thank you for the update.

    We are able to reproduce the issue. The script fails to create the following link tag or font resource in incognito mode because the “aviaCookieSilentConsent” is not set on load. We can’t reproduce the issue on our own installation though.

     	<link type="text/css" rel="stylesheet" href="//fonts.googleapis.com/css?family=Arvo" id="avia-google-webfont">
    

    We’ll notify the team regarding the issue. Thank you for your patience.

    Best regards,
    Ismael

    #1150499

    Hi Ismael, will this be addressed in the next update?

    #1150850

    Hi,

    Thank you for the update.

    We are not really sure if this is an issue with the theme because we are not able to reproduce the problem on our local installation. The resources are loading properly on incognito mode even when the “aviaCookieSilentConsent” is not added in the local storage. Do you have a staging version of the site, or any other site using Enfold?

    Best regards,
    Ismael

    #1150859

    I’ve have provided a few sites below where I am having the same issues.

    Like I said early, what happens in the correct style headline fonts do not render and the default font displays instead. Once I click the ‘accept cookie bar button’ and hit page refresh the correct styled google font will load.

    #1151724

    Hi,

    Sorry for the delay. In the “gamehunter” site the cookies are not set to be silently accepted on load, so the font doesn’t render properly. The “Lato” font loads fine once we accepted the cookies — same with the other sites. Did you change the settings?

    Best regards,
    Ismael

    #1152285

    on the ‘gamehunter’ site I have it set to ‘All cookies and services are accepted on first page load, user can opt out” I thought that first would allow the fonts to load without user action.

    #1153509

    Am I missing a setting where I can activate ‘silently accepted on load’ or is that the same as ‘All cookies and services are accepted on first page load, user can opt out” ?

    #1154803

    Hi,

    Sorry for the delay. Just got back. Our developers said that it’s a cache issue and is currently looking for a solution.

    Am I missing a setting where I can activate ‘silently accepted on load’ or is that the same as

    That’s what the option is for, but for some reason it doesn’t work in your installation.

    Best regards,
    Ismael

    #1155223

    Thanks for getting back to me Ismael, I’m pretty sure there is some conflict between the theme and wp-rocket caching plugin.

    #1157147

    Hi,

    We found a fix for the cache issue according to our developer. We’ll add it in the next update. There’s a lot of related files that needs updating, so I wouldn’t be able provide you with the modification. You might have to wait for the upcoming version. We’ll close this thread for now. Please don’t hesitate oto open a new thread if any critical issue arise.

    Thank you for your patience.

    Best regards,
    Ismael

Viewing 18 posts - 1 through 18 (of 18 total)
  • The topic ‘Caching Issue’ is closed to new replies.