Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #521206

    I’m trying to create a button using one of the provided shortcodes with a manual link to a self hosted video. When the link in the button points to YouTube or Vimeo everything works fine – the lightbox opens and a video is playing. However when I simply point to a video file (self hosted), the button opens a new page, where the browser takes over and shows the video.

    I’d rather have a behavior similar to when I use a “video” media element shortcode. However it causes the video to be shown in the post, instead of a button with a link to a lightboxed version of the video.

    On top of that, the video player for self hosted videos is missing a fullscreen button.

    Also, I’d like to remove the “hover” action on the feature image when viewing a single post, or to change it’s icon to ue80d and a title to “Watch now” and have the feature image behave the same as the button (open lightbox with self-hosted video).

    Any help with this? Thanks.

    • This topic was modified 4 years, 1 month ago by  maltaannon. Reason: additional information
    #521442

    Hi maltaannon!

    Thank you for using Enfold.

    Please add the iframe=true parameter if you want to open a self hosted video in a lightbox. Something like this:

    http://yoursite.com/wp-content/uploads/2015/10/video.mp4?iframe=true
    

    Remove the hover effect with this:

    .single span.image-overlay.overlay-type-image {
        display: none !important;
    }

    Regards,
    Ismael

    #521460

    While I waited for an answer I figured it out with the ?iframe=true, however this still does not answer my original question in full. When I do that, the self hosted video opens up in a lightbox, but it is being played back by a browser video player, not the one included with the theme (av_video). And if it would, the player would still be missing the fullscreen button.

    As for the feature image maybe I wasn’t precise. By hover actoin I mean not only the overlay, but the entire link. I guess that if the ling would be gone, the hover would not happen as well. So How to I remove the link being added to the feature-image? Please not that I’m using this technique to add feature images: https://kriesi.at/support/topic/inject-feature-image/ On top of that I’ve just added the css you posted to Quick CSS and it did not remove the hover effect.

    By the way… is it possible to open that (inject feature image) thread up again? There are still some things, notes, and additional questions that need to be added there and I don’t want to start a new thread.

    • This reply was modified 4 years, 1 month ago by  maltaannon.
    #522064

    Hey!

    One way to do it would be to create a separate -blank- page and place the video there (using an Enfold video element), then link it to that page instead of the video directly.

    Best regards,
    Josue

    #524454

    For video that is out of the question unfortunately. What of my other questions? The hover effect, the link, and one more: any way to set the size of the lightbox manually for each instance? I mean manual – like adding something to the link to force it to open up in a specific size, which may be different depending on some conditions?

    #524515

    Hi,

    Can you post the link to your website please?

    Regards,
    Josue

    #524534

    I don’t see how the link would help, but I can’t post it anyway. It’s being developed locally.

    #524624

    Hi!

    Ismael code to disable the image overlay should work, if it doesn’t, the only way to debug it would be to inspect the website live. Let us know through this topic when you publish it.

    Cheers!
    Josue

    #524866

    Ok. I understand. The problem might be caused by injecting feature images via functions.php. I wrote a post about it here https://kriesi.at/support/topic/inject-feature-image/. Some problems in there still remain and maybe they are causing this behavior.

    After a while…..

    And I was right. Injecting the feature image as described in the link above apparently changes some styling and Ismaels code doesn’t work, however when the feature image is there to begin with the code works. That also means that the solution that I found to inject images is not a good one (as Yigit claimed it to be) because it does not cause Enfold to “think” the image was already in the DB to begin with.
    That’s problem one.

    Problem two still not answered here is this:

    Also, I’d like to remove the “hover” action on the feature image when viewing a single post, or to change it’s icon to ue80d and a title to “Watch now” and have the feature image behave the same as the button (open lightbox with self-hosted video).

    As you can hopefully see this time, this is not only about removing the hover effect. In fact I would be sort of ok with it being there if I could set the link of the image manually, to a self hosted video or a youtube/vimeo wideo, remove the white overlay, leaving the icon there but changing it to ue80d or whatever else. Or… simply… do not link to anything – if my understanding is correct, if there was no link in the image, there would be no hover, no overlay, no problem.

    • This reply was modified 4 years, 1 month ago by  maltaannon. Reason: link to the post was missing
    #525235

    Hey!

    Can you paste the rendered HTML of the featured image element in single view here?

    Best regards,
    Josue

    #525242

    I believe this is the part you asked for?

    <article class='post-entry post-entry-type-standard post-entry-1323 post-loop-1 post-parity-odd post-entry-last single-big with-slider post-1323 post type-post status-publish format-standard hentry category-after-effects tag-animation tag-particles tag-text tag-articles' itemscope="itemscope" itemtype="https://schema.org/BlogPosting" itemprop="blogPost">
        <div class="big-preview single-big">
            <a href="" title="The Matrix Raining Code"><img src='http://maltaannon.com/wp-content/uploads/tutorials/after-effects/the-matrix-raining-code/preview.jpg' title='The Matrix Raining Code'>
            </a>
        </div>
    #525247

    Yea, try with this CSS code:

    .big-preview a{
    pointer-events: none !important;
    }
    #525250

    Yes! This works. Thank you. Now is there a way to maybe set the link manually? As you see the “a” tag is added automatically. My “inject” filter only adds the “img” tag, but it is wrapped in the “a” to begin with.

    Also… how would I turn of the thumbnail image entirely (in the blog-grid)? I’ve found a post about it but it didn’t help me.
    https://kriesi.at/support/topic/articles-blog-shortcode/

    #525267

    Hi!

    The link is added by this line in includes/loop-index.php:

    if($slider) $slider = '<a href="'.$link.'" title="'.$featured_img_desc.'">'.$slider.'</a>';
    

    Try turning it to:

    if($slider) $slider = $slider;
    

    Cheers!
    Josue

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.