Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #615948

    Hi,

    • I’m using ENFOLD at a multisite installation (WP 4.4.2, ENFOLD 3.5.3).
    • Sub-blogs are installed in sub-directories.
    • ENFOLD is installed and active at the MAIN (!) blog.
    • I disabled all plugins – same problem.
    • I created a fresh WP multisite – same problem.

    On a single post view, the breadcrumbs are right:

    On a category or tag archive, the breadcrumbs show 2x “blog”:

    Category archive:

    Tag archive:

    This happens only on the MAIN blog of a multisite. When ENFOLD is installed at a multisite sub-blog, this problem does not occur!

    Maybe that happens, because the multisite MAIN blog adds an additional “blog” in the URL, as far as I know?
    Here a German explanation for it:
    http://thorstenbreyer.de/weblog/2014/03/28/blog-slug-bei-seiten-im-wordpress-multisite-netzwerk-entfernen/.

    But please note: I have NOT (!) changed this or anything at my permalink structure!

    And here the permalink structure at the superadmin network -> websites (……./wp-admin/network/site-settings.php?id=1)

    And I have also NOT removed something in WP SEO from Yoast:

    Please see demo post in the private content.
    Any idea how to fix this please?
    Thank you.

    —————————————————
    EDIT:

    if you call the blog page NOT “blog”, then the breadcrumbs are working ok at category and tag archives.
    For example, when I re-name the page “blog” to “Artikel”, then the breadcrumbs at category/tag archive show right:

    (“Intern” is a category)

    But I would prefer to call my blog page “blog” and not something else. It really must have something to do with the multisite and “blog” slug as mentioned above, but not: I have NOT changed what is mentioned in this post there!

    Could you please fix this in that way, that on a multisite MAIN blog, I can call my blog page “Blog” and that then at categaory/tag archives the breadcrumbs don’t show me twice “blog” – see screenshots above? Thank you.

    #617220

    Hey Chris!

    Thank you for using Enfold.

    Please check the functions.php file. Do you see any filter called “avia_breadcrumbs_trail”?

    Best regards,
    Ismael

    #617258

    Hi Ismael,

    thanks, but no, I checked the functions.php of ENFOLD 3.5.3 and there is nothing called “avia_breadcrumbs_trail”.
    I downloaded yesterday the newest version of ENFOLD and therefor the functions.php is also the newest one.

    What do I need to do?
    Thanks.

    #618094

    Hey!

    Please post the login details here. We will check the theme settings.

    Cheers!
    Ismael

    #630822

    I am having the same issue and wondering how this was resolved, if it has been. You can see the “blog / blog” here in a post within a video category:

    http://37.60.235.189/~anselada/interview-on-ansel-adams-with-his-son-michael-adams/
    (Best1902 to see it)

    #630827

    It’s not resolved on my end – I’m currently moving to a new hoster, so I had to put this problem on hold, @kaylesimon.
    By the way: your link/post is password protected.

    #631858

    Hi,

    @kaylesimon: Please check if you set the blog and frontpage in the Settings > Reading panel. If yes, reset the settings to default then configure those settings in the theme options instead.

    @chris: Again, please provide the login credentials so that we can check the settings.

    Best regards,
    Ismael

    #898831

    Since I have still the problem, although I am at a new hoster and had installed a fresh WP with ENFOLD 4.2.1 this issue of my first posting here is still a problem.

    If someone runs in the same issue, I solved this with this snippet:
    https://kriesi.at/support/topic/in-breadcrumbs-always-showing-blog/#post-849466

    but changed “single” to “archive”:

    add_filter( 'avia_breadcrumbs_trail', 'avia_breadcrumbs_trail_mod', 50, 2 );
    	function avia_breadcrumbs_trail_mod( $trail, $args ) {
    
    		if ( is_archive() ) {
    			unset($trail[1]);
    		}
    		return $trail;
    	}
    #900230

    Hi,

    Thank you very much for updating the posts an providing that info.

    Best regards,
    Basilis

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.