Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #196806

    Hey there!
    I’ve searched for the past couple days for a solution to these issues, in the forums and off, yet I haven’t found the fix to these problems yet.
    When using the Advanced Layout Editor, I am unable to publish or update a page when I have # = # within my text. For example, “1 inode = 1 file” will result in a “Page Not Found 404″ error when I try to Publish or Update my page. The only work around I’ve been able to figure thus far is to simply reword my text to not include the equals sign, but as you could imagine, this is not a fix and rather annoying. Also, I can’t leave this issue for future authors/editors to run into without a better solution.
    Does prettyPhoto work with pages or posts, or only media elements like images? I’ve created a post that I want to load within the lightbox effect, without it’s header, footer, or sidebar. All of the documentation I’ve found only speaks mostly of images, but I’m looking to load that page on top of the current page, until clicked off. Adding ?iframe=true and &width=725&height=300 to the end of the href url doesn’t do anything. I’ve tried both rel=”lightbox” (Like stated in Enfold Documentation) and rel=”prettyPhoto” (Like stated in prettyPhoto Documentation), and still nothing.
    I’ve noticed the Advanced Layout Builder strips out any <p> tags that don’t have anything assigned to it. A simple <p> tag will be stripped from the code when editing blocks of text, but will be re-inserted when I view the page/post. I want this feature turned off, so that the HTML tags I put in stay there, and I don’t have to guess at what will be outputted as a <p> or a <br>.

    Thank you for your support, and I look forward to hearing your responses soon!

    • This topic was modified 10 years, 6 months ago by certifiedhost.

    Hi certifiedhost!

    1) Can you please create us an admin account and post the login data as private reply. I can’t reproduce the = issue on my test servers.

    2) You can use the iframe function of prettyphoto but it won’t strip the header, footer, etc. If you just want to show a simply text I’d use the “inline text” feature of prettyphoto like demonstrated here: – basically you just need to create a div with an id and then create a link which points to the id and add rel=”prettyPhoto” to the link. Another solution would be to use the iframe function of prettyphto which points to an external html document

    3) Yes, this is a standard wordpress function wpautop() which removes unnecessary tags. You if you just want to add an empty paragraph use


    instead of


    Best regards,

    This reply has been marked as private.


    I couldn’t find the reason why the = doesn’t work on your server. I guess it might have something to do with the server configuration (php.ini or htaccess file) because I can’t reproduce the issue on my test server ( ) and your server blocks me when I try to update/publish a post with a = symbol (equal sign) in it and I must reconnect to access your server with a new ip address. Maybe try to deactivate all firewalls and security layers and upload a clean htaccess file and check if this solves the issue. I’ll mark this post for Kriesi – maybe he stumbled over this issue in the past and knows what’s going on.

    Best regards,


    Thank you for taking a look at the site, I passed your server suggestions down to our tech support, and the # = # issue seems to be resolved for now. Lets hope it doesn’t pop back up later down the road xD!
    I’m stuck with the prettyPhoto issue still. I am using a stand-alone html file that simply has the code (features chart) I need to display. I’m doing it this way rather than inline text, because there is a good chance I will have to create this same button on several pages. I’ve been working on the iframe and AJAX solutions, with no luck. I’ve tried everything suggested in both Enfold’s documentation and prettyPhoto’s documentation. How can I check to see if prettyPhoto is active or possibly broken? Oh and is the ‘rel’ tag supposed to be rel=”prettyPhoto” or rel=”lightbox” (I’ve tried both)??

    Enfold Documentation states:
    Lightbox: a custom pretty photo skin
    the lightbox gets automatically applied to links that contain images, youtube videos, vimeo videos, mov files and swf files. if you don’t want to activate the lightbox on any of those links add the class ‘noLightbox’. if you manually want to apply the lightbox to a link you can add the rel=’lightbox’ attribute to the tag.

    I’ve also taken the code directly from the prettyPhoto Website’s examples, which the description will state to add rel=”prettyPhoto” but then the example code shows rel=”prettyPhoto[iframes]”, so which is it?! Lol, I appreciate your time and help with this issue. Hopefully this is just an easy and simple fix.



    This is an example of the code for opening an html or a website on lightbox:

    <a href="" rel="prettyPhoto">Open This Topic on a Lightbox</a>

    Open This Topic on a Lightbox

    Add the “?iframe=true” at the end of the url. Don’t forget the rel=”prettyPhoto” attribute.



    I should have asked this from the begining, is prettyPhoto baked into the theme, or do I need to download the WordPress prettyPhoto plugin for this to work??
    if it is then well…
    This is what I have:
    <a href="/wp-content/themes/nakedhosting/html/webHostingFeatures.html?iframe=true&width=325&height=185" rel="prettyPhoto"> View All Features</a>
    And no good, simply loads the page. Is there any chance that I may have turned prettyPhoto off, or broke it, and if so, how can I turn it back on or check for errors?
    I have tried changing the url to the full url, used different rel properties, and anything else I can think of. I honestly think that it isn’t working because it isn’t loading in the prettyPhoto plugin, but from what I understand in the Enfold Documentation, prettyPhoto comes built into the theme. Thank you for your time.

    • This reply was modified 10 years, 6 months ago by certifiedhost.
    This reply has been marked as private.

    Yeah, I might not have been very clear earlier, but I’ve tried using an absolute url, and I’ve tried everything I can think of with the url. I’ve tried http:// and https:// and // and with the www. and without the www. and /wp-content/… And honestly, I don’t want to use the full url, because the site being built on a dev sub-domain, so using full url on anything will break once moved out of the sub-domain. I’ve also tried rel=”prettyPhoto” , rel=”prettyPhoto[iframe]”, rel=”lightbox”, rel=”lightbox[iframe]” and so on… I honestly don’t think I’m doing the code wrong.
    Where in the folder hierarchy can I find the prettyPhoto jQuery Plug-In? Where does the code get called into the site?. How can I test if it is working at all?
    Thank you :).

    • This reply was modified 10 years, 6 months ago by certifiedhost.


    No, prettyPhoto not working from the looks of it. It could be a plugin that is causing a conflict or if you’ve modified the avia.js file it could have gotten deactivated in the script directly. The css and js file for prettyPhoto are getting loaded in to your page but they are just not having any effect.

    I created test page as a draft to check.

    Best regards,


    I haven’t made any changes to the avia.js file, and I’m working with a child-theme to limit modifications made to the theme. I have edited config-templatebuilder/avia-shortcodes/textblock.php and config-templatebuilder/config/meta.php slightly to include my custom post types. I’ve also disabled all of my plug-ins and tested with no luck. I honestly cant think of anything else to get this working. Is Enfold compatible with other lightbox plug-ins? Thank you.



    I tested this on Enfold Child Theme and it works just fine. I tried it on your end but it’s not working. We don’t want to mess with your plugin settings. Please deactivate all plugins then test it again.



    So it’s not the child theme. It doesn’t seem to be a plugin either, because I’ve tested it twice today with all plugins deactivated. Is there a chance that it could be a server related issue that doesn’t allow the jQuery to pull the rel=”” information and use it?
    I’ve decided for the mean time to download and incorporate a different lightbox plugin, although I would much prefer having prettyPhoto working, so that there aren’t two of the same plugins running on the site at once. If you think of anything else that I can try or test, I am all ears! :D
    Thank you.


    Is it possible for me to remove prettyPhoto from the Enfold Theme without destroying the theme? If so, how do I go about doing so? Thank you. :D



    Please refer to Ismael’s post here

    Best regards,

Viewing 15 posts - 1 through 15 (of 15 total)
  • The topic ‘Broken : Post publish/update, prettyPhoto w/ pages, and ALE stripping code.’ is closed to new replies.