Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #1388021

    Hi Enfold team,
    I have a strange issue. In the breadcrumbs container I see 2 backslashes after “Home” link. I see it only in Single product pages. For example in the Cart or Checkout page there it is ok.
    See a screenshot here:

    Can you pls have a look, where the issue can be?
    I put the credentials in the Private Content.

    Thank a lot!


    Hey Zdeněk,
    Thanks for the link to your site this is because one of your breadcrumbs is empty but I not sure what is causing this, I see you have customized woocommerce files and productslider and you have jQuery errors in the browser console and you are using Yoast which may be changing the breadcrumbs.
    JQuery errors often have a cascading effect, so first try disabling your custom sticky function.
    Then try switching to the parent theme so the child theme custom files are not used.
    Then try disabling your plugins.
    One of these steps should identify the cause.
    If not or if the cause is something that you can not change you could use this css to hide the extra backslash since it only occurs on product pages.

    #top.single-product #main > div.title_container > div > div > div > span:nth-child(5) {
    	display: none;

    Please ensure to copy the code from the forum and not an email notification so the symbols are not converted.
    After applying the css, please clear your browser cache and check.

    Best regards,


    Hi Mike,
    thank you for your fast response!

    I did the steps you are recommending:
    1. disable the sticky function and all the other functions in the funciton.php
    2. switch to Enfold parent
    3. disable all the plugins except woocommerce

    Unfortunately it did not help.

    I know that the sticky function causes an issue in the console, but I don´t know why. I use this solution: several years and in the past there were no issues. It arrived with some WordPress or Enfold update, but I don´t know when exactly. Or do you think it can cause used jQuery? I use this solution becase I didn´t find any better (I have tryied everything including some plugins).

    Maybe you will advice me a better solution?
    I am writting about it because I know that the issue with the breadcrumbs doesn´t cause any function or plugin.

    I exactly know how it happened.
    Recently I (re)build my eshop „from beginning“ (clean wordpress installation etc.) … and I have noticed, that the breadcrumbs are displayd in the strange order: Home / „Name of my website“ / Category / Page. The strange thing is the „Name of my website“ which I never had it there before. And it was linked to the same page as „Home“ => to homepage.

    At the same time I (re)built other my website (not eshop, but presentation web using Portfolio items)… and there was the same issue on portfolio pages. What I did was, that I create a new homepage (new name, new ulr) and set it as homepage in the WordPress settings and also in the Enfold settings. And it helped! The „Name of my website“ disappeared from the breadcrumbs.

    So I expect the same behavior in the eshop installation and I did it the same way. But in the eshop we see the 2 backslashes and empty space between.
    The only defference I see is that the eshop is using woocommerce with product pages. I don´t know, I am not wordpress expert, that´s just what I observed.

    Maybe it can help you to find the real issue?

    If not I am ok because it is working correctly and I can just hide the backslash with your css code => the cs sis working, thank you!

    Waiting for your answer.
    Thanks a lot!


    Thanks for the feedback and for explaining the odd behavior with the breadcrumbs. I have not seen this before and it sounds like something with the permalinks, but that should affect all pages. I tried resaving them and setting the default values but it didn’t help, I then put everything back to the way you had it.
    I have asked the rest of the team for ideas and will write back when I hear from them, thank you for your patience.

    Best regards,




    Hi Mike,
    if the Enfold team will test the issue, I prepared for this case a test environment. You can test there whatever you want :)
    Credentials in the Private Content.



    Thank you for creating the test site.

    Best regards,


    Hi Mike,
    I am building a new blog web (another subdomain) and I have there almost the same issue as I described above.
    See the screenshot:

    Maybe it will help the Enfold team to find the issue. If not, can you give me a css code to hide the breadcrumb after “home”?

    If you would like to look at the back-end, the Credentials in the Private Content.


    on tribe-events we got a little bug with breadcrumbs and double slashes – is there a similar behavior on woocommerce ?


    Hi Guenni,
    yes, I have the same problem on my woocommerce web as I described above.


    thanks for the link to your new blog site, I see the breadcrumb error on your post there:
    When I switch to the parent theme this is resolved:
    Give this a try, I was not able to isolate the function in your child theme functions.php causing this, perhaps you have other customizations that I’m not aware of?

    Best regards,


    Hi Mike,
    thank you for your response! I have finaly found out where the “issue” is! But just with the blog web, not with the woocommerce web.

    You are right that with the parent theme it is displayed right.
    So I removed everything what is customized (php, css, jQuery with sticky function…) in the child theme. Nothing happened, the breadcrums were still displayed wrong.

    So I started thinking that it must be somewhere in the child theme settings. And I was right :)

    The issue comes when you don´t have set up a page for the blog in the child theme; Theme options => Where do you want to display the blog
    If I set up to any page, the issue disappeared.
    I have tryied to do the same in my woocommerce web (that´s why I have started this thread), but this solution is not working there. But maybe it gives you a way, where the issue is comming from.



    I’m Glad to hear that you have this sorted out with the bog breadcrumbs, with this in mind I logged into your test site to check the empty breadcrumb issue with woocommerce products and I found that in the woocommerce settings woocommerce ▸ products ▸ Shop page no page has been set
    I selected your e-shop page and now the breadcrumbs are correct.
    I also checked my demo site for our shop demo, and it also has a shop page selected, so this seems to be the solution.
    Please adjust to suit, then clear your browser cache and check.

    Best regards,


    Hi Mike,
    yes, that´s it! I can´t believe I forgot about such a simple thing :)

    Thanks a lot for your help and you can close this threat.



    Glad we were able to help, if you have any further questions please create a new thread and we will gladly try to help you. Thank you for using Enfold.

    Best regards,

Viewing 15 posts - 1 through 15 (of 15 total)
  • The topic ‘Breadcrumbs – 2 backslashes after "Home"’ is closed to new replies.