Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1217317

    with posts it works – but with portfolio not

    the image shows you that there are entries!

    see here: https://webers-testseite.de/blog-posts-in-list-view/

    this is layout:

    #1217319

    Please excuse the storm in a teacup, but it seems to be only on my mega-site.
    With more than 3000 lines of child-theme functions.php something else might be disturbing.
    I am looking for – on another test page it runs!


    BUT
    i now deleted all entries in child-theme functions.php – deactivated all plugins – cleared all cache and switched off merging – but it is still on that page the issue.
    The only thing now – i do upload via ftp again all files – maybe there is gone something wrong on first upload.

    EDIT: I’m desperate. See page now : left side List Compact View – right side Grid-view.
    Both the same ( Webdesign Taxonomie – view all – offset deactivated etc. pp )
    the compact view only show two portfolios .

    #1217354

    My assumptions:

    on the compact list of blog posts : only one entry of the older Portfolio Entries is shown + the newly added – and you see on the testpage above the readmore link is wrong! The link of the title is ok!
    See DOM : the new entry got on articles a class: portfolio_entries-webdesign
    the other from the older Portfolios Not

    Every newly made Portfolio is shown in that compact list view!

    The page where it works as it should ( https://webers-testseite.de/pureinstall/portfolio-list/ ) has never had an Enfold Version older than 4.7.4 !

    i tried to repair / optimize Database of the older installations – but it does not show any effect.
    I tried to open the older portfolios and save them again. But no influence.

    I always update via ftp and a full upload of the new enfold. so there are no remnants of the old Enfold versions.

    • This reply was modified 2 months, 1 week ago by  Guenni007.
    #1222101

    Hi,

    Sorry for the late response. Is “webdesign” a new category for the portfolio items? Looks like the term is not returned by the get_post_class function in the includes > loop-index.php file, but I’m not really sure why.

    Best regards,
    Ismael

    #1223885

    Not instead portfolio – Webdesign is just one “Portfolio Category”

    and as i said above All new added portfolios in that category are shown even on the list style directly. But the old one – only one –
    and that one what is shown – has a wrong link on read-more button.

    So the bug is on older existing posts from far away ( no backward compatibility ) in the list style. The grid-style shows all post on that category. And the bad thing is even that I can’t fix it by recalling these posts and saving them again.

    you can see here that the masonry or grid view shows all 8 entries – but the list not ! https://webers-testseite.de/blog-posts-in-list-view/

    #1224516

    Hi,

    Have you tried repairing or optimizing the database? Maybe that will help repair the portfolio items and the categories? It is kind of difficult to reproduce the issue on our end, or recreate the environment in which those items are created.

    Best regards,
    Ismael

    #1224701

    Well, it would be easy to see if this is the case if my guess is correct, for example by updating Enfold 2017 from version 4.4 to the current Enfold version and seeing how the list view of the blogs looks like.
    I have just repaired and optimized the databases on the server side, without success.

    In fact, I would argue that this should become a standard procedure for you before you release a new version.

    What I tried now: Export of the portfolios – complete deletion within the WordPress Dashboard – import with WordPress Importer. – It remains so that these old portfolios do not appear in the list view.
    The one older portfolio that appears in the list view, but has a wrong link in the read more link, is the first one after the new created portfolios.

    #1226323

    Hi,

    Can we have access to the dashboard and the file server? We would like to check the issue.

    What do you get when you check the global $posts variable in the loop-index.php file?

    Best regards,
    Ismael

    #1227322

    Ok

    I set the page to “under construction”

    #1228211

    Hi,

    Thank you for the update.

    We exported the portfolio items and imported it to our own installation, then use the compact blog layout. This time all items displayed without issue, so it’s probably not an issue with the Blog Posts element. Unfortunately, we are still not sure why it doesn’t work in your installation.

    Best regards,
    Ismael

    #1228372

    Thanks –
    I already did this – and also reimport them.

    now I have taken an even more drastic action:
    I exported the portfolios all to another test platform, then deleted them all, emptied the trash can, logged in to mysql and cleaned the database.
    Also deleted all portfolio “categories”.
    Reset the permalinks (same settings, but I wanted to make sure that the portfolio permalink structure didn’t play a role here). Then I played back the portfolios. Now it works.
    Still it remains a mystery to me why only in the list view the portfolios were displayed incompletely and incorrect – and the other views were all displayed correctly.

    Of course I had changed the names of the portfolios for some inquiries here on board. The Custom Post Type once set to Books ( you may remember ) and back again. But why it only went wrong with the list views I don’t understand.

    Anyway: can be regarded as done.

    #1229582

    Hi,

    Glad you could fix it.

    Have a nice weekend.

    Best regards,
    Günter

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Blog Posts ALB with Portfolio – do not work as expected’ is closed to new replies.