Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #472977

    Hello,

    I’ve got a site: http://www.bemorail.nl
    This is the main site with the main language.

    There is a english version on http://www.bemorail.com
    I use WPML to translate. Almost everything works fine, but the blog page won’t translate correctly.

    Example:
    The news page (with the blog posts) is present on http://www.bemorail.nl/nieuws/
    When I hit the English flag in the menu on this page to go to the English version of the blog page, it goes to the homepage.
    It should go to http://www.bemorail.com/news/
    Can you tell me why this is happening?

    Greets Jeen

    #473647

    Hi Groeier!!

    Thank you for using Enfold.

    That is the default behavior of the language switcher. Try to go to the english version of the blog page then hit the flag. It will go to the main language home page. http://www.bemorail.com/news/

    Regards,
    Ismael

    #475279

    Hello Ismael,

    I don’t understand… If I go to lets say contact:
    http://www.bemorail.nl/contact/ and I hit the flag, then everything works great, because it goes to the english version of contact:
    http://www.bemorail.com/contact/

    So I would think that if I go to the news page and I hit the flag, that it goes to the translated version of the newspage?
    That should be the standard behavior right?

    Greets Jeen

    #476383

    Hey!

    you are using quite an old version of the theme. Please upgrade to Enfold v3.2.3. and make sure to use newest WPML version as well.

    Cheers!
    Andy

    #483210

    Hello Andy,

    It took a while, because like you said: the enfold version was quite old. It took some time to update everything.

    I’ve updated the theme, the WPML plugin had already the latest version.

    The problem is still present. Can you explain how I can solve this?

    Greets Jeen

    #483771

    So what’s your answer guys? I have the same issue.

    #485718

    Hey!

    Try the following:
    1. In Blog Settings, select this option – http://imgur.com/P6QkPdR
    2. Go to the Blog Page and edit it like any other Page, drag an ALB Blog element to mimic the Blog grid.
    3. Duplicate or do the same for the other language version of the Page.

    Best regards,
    Josue

    #485795

    Hello Josue,

    Thanks for the answer! Works perfectly!!

    Greets Jeen

    #485811

    Hey!

    glad Josue could help you. Let us know in a new ticket if you have some more questions or issues related to the theme. We are happy to assist.

    Best regards,
    Andy

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Blog page won't translate’ is closed to new replies.