Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #162315

    Hi everybody,
    I’m struggling with the blog to be shown on the pages of my choice (I adjusted the theme options settings separately for all languages). It’s shown in english (i.e. my original and admin language) but it does not show the posts in the two other languages. I translated the categories and setup widgets that filter the posts according to the selected language using the plugin “widget logic”. But where is my blog? :-)
    Page:, guest, guest
    Thanks a lot!



    You need to configure both languages. You need to switch to the other language then set the blog on Enfold > Theme Options > And where do you want to display the Blog? option.



    Good morning Ismael,
    Actually, I tried this and it’s set to News (en), News (de) and Actualités (fr) respectively. But still, it does only show up in the original language. It works for the “latest news” plugin, where I filter by category and therefore only select the translated blog entries. Do I have to configure something similar with the blogs main page?


    Hi Chris,

    I’ve tagged the topic for the head of support and Kriesi as I’m not overly familiar with the specific ins and outs of wpml but hopefully they will be able to shed some additional light on your issue.





    Please create me a wordpress admin account and send me the login data to: (Email address hidden if logged out) – I’ll look into it.




    I fixed it on your server. I’m not sure why the blog page doesn’t work in your case (I can’t reproduce the issue on my test servers) but I found a simple fix.

    Best regards,

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Blog (original: en) does not show in second (de) and third (fr) language’ is closed to new replies.