Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #1270714

    Some of the features for the blog are not showing up.

  • Sidebar blog is not showing up on blog page “Pet Store”. I’ve made the settings in the Theme options, on the Pet Store page, and created the widget. Still, no sidebar.
  • There is no way to leave a comment or share the post. I’ve chosen options for comments in Settings > Discussion and allowed comments on the Pet Store page and in the settings for the first post. Still, no way to add comments or share.

Hey phausner,

Thank you for the inquiry.

1.) We cannot find the “Pet Store” page anywhere in the site. Do you mean “Pet Care”? If you click on the Pet Care menu item, you are actually redirected to the Pet Care category page instead of the actual Pet Care page. This happens because the page and the category have the same name and slug, and when that is the case, WP automatically prioritize the archive page. You may need to rename the Pet Care page or change the slug of the Pet Care category.

And the reason the sidebar is not displaying on that page is because the sidebar for archive pages is disabled in the Enfold > Sidebar Settings. (see private field)

2.) The comments area is displaying properly when we checked one of the posts in the Pet Care archive page. (see private field)

Best regards,


Hi, Ismael. I appreciate your help. I’ve changed the “Pet Care” page name to Animal Care so it wouldn’t conflict. Thanks…I should have caught that.

I still do not see the comments area anywhere. There is only one post for the blog; it is in the Pet Care category. But it doesn’t matter whether I view that post from the blog page (now called Animal Care), or the post page, or the archive page. Here is a screen shot of what I see: That view is from the post page in the archive.

One other thing I’ve noticed, now that the sidebar is showing up is an issue with the Share button in the Facebook widget. You can see the message here:

Thanks so much for your help. I don’t know what I’d do without you.



Thank you for the update.

That view is from the post page in the archive.

1.) The comments area will only display in the actual post page. Are you expecting it to display in the archive page as well? (see private field)

2.) According to an article, this is a permission issue or it is possible that the Facebook app or page is not yet live and not yet public. To fix it, you may need to toggle the page’s visibility status. Have you tried that?

Best regards,


1. Thank you for your patience in explaining that the comments area only shows up in the actual post page. Is there some way to have it show up on the archive page as well?

2. The Facebook page for this business has been live and active since 2013. Since the error message said to see the “app administrator”, I thought that would be you since it’s the “Enfold Child Facebook Likebox” widget. Should I just remove it from the sidebar if it doesn’t work?



1.) Unfortunately, this is not possible and we do not know of any plugins that enables this functionality. You may need to look for a custom solution from a third party developer or contact our partner, Codeable.

2.) We are not really sure what causes that error but it looks like it is not something that we could control on our end. Have you tried setting the widget’s Link to facebook settings to the third option (Only open facebook page – no data is sent)? You have to provide a banner image as preview if this option is enabled.

Best regards,

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.