Viewing 25 posts - 1 through 25 (of 25 total)
  • Author
    Posts
  • #724210

    The featured images for the blog posts are not appearing.
    Is there any reason for this? how to remedy?

    We are using the Advanced Layout Builder

    Thanks!

    Dara

    #724604

    Hi Dara!

    Can you please create a temporary admin login and post it here privately?
    Also, the site you posted cannot be found. Typo i guess? :)

    Best regards,
    Yigit

    #724968

    Here is the requested info.
    Website is up again….thanks!

    Dara

    #725213

    Hi Dara,

    There is an .htaccess password prompt before being able to access the login page, could you post those details as well please?

    Best regards,
    Rikard

    #726626

    Dear Rikard,
    There was no problem when we tried with the above information on two different computers with 2 different users using the password for Yigit.
    also loging in with different users.

    Thanks for trying again!

    Best wishes and thanks.
    Dara

    #726632

    Hey Dara!

    You should add your featured image manually using Image element to your posts when creating your posts with ALB. The same goes for Comments and Social Share Buttons elements as well :)

    Best regards,
    Yigit

    #726705

    hmm……..
    what about on the main blog, category and post pages?

    : )
    as usual
    thanks
    Dara

    #727799

    Hey!

    The featured image will still display on the blog overview and the archive or category pages. However, in the single post page built with the advance layout builder, you have to add the image manually.

    Cheers!
    Ismael

    #728619

    HI guys,

    I have exactly the same type of problem. Feature images does not show up in single post view.

    When using another theme, they do show up. When working with Enfold in default editor they are fine too. Once switched to ALB, they are gone.

    >You should add your featured image manually using Image element to your posts when creating your posts with ALB.

    I would like the image to have the same size as in preview. If I add it as a separate element, it shows in it’s original size. As I have images of different sizes single blog post views will not look consistent.

    What I really want to reproduce is this (the reason I purchased the theme): http://kriesi.at/themes/enfold/2014/04/28/new-electric-cars-are-getting-really-fast/

    I have looked at most default demos (switching to them and reseting back to empty content). Featured images are used everywhere (they are not manually added as separate image elements). Once I enable ALB in any of the posts, the images are gone from singe post view.

    #728671

    Hi John,

    That is an expected behavior of Advanced Layout Builder, once it is enabled on posts or other post types it will allow the user to have full control over the elements and whatever you add using ALB that will be exactly what you will have on the page (post or other post types), which also means that the default layout for posts won’t work (the one with featured image, dates, comments, etc). If you want to make it look like this: http://kriesi.at/themes/enfold/2014/04/28/new-electric-cars-are-getting-really-fast/ we would recommend not using ALB for posts, you can still use shortcodes on posts.

    Best regards,
    Nikko

    #728714

    Hi Nikko,

    Ok. Got it. A bit unexpected but I am sure I can live with it. Thanks for the note.

    #728773

    Hi,

    You’re very much welcome :)

    Best regards,
    Nikko

    #741751

    how can we use shortcode
    and WHAT IS THE SHORTCODE
    so that the FEATURED IMAGE appears both in the:
    POST

    and in the
    CATEGORY
    TAG
    pages

    ?

    using ALB of course

    Thanks
    : )

    NOTE:
    PLEASE LET USERS UNDERSTAND THAT USING ALB IN POSTS involves alot of unnecessary work
    UNLESS OF COURSE they understand how to adapt with java.

    #742239

    Hi @daraemerson,

    You should be able to achieve that if you save the posts in question when the default editor is active.

    Best regards,
    Rikard

    #743884

    so…..
    is not the default editor always active?

    if not how to make the default editor active and save the featured image so it shows?

    thanks

    (perhaps for you this is self-evident, but for me a conundrum.)

    #744196

    Hi,

    If you use the theme Layout Builder when you create your posts you will have to add all content to the post manually and the featured image will not show unless you save while the default editor is active. If you only use the default editor then your featured image should show without you having to switch editors.

    Best regards,
    Rikard

    #748057

    so….
    Do we have to SWITCH ALL CONTENT from the layout builder to the default editor? (!!!!)

    or….
    do we go to Enfold Child Theme Options: Blog Layout and switch to “default blog layout”
    and then go into each post and insert the featured image
    and then save the post.
    and then go back and switch back to: “use advanced layout builder to build”?

    and if this is the case…….. (?)
    will all the posts created in the layout builder then disappear ???

    if neither thanks for explaining step by step
    : )
    appreciated of course!

    #748244

    Hi,

    The simplest way would be to add the featured image manually to the location you want it in using and Image element from the builder, if you want to keep on using the Builder for your posts.

    Best regards,
    Rikard

    #748292

    Well……
    Before we realised how complicated using the the layout builder is with posts we already had all the information in the blog part of the website

    Adding the featured image on the actual post is no problem.
    HOWEVER….
    Adding the featured image so it shows on the main BLOG/CATEGORY/TAG pages is something else.
    this is what we want to know how to do.

    Is this at all possible?
    THANKS we need to solve this one issue
    Best regards,
    Dara

    (AGAIN: there should be a very clear notification concerning the complications involving the use of ALB in Posts. The way it is presented is that it is a great advantage in Enfold. For someone who understands PHP great! but NOT for your CSS/HTML only designers.)

    #750349

    Hi!

    Adding the featured image so it shows on the main BLOG/CATEGORY/TAG pages is something else.
    this is what we want to know how to do.
    Is this at all possible?

    Yes, just edit the posts then add a featured image. The featured images are not going to display in the single post page because you’re using the advance layout builder but the category or tag pages can still use it.

    The way it is presented is that it is a great advantage in Enfold. For someone who understands PHP great! but NOT for your CSS/HTML only designers.)

    I don’t think that’s true at all. I think you’re just confuse on how it works right now. If you switch to the advance layout builder, it’s going to use another template called “template-builder.php” and it is basically a blank canvas until you add more builder elements in it. The default editor is using the single.php and the loop-index.php file which is what you’re used to. It contains the default elements such as the featured image, post meta info, the content and so on and so forth. And the post template files have a default layout which is not controllable unless you’re familar with PHP so I think the advance layout builder is really advantageous for users who are not familiar with the language.

    Best regards,
    Ismael

    #750351

    Hi,

    To summarize that this is how it works:
    Blog/Category/Tag – uses featured image.
    Single Blog Post (using Default Editor) – uses featured image.
    Single Blog Post (using Advanced Layout Builder) – does not display featured image.

    Best regards,
    Nikko

    #1247828

    We are 3 years later. Is there shortcode (or multiple) available to display the featured image, title and categories just like a default blog post (created with the default editor)?

    Thanks, D

    • This reply was modified 6 months, 3 weeks ago by  DimitriMTM.
    #1247868

    Hi DimitriMTM,

    Yes, for the featured image there’s the Image element, for title there’s Special Heading and for the categories, just use Widget Area so it uses those widgets assigned.
    I hope that helps.

    Best regards,
    Nikko

    #1247906

    Nikko,

    Thanks for your feedback. This indeed gives what you need but still requires 3 manual steps.
    A quick shortcode giving the same layout (the image header & categories AND also the standard footer info like tags and share buttons) as with the default editor, would have been nice. Perhaps something for the feature request list?

    Thanks, D

    • This reply was modified 6 months, 3 weeks ago by  DimitriMTM.
    #1248023

    Hi DimitriMTM,

    Yes, it does take manual steps then create a template out of them to use for other posts.
    Otherwise, it’s better to use the default editor then maybe use the Magic Wand Tool if you only need few elements from the Advanced Page Builder.

    Best regards,
    Nikko

Viewing 25 posts - 1 through 25 (of 25 total)

You must be logged in to reply to this topic.