Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #787461

    I am setting up bbpress forums using a root page and the [bbp-forum-index] shortcode and the index automatically adopts the styling of my webside except for the title of the first forum in the index. For some reason the link styling, active styling and hover styling are all different but only for the first forum in the index. If I rotate other forums to the top, they inherit the styling problem. I am hoping there is a quick CSS edit that can overcome this issue. Thank you!

    #787713

    Hey 1raddad,

    Here is the css that you can put in your child theme style.css

    
    #bbp-forum-2365 li a {
        background-color: #88bbc8;
        color: #444444 !important;
    }
    
    #bbp-forum-2365 li a:hover {
        color: #c05f5f !important;
        background-color: initial !important;
    }
    

    The code that gets applied and breaks the styles is in /dynamic_avia/enfold_child_theme.css which is generated fro all the settings you make in theme settings and quick css, you might want to check for it and see if you can adjust it there, making it more specific, targeting more explicitly the selector, not allowing it to apply to other elements.

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #788069

    Thank you Victoria! It partially worked. The first snippet effectively changes the link color as desired, however the hover color does not change appropriately. The css looks correct to me, and I tried several iterations all to no avail. Is there something else I can do to change the hover color of that one link?

    #789113

    Hi 1raddad,

    The code that overrides the hover is in Quick css somewhere. It looks like this:

    
    #top ul:first-child > li > a:hover {
        color: #88bbc8!important;
        background: #ffffff;
    }
    

    You can find it and change it, or just remove !important.

    Best regards,
    Victoria

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.