Viewing 26 posts - 1 through 26 (of 26 total)
  • Author
    Posts
  • #782205

    Hi there, I am having issues with Avia layout builder since the wordpress update last week.
    Steps I have taken:
    1) Check and increase memory size allotted to processes.
    2) Upgrade PHP to 7.+
    3) Backed up and restored the theme.
    4) Re-installed wordpress.
    5) Checked all plugins by deactivating all at once, and one by one activating them again.

    The problem persists… Really not sure what to do anymore, but the avia layout builder won’t load. I also had a similar problem with layerslider, but re-installing it and buying a license for it worked for that fix.

    Thanks in advance

    #782211

    From your other thread (popup) one could assume you tried some custom code and put it in the functions.php of your parent theme (never do that, always use a child theme) which would get restored in step 3 of your list. Did you try to reinstall enfold from scratch? (fresh download, delete old endlof folder and transfer the fresh ones via ftp)

    #782640

    Hi,

    Please send us a temporary admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply. Also please point out how we can reproduce the error and where.

    Best regards,
    Rikard

    #791801

    In the Pages section of the Enfold theme, when editing or creating a new Page the Avia Layout Builder Toolbar/Dashboard has disappeared. I don’t know why or how to rectify this.

    The only custom code added to Functions.php was to increase the amount of product variations allowed in Woocommerce (this was a fix provided by the Kriesi site which we have used successfully from the beginning)

    the error need not be reproduced – it is always there. The Avia Layout Builder was only used in the Pages and Portfolio sections of the Enfold theme but the Dashboard/Toolbar is no longer there so now I am unable to ADD new sections to these pages. I can only partly amend/update content that is already there.

    I do not use the Avia Layout builder in Posts created.

    #791830

    amended login details…..

    #792069

    Hi,

    Could you please try to overwrite the theme files with a fresh copy from your Themeforest account via FTP to see if that helps? http://kriesi.at/documentation/enfold/updating-your-theme-files/

    If that doesn’t help then please try deactivating all plugins to see if one of them is causing a conflict.

    Best regards,
    Rikard

    #792215

    Hello Rikard

    I have overwritten Enfold theme files via FTP and then i have also deactivated all plugins.
    I still sit with the same problem – no Avia Layout Builder Toolbar/Dashboard on Pages and Portfolio items – so i am unable to add to current pages or create new ones with Avia

    Please assist.
    Cheers

    #792478

    Hi,

    I think the issue is located to your problem with SSL
    Can you try fix that, so we can be able to help you out?

    Thank you

    Best regards,
    Basilis

    #792491

    What problem are you picking up? My SSL appears to be working fine on my side. See report:

    • This reply was modified 6 months, 1 week ago by  PeterSocialiq.
    #792492

    The Avia Layout Builder was working perfectly before with my SSL enabled as it is now. I have made no changes.

    #792937

    Hi PeterSocialiq,

    There are errors of various causes on in Javascript. Looks like WordPress update was unable to overwrite some of it files, then an access rights error for images and cache.
    You might want to look into those. Screenshot in private.

    Best regards,
    Victoria

    #797448

    Hi again, so last week I went through everything.
    The issues you are showing (@Victoria), are not showing up in my browser upon inspection with exception of the maps api from google.
    I thought it possible that somewhere something went iffy, so I re-installed everything, wordpress, enfold, all my files, plugins (One by one) etc.
    The problem persists. I removed the SSL certificate entirely, that didn’t work, then I disabled all of my security, that also hasn’t shown results.

    PHP is set up at the right version, server is running fine, everything is just hunky dorey except this bleddy layout builder.
    Is there perhaps another thread somewhere that you guys know of I can go to help for? Anyone else had this issue before?

    #797449

    @PeterSocialip chances are your php memory limit is to low. Try to raise it to at least 128MB

    #797450

    @mensmaximus, PHP memory limit is set at 128 or 256 due to a store on the site requiring a ton of memory.

    #797451

    @mensmaximus, literally everything else works. it’s just the layout builder that simply doesn’t display at all. No elements, no buttons to transition into the editor, nada.

    #797452

    What does the server error log say?

    #797460

    @mensmaximus,
    No 500’s, 400’s, 401’s,403’s (Or anything else showing up in the error log for this site) in the last month with exception of a few images etc. that we changed).
    There is one 404 not related to the builder that has come through this morning.

    #797465

    Those are messages from the access log not the error log. If the builder cant load for what reason ever this reason must show up in the php error log. My strong guess is one of the essential php variables is to low like memory_limit or max_input_vars. Anyway this is not an Enfold issue as you already know from your other sites.

    #797478

    The file I am getting that information from is literally called ‘Error log’ in my cpanel.
    Not a memory issue: “define(‘WP_MEMORY_LIMIT’, ‘256M’);”
    Not a vars issue: “max_input_vars = 5000”

    As I said, nothing has been changed on this site with exception of adding some content every now and then. The WordPress update happened last month and I think the enfold update, and now nothing works. The servers settings are fine, I am running the same settings and configurations for other websites using the same theme and not having any issue.

    #797481

    Well, when I say nothing, I specifically mean “Nothing of the avia editor”.

    #797489

    Hire an expert to troubleshoot the issue from ground. As you say yourself it is not an Enfold issue.

    #797496

    Hi @mensmaximus, thank you for your assistance. I have no where stated or jumped to the conclusion that this is not an Enfold theme issue (Otherwise I would not be on this forum..). I have no idea what the issue is. Considering that I have done nothing to the server for 3 months, and changed no configuration/core files in this time either, I would only assume that the problem is happening post-wp update, this is most likely then an issue with the theme and not the server.

    I will wait to see if the guys here at Enfold are able to assist me any further with the issue (Considering it’s a paid service to receive their support it seems a waste not to use it), and failing their advice/insight I will simply switch to another theme that I have a spare license for and I can get the same results with, scrap this theme for this website and leave the other websites that the builder is working on to use the Enfold theme.

    Excuse my tone if this comes off as passive aggressive.

    #797502

    @petersocialiq if you say you have no issues with other installations running the same server configuration, same theme and same plugin versions you have proven this not to be an Enfold issue ;-) Instead of insisting on this to be a theme issue you should troubleshoot it from ground. You might even have a simple cookie issue that can be solved by clearing your browser completely. Much luck!

    #797503

    Thanks @mensmaximus

    #797713

    Hello all

    Well – blow me away with a feather – I found it!

    On the last update of Enfold/Wordpress etc in the Enfold Theme Options it appears an extra security measure must have been added because the “Lock advanced layout builder” was checked AS WELL AS the “Lock advanced layout builder for admins as well?”

    The second option [Lock advanced layout builder for admins as well] must remain UNchecked as this will lock the elements for all administrators to prevent accidental changing of a page layout. In order to change a page layout later using Avia Layout Builder, you will need to uncheck this option.

    I hope this helps you guys out there.

    #799160

    Hi,

    Thank you very much for updating the others also!
    We really appreciate that.

    Best regards,
    Basilis

Viewing 26 posts - 1 through 26 (of 26 total)

The topic ‘Avia layout builder not working’ is closed to new replies.