Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
  • #304649


    I see this has been a reoccurring issue in the forum. Not sure if any of the past solutions apply to my site since I have the most recent versions of both the Enfold Theme (2.9.1) and WordPress (3.9.2). Unfortunately, the advanced layout builder through the enfold theme is not functioning. When I try to go into a page to edit the content the layout builder shows that it is loading but it never fully loads.

    We recently just made our website live to the public so we would like to be able to edit our content as needed. Please Help!


    Hey WattzOn2014!

    Thank you for visiting Kriesi’s support forum!

    Please deactivate all third party plugin then test the builder again using another browser or computer. Did you happen to move the website from a development domain to the live site? Make sure that database has been moved properly. In order to migrate the theme successfully and leave the database intact, please use this plugin: WP MigrateDB or WP MigrateDB PRO

    Refer to this link for more info on how to properly migrate your enfold website from production to development vice versa:–wp-32684

    Best regards,


    QUICK SOLUTION: switch to Standard Editor and then back to AVIA Layout builder….
    I have the same problem – when I open an existing page the avia builder is not loading, you just see the spinner icon.
    If you switch to the standard editor and then back the Avia builder loads.
    This is a fresh installation without any migration, most recent WP and theme….



    That *shouldn’t* be needed but if its working for you its a good workaround.



    Thanks for the suggestions. So I tried deactivating all third party plugins (none were currently activated) and tested the builder on another browser. Alas, I still ran into the same issue with the avia layout builder constantly loading. I also don’t suspect it’s a DB issue as we used a similar tool to the one suggested to update all the URLs from the temporary domain to the production domain.

    Finally, I tried using the quick solution offered but when I click “Default Editor” WordPress does not respond. I went to add a new page and when I click “Advanced Layout Builder” no response either.

    Not sure what else to try.



    @wattzon2014 Do you mind creating a temporary admin login and posting it here privately?


    This reply has been marked as private.


    Thank you for the info.

    All plugins are deactivated but they are still present on the wp dashboard. Please go to wp-content/plugins folder then rename all plugins folder. Test the advance layout builder again.



    If I rename the folder will that break the plugins that our other sites use?



    It will deactivate all plugins on that WordPress installation



    So we created a separate installation specifically for this site since we didn’t want our other sites to be effected. We have multi-sites, some of which use several plugins. Once the new installation was ready I deleted all other sites and deleted all the plugins. Unfortunately, this has had no effect on our website. I even reached out to a plugin support team to see if they could share some light but the plugin support team said that since we are not using a child theme we should be able to disable all genesis plugins as they will not be compatible with the theme. They write their plugins in such a way that not only will they not activate when you aren’t using a Genesis theme and they will not actually run any of the plugin code if they happen to remain active when switching themes.This means that the conflict probably didn’t originate with any of their plugins since the check to see if it is Genesis would have stopped the plugin from outputting any code.

    Not sure what else to try, please help!

    This reply has been marked as private.


    @slimmer1, you are having this issue because you are using WP 4.0, you need to update Enfold to its latest version too (2.9.2).

    @wattzon2014, can you post a link to your website please?



    Thanks, Josue!

    I think the API key should be documented more openly, but after ten minutes of googling and fiddling, I found it:

    Log into themeforest
    click Settings
    at middle left, find API keys, click that link
    Generate new key
    Go to WordPress admin>Enfold
    Click “see all options”
    enter themeforest username and generated key there

    …the Enfold will check for an update every 12 hours.
    I’ll keep you updated.


    Hi again Josue,

    Your advice to update Enfold to 2.9.2, to match the updated WP 4.0, resolved the issue wherein loading the Avia drag and drop editor never completes.

    Thanks for a truly stellar customer support experience. Enfold is an amazing theme, and Kriesi’s tech support bench strength sets you apart as an organization that we end-users can count on to keep our projects on track.


    -Alan Horenstein


    Glad to hear that Alan, you are welcome :)


    This reply has been marked as private.


    Have you tried disabling all third-party plugins to see if it gets fixed?



    Yes, and below is everything else I have tried:
    -Deactivating all third party plugins
    -Test using another browser/computer
    -Increased PHP memory
    -Pushing the site to staging and disabling plugins
    -Moving the site to its own installation & disabling plugins
    -Enabled plugins one by one to see which is causing problem
    -Contacting Plugin Support
    -Killed extra sites on the new installation and deleted all plugins



    I just tried disabling all third-party plugins and the problem seems to be fixed, check it now.

    Best regards,


    Yes, the advanced layout builder is now working but disabling all the third party plugins has now messed up one of our other primary websites. Luckily, I was able to remedy it by activating the Gravity Forms plugin. Thanks for all the help Josue!

    • This reply was modified 5 years, 11 months ago by  WattzOn2014.

    You are welcome, glad to help :)


Viewing 22 posts - 1 through 22 (of 22 total)

The topic ‘Avia Layout Builder Constantly Loading’ is closed to new replies.