Tagged: 

Viewing 27 posts - 1 through 27 (of 27 total)
  • Author
    Posts
  • #1144573

    I am really pulling my hair out from stress of this one.
    I’ve included admin credentials in private content.
    I disabled all plugins (except woocommerce, as i need that on for the editing i need to do), still cannot work. I tried some other ‘fixes’ from your forum in the past suchas disable block editor etc, no success.

    Please help! Client is rushing me too and I cannot do anything at all :(
    Some content blocks load but most do not, and the important ones don’t. Such as i cannot add an image. Adding the image block then hitting edit results in a blank edit box after some spinning wheel for some time.

    #1144646

    To follow up on this, i called my hosting provider Godaddy and they do not have Mod Security on the server at all.
    They could not find any errors that jumped out at them to resolve the problem. They offered paid support for them to figure it out, but i think it is a theme issue so i need to wait for you to respond.

    #1144688

    Get this error in console when attempting to edit a object in the builder:
    https://…./wp-admin/admin-ajax.php?_fs_blog_admin=true 500

    #1144723

    going in to network due to the 500 error and inspecting the error, all we get back is “The site is experiencing technical difficulties” lol.

    It looks like i will need to wait for your assistance, thank you in advance.

    #1145008

    I see support logged in early this morning, but no reply. Any news?

    #1145080

    Hi moonknight066,

    Have you checked the server log for the error?

    Please refrain from replying to your own thread because it gets pushed back to the end of the queue and moderators won’t be able to provide a response immediately. Please be patient while we go through the rest of the queue. Thank you for your understanding.

    Best regards,
    Victoria

    #1145081

    Yes, there were no errors Godaddy found in many weeks.

    #1145646

    Hi,

    Thank you for the update.

    Where can we see the issue? We can’t reproduce the error on a test page (see private field). Please provide the actual link to the page with the error. A screenshot will help as well.

    Did you add any html tags in the page? Please make sure that the tags are closed properly.

    Best regards,
    Ismael

    #1145661

    many builder elements dont work. like image. see screenshot example. i have not added any manual html to any pages.

    #1146331

    Hi,

    Thank you for the update.

    We can now reproduce the issue on our end. An internal server occurs every time the admin-ajax.php file is needed to execute a script. It is possible that the server blocks the file because it’s getting a lot of unexpected requests from it. Please ask your hosting provider if mod_sec is enabled in your server — it is a security module for PHP — and if the said module comes with a rule that blocks files like the admin-ajax.php file.

    Best regards,
    Ismael

    #1146541

    Hello, thank you Ismael.

    I had already talked to GoDaddy about the Mod Security. They say there is absolutely no mod security on my web server. Is there anything else they can look into? I will post back with an update about what they say about server fault.

    #1146644

    GoDaddy cannot help on this and there is no mod_sec, they increased memory to 4GB from 1GB and still same problem. They don’t know what to do.I have all plugins disabled and still the issue persists.

    I thought maybe the size of the media library may be an issue? i Have 93GB of Media on the server out of 130GB available disk space. Again, this issue did not start until recently though. Probably newer version of WordPress is the issue?

    #1146647

    I have downgraded to WordPress 5.1.2 and the Avia Builder works even with all plugins on and off. but then about 15 minutes later its broken again without doing anything. I didn’t even get to update a page, i was re-arranging it and by the time i went to add an image, it was broken again.

    Turning OFF WooCommerce resolves the issue. However I NEED WooCommerce…?
    I downgraded to 3.7.0 WC from 3.7.1 and still same issue. I cannot roll back further as my database is 3.7.0 and probably not compatible with lower version to try.

    Please let me know if there is some code i can add to fix the Enfold <-> Woocommerce 3.7.x issue until a new release with fixes can be done.

    • This reply was modified 11 months, 3 weeks ago by  moonknight066.
    • This reply was modified 11 months, 3 weeks ago by  moonknight066.
    • This reply was modified 11 months, 3 weeks ago by  moonknight066.
    #1147003

    Hi,

    Thank you for the update.

    Did you enable the error logs? Please enable it and post the FTP details in the private field so that we can check what’s in the file. We might be able to trace where the error occurs based on the errors in the log.

    // https://wordpress.org/support/article/debugging-in-wordpress/#wp_debug_log

    Best regards,
    Ismael

    #1147153

    Thank you Ismael, i have added
    define( ‘WP_DEBUG_LOG’, true );
    define( ‘WP_DEBUG_LOG’, ‘/tmp/wp-errors.log’ );
    to the wp-config.php file

    FTP credentials in Private Data:

    • This reply was modified 11 months, 3 weeks ago by  moonknight066.
    #1147993

    Hi,

    Sorry for the delay. Did you disable the WP account above? We need to edit one of the pages in order to debug the issue. Please provide another WP account and leave the FTP details available so that we can check the files when necessary.

    Thank you for your patience.

    Best regards,
    Ismael

    #1155757

    Sorry for the EXTREMELY long delay but this got put on hold because of client relations on the repair not being done in a timely manner. We have gotten back on track and still need this repaired, as i see there are no enfold updates lately or wordpress/woocommerce so it may be specific to my godaddy server. Thank you for your help.
    Debugging is turned back on, the FTP account provided above still is operational.
    I have added this new wordpress account for you: (see private data)

    #1156622

    Hi,

    ? i Have 93GB of Media on the server out of 130GB available disk space.

    Thank you for the update.

    We can still reproduce the issue whenever we try to access any elements containing an image. It’s possible that the server times out when it tries to query the media library because of the number of entries in the database. The AJAX requests returns the following response.

    The site is experiencing technical difficulties.
    

    And this is the error from the log.

    [14-Nov-2019 02:14:00 UTC] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 4096 bytes) in /home/wua4p6lmxmxf/public_html/wp-includes/wp-db.php on line 1972
    
    

    This means that the maximum memory allocated to PHP is only 268MB, not 4GB. This also confirms what we see in the Query Monitor plugin’s PHPinfo tab. Is the site on a shared hosting? If not, then you might be able to adjust the maximum memory limit directly from the php.ini file.

    Screenshot of the PHP settings: https://imgur.com/a/cvvVoKU

    Best regards,
    Ismael

    #1156641

    The site is on shared hosting with dedicated resources according to godaddy. They said it is impossible for the 4G allocation to work. It was set. I just set to suggested max of 512M in the .user.ini, but where is your query monitor getting the 256M limit? Where is that limit being imposed ??? Problem still persists after my change. Upgrade to woocommerce 3.8 and WordPress 5.3 will not fix the issue I am guessing? So I will not make the issue worse until you can find the solution to the issue. Of course you have permission to do any needed steps to test, simply turn maintenance mode on if you need to take the site down, management is OK with this.

    #1157135

    Hey!

    ,they increased memory to 4GB from 1GB and still same problem

    They said it is impossible for the 4G allocation to work.

    Why would they increase the memory if they know that it’s not going to be actually applied? Shared hosting never has any “dedicated” resources — they are sets of virtual machines running on bare metal servers.

    Can you point us to the GoDaddy shared hosting plan that you have for the site? Even for Google, Azure or AWS — some of the largest hosting companies in the world — a shared-core virtual machine only has a 0.6GB of memory and will cost you around $4-5 a month, but we are not really sure if it’s the same for GoDaddy.

    Try to increase the memory limit directly from the .htaccess file.

    // https://www.a2hosting.com/kb/developer-corner/php/using-php-directives-in-custom-htaccess-files/setting-the-php-script-memory-limit-in-an-htaccess-file

    Cheers!
    Ismael

    #1157225

    View post on imgur.com


    I gave you access to FTP, you are free to try and edit .htaccess to see if it makes a difference. I don’t believe it did, but it has been some time.

    The Godaddy Representative, Mr. Melvin, was adamant that the server should have zero problems handling the load from the media library requests from wordpress and that it was a theme problem. Of course, that is speculation as he does not know everything about your code.

    Thank you for your continued investigation.

    If you know that we can migrate everything to another host you can reccomend, please advise.

    #1157746

    Hey!

    Thank you for the update.

    The current specs of your server should be able to handle the media library requests and allocate more memory to PHP. We managed to increase the memory limit from 256M to 512M but the internal server error still occurs — same error in the debug log.

    Do you have a development version of the site? We would like to debug the issue further, but we don’t want to break anything in the live domain while doing so. We might have to deactivate the plugins temporarily.

    Regards,
    Ismael

    #1158262

    Not currently, but the hours you currently work on the site is dead time for our clients and us, you would not be interefering with potential business. simply backup any files you change on the FTP of course. i can provide cPanel access on godaddy as well,
    See private content

    #1158997

    Hi,

    Thank you for the update.

    Not currently, but the hours you currently work on the site is dead time for our clients and us

    This is why we don’t want to touch anything in the site without your permission. We have to deactivate the plugins temporarily to rule out any incompatibility issue during testing, but we will not proceed without your say-so. Will you be able to restore the site in case something went wrong during testing? Did you create a site backup or restore point?

    Best regards,
    Ismael

    #1159312

    I’ve created a backup today.

    #1159823

    Hey moonknight066,

    I’ve created a backup today.

    Alright. We are currently inspecting the site. We’ll give you an update as soon as possible.

    Best regards,
    Ismael

    #1159836

    Hi,

    UPDATE: The server is still running out of memory during the database query because the maximum memory limit is still set to 268435456 bytes or 268MB instead of the 512MB that we set in the .htaccess file. The memory adjustment is reflected in the PHP info variables, but it doesn’t really get applied in the environment. You should ask your hosting provider if it’s possible to increase the PHP memory limit and if so, ask them how because all the attempts that we made to increase it is not working.

    [25-Nov-2019 10:46:07 UTC] PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 4096 bytes) in /home/wua4p6lmxmxf/public_html/wp-includes/wp-db.php on line 1972

    Best regards,
    Ismael

Viewing 27 posts - 1 through 27 (of 27 total)

You must be logged in to reply to this topic.