Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #26208


    we are having a problem with the Avia Framework, we are using a section with 5 columns in our homepage, and if we create the page from scratch, everything works fine, if then by any reason, update content or simply republish the page, the layout breaks, on the editor and on the page itself.

    We are using 4 plugins at the moment:

    Akismet, Hello Dolly, Post Duplicator and URL & Path Shortcodes

    This is the AVIA generated code for the page where the problem is occurring, copied into a text file:

    thanks for any help


    Hi dm-consulting,

    Can we see the site and page live? From that bit of information I’m not really sure what could be causing something like that. I’ve not run across it at this point.

    When you created the page, how did you create it? In the regular visual editor, the text tab, the advanced layer slider? Any other information on how we can re-create the issue will help.




    Good Morning,

    The website is in a password locked location because currently under development, i will share the access here so you can take a look at it. (user: kriesi passw: kriesi )

    The page is the theme’s homepage, we imported the content after installing the theme and then changed the content for the homepage.

    The layout is simple, first the slider, them a full column with text, then 5 columns, then an alternate content area and before the footer a post slider in a 4/5 column with a 1/5 column on the left.

    Problem presents itself when we create the 5 columns below the slider and the full column. If we dont add these 5 columns everything works fine.

    Strange thing is that we can create the same 5 columns on other pages without issues. Today i am going to try to use the same layout on another page and see if it presents itself.

    We are using safari for the development, and sometimes firefox. Problem remains.

    Thank you for the help.


    this is the code generated as seen on firebug, as you can see, instead of 5 columns, system renders first 2 and the third breaks layout that comes next on syntax, and makes it DISAPPEAR from avia framework.

    <br />
    <div class="post-entry post-entry-type-page post-entry-734"><div class="entry-content clearfix">
    <div class="avia_textblock"><h1 style="text-align: center; font-weight: 200; font-size: 2.7em; text-transform: none;"><a href=""><span style="color: #005cb9;">La rivoluzione del Printing & Packaging in 5 semplici punti.</span></a></h1>
    <div class="flex_column av_one_fifth first avia-builder-el-2 el_after_av_textblock column-top-margin">
    <div class="avia_textblock"><div class="avia-font-entypo-fontello icona-colonnehomepage-dmc"></div>
    <h3 style="text-align: left;"><a title="DEFINIZIONE" href="./prodotti/">DEFINIZIONE</a></h3>
    <p>Progetto del tracciato di fustella e applicazione della grafica. Realizzazione del mock-up…
    <a href="./prodotti/">continua</a></p>
    <div class="flex_column av_one_fifth avia-builder-el-4 el_after_av_one_fifth column-top-margin">
    <div class="avia_textblock"><div class="avia-font-entypo-fontello icona-colonnehomepage-dmc">⚙</div>
    <h3 style="text-align: left;"><a title="AVVIO" href="./prodotti/">AVVIO</a></h3>
    <p>Visto si stampi. Finalizzazione degli impianti di stampa e avvio del ciclo produttivo…
    <a href="./prodotti/">continua</a></p>
    </div><div class="flex_column av_one_fifth avia-builder-el-6 el_after_av_one_fifth avia-builder-el-last column-top-margin"></div><p></p>
    <div class="avia_textblock"></div>
    <div class="avia-font-entypo-fontello icona-colonnehomepage-dmc">


    I’m not able to access the page with the username and password provided.

    The only thing that we can do is to try and duplicate the layout you have and see whats going on. What you might want to try is to re-adjust the layout by using color sections to break up the content instead of just groups of column content on top of each other.

    Using what you had in the original text file I don’t get any issues when displaying it live.


    Back again,

    i am sorry that you could not enter the site with the username password i gave you. Please try again.

    On the same matter, we keep having problems with the Avia editor, I tried installing the theme from scratch on another server and after using Avia for a while, on some pages i get other kinds of problems.

    On one page, when editing the Avia Editor does not load at all and the loading indicator (the rotating circle) keeps rotating and does not load the WYSIWYG editor.

    On another page, after adding a background image to the Alternate Content container, when i click update page i get a 404 error, even thought the page exists.

    And this is happening on a MAC in Safari, Chrome and Firefox, on 2 different web-servers and even on a local MAMP stack.

    Do i need to do something to the server configuration? Is there any recommended .htaccess or php.ini config?

    Is there a way to somehow reset the Avia Framework?

    Maybe bypassing the framework and using the standard shorcodes might solve the problem.

    Is there an email i can send access information to the website so you can take a closer look? Or maybe using team viewer software.

    I do not know if anyone else is having these kinds of problems, but we need some help, please.


    I have AVIA who disappeard. When you click advanced editor, nothing show anymore.

    I still can import things with the magic wand icon but, nothing shows anymore visually from advanced.

    Just got this after installed the plugin : permalinks editor

    I uninstalled but AVIA still missing.



    @digitalmedia: Click Screen Options > Check the Avia Layout Builder.




    Any solutions?



    I was doing some testing and it seems it is the use of the icon font somehow that is breaking the layout.

    I removed only the icon code in html entity format from the code and the layout does not break anymore.

    I even tried inserting the original code inside a widget on the same page, and layout broke again, even without the columns anymore. On this occasion the footer widget also stopped working and i had to resave the footer widget to get it back on.

    You can take a look now if you want to see, using the access codes i gave you before.

    I will probably resort to changing the font icons on the source code to images. :(

    the culprit lies on this line of code i think:

    <div class="avia_textblock"><div class="avia-font-entypo-fontello icona-colonnehomepage-dmc"></div>


    Hi dm-consulting,

    You can try updating your theme files since they are a few weeks out of date now and are missing a number of recent bug fixes.



Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Avia Framework messes up layout’ is closed to new replies.