Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #749063

    Hi,

    I just deployed my site to production, the site has an SSL certificate installed so all assets are supposedly called over https (using Really SImple SSL). On my staging site, everything works smoothly, but on my prod site TinyMCE is not working, I can’t switch between Visual and HTML and I don’t see most of the formatting options. Whenever I click on the Advanced Editor button I get a couple of other errors as well. The real problem with this is content’s not getting updated (it gets deleted instead).

    I tried a few solutions I found on the forums such as doing a bulk replace of http: for https:, but these haven’t been successful in fixing the issue. I’m basically stuck at this point, do you guys have any idea why this is happening?

    Uncaught TypeError: Cannot read property 'canvas' of undefined
        at Function.b.closeAllTags (quicktags.min.js:1)
        at d (editor.min.js:1)
        at HTMLDocument.<anonymous> (editor.min.js:1)
        at e (wp-tinymce.php:3)
        at HTMLDocument.m (wp-tinymce.php:3)
    quicktags.min.js:1 Uncaught TypeError: Cannot read property 'canvas' of undefined
        at Function.b.closeAllTags (quicktags.min.js:1)
        at d (editor.min.js:1)
        at HTMLDocument.<anonymous> (editor.min.js:1)
        at e (wp-tinymce.php:3)
        at HTMLDocument.m (wp-tinymce.php:3)
    quicktags.min.js:1 Uncaught TypeError: Cannot read property 'canvas' of undefined
        at Function.b.closeAllTags (quicktags.min.js:1)
        at d (editor.min.js:1)
        at HTMLDocument.<anonymous> (editor.min.js:1)
        at e (wp-tinymce.php:3)
        at HTMLDocument.m (wp-tinymce.php:3)
    quicktags.min.js:1 Uncaught TypeError: Cannot read property 'canvas' of undefined
        at Function.b.closeAllTags (quicktags.min.js:1)
        at d (editor.min.js:1)
        at HTMLDocument.<anonymous> (editor.min.js:1)
        at e (wp-tinymce.php:3)
        at HTMLDocument.m (wp-tinymce.php:3)
    quicktags.min.js:1 Uncaught TypeError: Cannot read property 'canvas' of undefined
        at Function.b.closeAllTags (quicktags.min.js:1)
        at d (editor.min.js:1)
        at HTMLDocument.<anonymous> (editor.min.js:1)
        at e (wp-tinymce.php?c=1&ver=4403-20160901:3)
        at HTMLDocument.m (wp-tinymce.php?c=1&ver=4403-20160901:3)
    b.closeAllTags @ quicktags.min.js:1
    d @ editor.min.js:1
    (anonymous) @ editor.min.js:1
    e @ wp-tinymce.php?c=1&ver=4403-20160901:3
    m @ wp-tinymce.php?c=1&ver=4403-20160901:3
    quicktags.min.js:1 Uncaught TypeError: Cannot read property 'canvas' of undefined
        at Function.b.closeAllTags (quicktags.min.js:1)
        at d (editor.min.js:1)
        at HTMLDocument.<anonymous> (editor.min.js:1)
        at e (wp-tinymce.php?c=1&ver=4403-20160901:3)
        at HTMLDocument.m (wp-tinymce.php?c=1&ver=4403-20160901:3)
        at Object.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:3)
        at Object.a.event.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:9)
        at HTMLButtonElement.<anonymous> (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:3)
        at Function.each (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:2)
        at a.fn.init.each (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:2)
    b.closeAllTags @ quicktags.min.js:1
    d @ editor.min.js:1
    (anonymous) @ editor.min.js:1
    e @ wp-tinymce.php?c=1&ver=4403-20160901:3
    m @ wp-tinymce.php?c=1&ver=4403-20160901:3
    trigger @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:3
    a.event.trigger @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:9
    (anonymous) @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:3
    each @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:2
    each @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:2
    trigger @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:3
    (anonymous) @ avia-builder.js:597
    quicktags.min.js:1 Uncaught TypeError: Cannot read property 'canvas' of undefined
        at Function.b.closeAllTags (quicktags.min.js:1)
        at d (editor.min.js:1)
        at HTMLDocument.<anonymous> (editor.min.js:1)
        at e (wp-tinymce.php?c=1&ver=4403-20160901:3)
        at HTMLDocument.m (wp-tinymce.php?c=1&ver=4403-20160901:3)
        at Object.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:3)
        at Object.a.event.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:9)
        at HTMLButtonElement.<anonymous> (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:3)
        at Function.each (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:2)
        at a.fn.init.each (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,jquery-ui-core,jquery-ui-widget,utils,pluplo…:2)
    #749210

    Hey untaljaime,

    Please send us a temporary admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #749426

    Sure! Here you go.

    Thanks!

    #749767

    Hi,

    Thanks for that, I had a look at a text block on your front page but I couldn’t see any problems there. Where exactly are you getting this problem?

    Best regards,
    Rikard

    #749773

    Hey! Thanks for your response. Just create a new Entry and try to switch between HTML and Visual, or click on the “Editor visual” (Advanced editor) tab. I’m attaching a screenshot on the private content area.

    Thank you once again,
    J

    • This reply was modified 7 years, 3 months ago by untaljaime.
    #750250

    Hi,

    Thanks for that, I see what you mean now. It seems like you have removed some options from the WordPress menus, are you running the latest version of the theme (3.8.5)? Did you try deactivating all plugins to see if there is a conflict coming from any of them.

    Best regards,
    Rikard

    #750285

    Hi! Thanks for your answer. Yes, I’m running 3.8.5, I haven’t tried deactivating my plugins, I’ll give it a try. The weird thing is I have the exact same configuration on both my local and staging servers (non-ssl) and the problem doesn’t appear.

    UPDATE: Tried deactivating all plugins but the error persisted.

    UPDATE 2: It’s definitely a theme issue. I tried switching to the default Twentyseventeen theme and the problem did not appear (screenshot attached).

    • This reply was modified 7 years, 3 months ago by untaljaime.
    #750779

    SOLVED IT. I had a function set up to defer all scripts which obviously conflicted with the theme files/file load order for some reason, I just wrapped it inside an if(!is_admin()) conditional. Thanks a lot for your help.

    #750805

    Hi,

    Great, glad you got it working and thanks for letting us know. Please let us know if you should need any further help on the topic or if we can close it.

    Best regards,
    Rikard

    #750821

    You can go ahead and close it, thanks a lot.

    #752601

    Hi,

    Glad this is sorted for you. To know more about enfold features please check – http://kriesi.at/documentation/enfold/
    Thank you for using Enfold :)

    Best regards,
    Vinay

Viewing 11 posts - 1 through 11 (of 11 total)
  • The topic ‘Avia Editor / TinyMCE / Script errors over SSL’ is closed to new replies.