Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1335622

    I need help reducing our autoloaded data.

    Top largest autoload rows: (Many are ALB related)
    mysql> SELECT LENGTH(option_value),option_name FROM wp_options WHERE autoload=’yes’ ORDER BY length(option_value) DESC LIMIT 20;

    +———————-+———————————————————————-+
    | LENGTH(option_value) | option_name |
    +———————-+———————————————————————-+
    | 385450 | _transient_dirsize_cache |
    | 255578 | av_alb_usage_av_hr |
    | 126340 | av_alb_usage_av_icon_box |
    | 125704 | av_alb_usage_av_one_half |
    | 91416 | av_alb_usage_av_heading |
    | 90163 | av_alb_usage_av_textblock |
    | 79256 | rewrite_rules |
    | 69289 | av_alb_usage_av_social_share |
    | 43469 | widget_black-studio-tinymce |
    | 35009 | _transient_wr2x_issues |
    | 34134 | avia_options_enfold_child |
    | 32789 | av_alb_usage_av_one_full |
    | 32034 | monsterinsights_report_data_yearinreview |
    | 25179 | ws_menu_editor_pro |
    | 25099 | _ubermenu_menu_item_styles |
    | 24708 | wp_user_roles |
    | 21742 | bwp_minify_detector_log |
    | 21496 | av_alb_usage_av_image |
    | 21002 | _transient_mailpoet_subscribers_statistics_count_cache |
    | 19880 | _transient_mailpoet_subscribers_statistics_count_global_status_cache |
    +———————-+———————————————————————-+

    Total autoloaded data (in bytes):
    mysql> SELECT SUM(LENGTH(option_value)) FROM wp_options WHERE autoload = ‘yes’;

    2014471
    WP Engine wants that total to be under 800k or so for good performance.
    This is ~1214471 bytes larger than 800k. They recommend reducing this to below 800k for good performance.
    Their documentation on this says to work with the Theme author to be safe.
    Ref. https://wpengine.com/support/database-optimization-best-practices/#Autoloaded_Data
    Please help. Our site is slower than normal Backend and Fronend and is more frequently hitting 504s.
    I ran wp-optinize and did some clean up on other plugins, tables etc. but need help with this

    #1335658

    Hey Julie,

    You could try to remove transients using a plugin like this: https://wordpress.org/plugins/transients-manager/

    Best regards,
    Rikard

    #1336060

    Hi Rikard,
    Thanks for your help but transients had nothing to do with autoload settings on tables. I did figure out what was causing the 504’s – page cache was turned off.
    This ticket may be closed.

    #1336103

    Hi,

    Great, I’m glad that you found the problem, and thanks for the update. Please open a new thread if you should have any further questions or problems.

    Best regards,
    Rikard

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Autoloaded Data – Slow Performance -504's’ is closed to new replies.