Tagged: ,

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #277675

    I am trying to add some mp3s to a portfolio page. I added 3- 1/3 elements, then a text block inside each. In the text blocks I used WPs ‘Add Media’ button and navigated to my uploaded mp3 files for placement. I did not add an OGG file if that matters.

    I then Saved and Updated the page. In the browser, no player shows and if I hover over where they are supposed to be, a text link appears that says ‘Download’ and the link is to the page itself.

    I also tried using a third-party player but it didn’t show up either. Suggestions?

    • This topic was modified 9 years, 11 months ago by blaisen.
    #277744

    Hey Blaise!

    Make sure you have this option selected:

    Cheers!
    Josue

    #277806

    Yes – that is the default. I tried importing another…no luck.

    Next Option?

    Here is the code:
    <div class=”wpview-wrap wpview-type-audio” contenteditable=”false” data-wpview-text=”%5Baudio%20mp3%3D%22http%3A%2F%2Fwww.brainshine.com%2Fwordpress%2Fwp-content%2Fuploads%2F2014%2F06%2Fgrunion_image_00.mp3%22%5D%5B%2Faudio%5D” data-wpview-type=”audio”>
    <div class=”toolbar”></div>
    <div id=”mep_15″ class=”mejs-container svg wp-audio-shortcode mejs-audio” style=”width: 400px; height: 30px;”>
    <div class=”mejs-inner”>
    <div class=”mejs-mediaelement”><audio src=”http://www.brainshine.com/wordpress/wp-content/uploads/2014/06/grunion_image_00.mp3?_=15&#8243; style=”visibility: hidden;” class=”wp-audio-shortcode” width=”400″ preload=”metadata”>

    <source src=”http://www.brainshine.com/wordpress/wp-content/uploads/2014/06/grunion_image_00.mp3?_=15&#8243; type=”audio/mpeg”>

    </audio></div>
    <div class=”mejs-layers”></div>
    <div class=”mejs-controls”>
    <div class=”mejs-button mejs-playpause-button mejs-play”></div>
    <div class=”mejs-time mejs-currenttime-container”><span class=”mejs-currenttime”>00:00</span></div>
    <div class=”mejs-time-rail” style=”width: 0px;”><span class=”mejs-time-total” style=”width: 0px;”><span class=”mejs-time-float”><span class=”mejs-time-float-current”>00:00</span></span></span></div>
    <div class=”mejs-time mejs-duration-container”><span class=”mejs-duration”>00:00</span></div>
    <div class=”mejs-button mejs-volume-button mejs-mute”></div>
    <div class=”mejs-horizontal-volume-slider mejs-mute”></div>
    </div>
    <div class=”mejs-clear”></div>
    </div>
    </div>
    <div class=”wpview-overlay”></div>
    <ins data-wpview-end=”1″></ins></div>

    • This reply was modified 9 years, 11 months ago by blaisen.
    #277809

    Please update the theme to the latest version (2.8.1).

    If you have modified the theme files it is recommended to backup your current theme.

    Best regards,
    Josue

    #277829

    I updated the theme, and I can see the players in preview mode on Firefox. But when I try and open the page regularly through the site, in Firefox, Safari and Chrome, I get the same result I originally described.

    #277830
    This reply has been marked as private.
    #277836

    Hi,

    Can you please create me an administrator account? post it here as a private reply.

    Regards,
    Josue

    #277841
    This reply has been marked as private.
    #277913

    Hi!

    Found a workaround, use this method to include the audio files, i already did it for the first one:

    Best regards,
    Josue

    #278196

    That works as long as you stay in the Text editor. As soon as you save and re-open the Text Block – which by default opens in the Visual editor – WP (I assume) replaces the code with the player graphic and the problem starts over. This means one has to go back and fix the code in the Text editor every time the Text Block is opened. Not very efficient! Thoughts?

    #278200

    Hi!

    You can also disable the Visual Editor (Users > Your Profile), that way the shortcode format remains. I know this is not ideal, but it does the job while we find a definitive solution for this bug.

    Best regards,
    Josue

    #278217

    Thank-you!

Viewing 12 posts - 1 through 12 (of 12 total)
  • The topic ‘Audio Not Working’ is closed to new replies.