Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #1290581

    Various animations are no longer working on our website. Using the link below, when you scroll down to “Services include” the icons are no longer animated. On another page, the “counter” no longer works. I have had to slowly remove all instances of animation on our website as I find them.


    Hi cpetroff1321,

    I could see js errors.
    Please update Enfold to the latest version (4.8.1) in order to fix this issue.
    If it still does not work or have issues, please disable Javascript file merging and compression in Enfold > Performance.
    Also, please make a backup first before updating.

    If you don’t want to upgrade yet, the workaround is to install and activate Enable jQuery Migrate Helper plugin and set jQUery version to Legacy 1.12.4-wp.
    Hope this helps.

    Best regards,


    Dear support team

    I face the issue of ANIMATED TIMELINES, which I use on all my ‘Angebote’-pages: Although I deactivated the ANIMATION menue under extended options, these timeline widgets still seem animated. How can I deactivate the ANIMATED TIMELINES?

    This causes trouble, because these ANIMATED TIMELINES do not show up since I added a floating calender widget form calendly.com. My aim is to deactivate alle ANIMATED ELEMENTS.

    Thank you so much.


    Hi, I completed those actions (upgraded to the latest version of enfold) and the Javascript file merging and compression was already disabled. The animation worked at first, and now it’s reverted back to not working again.


    I think this was a conflict with WP Rocket. I tweaked some settings there and it appears to be working again. Thank you for pointing me in the right direction.


    Hi cpetroff1321,

    Please post us your login credentials (in the “private data” field), so we can take a look at your backend.

    1. Install and activate ” Temporary Login Without Password “.
    2. Go to ” Users > Temporary Logins ” on the left-side menu.
    3. Click ” Create New “.
    4. Add the email address for the account ( you can use (Email address hidden if logged out) ), as well as the ” Role ” making that the highest possible and the expiry about four days
      ( to be sure that we have enough time to debug ).
    5. Click ” Submit “.
    6. You’ll now have a temporary account. Please provide us here in the private section the URL, so we can login and help you out.

    When your issue is fixed, you can always remove the plugin!
    If you prefer to not use the plugin, you can manually create an admin user and post the login credentials in the “private data” field.

     @PhilippKellerhals please create a new thread and give us admin credentials so we can check further.

    Best regards,


    The animation worked for a short time, then stopped working again. Credentials are below.


    Hi cpetroff1321,

    Thanks for giving us admin access.
    I checked the page both logged in and as a guest and it seems it’s a caching issue (animation worked properly when logged in and animation not working as a guest).
    After clearing the caches in WP Rocket (link in private content) it seems to work properly even as a guest.
    I think this is how WP Rocket works (based on experience).

    Best regards,


    I want to follow up on this. The Icon animation don’t work when “Delay JavaScript Execution” is enabled in WP Rocket.

    WP-rocket provides and option to “Exclude JavaScript Files” it says, “Specify URLs or keywords that can identify inline or JavaScript files to be excluded from delaying execution (one per line) and this it the default entry:


    What would we have to exclude so that the Icon animations work? I think this is the CLASS that is affected:

    avia-icon-list avia-icon-list-left av-iconlist-big avia_animate_when_almost_visible avia-iconlist-animate avia_start_animation


    Thank you for your patience, please try excluding these files:
    but I’m not sure if this will work if the theme is merging the css & js and WP Rocket is combining & minifying, you may need to leave this WP Rocket feature disabled.

    Best regards,


    Hi Mike, I’m still tinkering with this. My pages have a combination of Enfold Icon, List Icon and Fullscreen Slider on a single page. When “Delay JavaScript Execution” is enabled the animations work with the exception of the icons, which appear to run in reverse.

    I was able to modify this line but then none of the animations run until I mouse over the page. I added ([css]+)(.*)


    “Delay JavaScript Execution” does improve the page speed, so fixing this is worth pursuing in coming updates. I haven’t tried your suggestion yet, but excluding almost all of the Avia JS elements seems to defeat the purpose, when only a few seem to be affect. So far it only seems to affect the (before|after) icon animations.


    One other thing I should point out to clarify, the animations work fine with all of the WP-Rocket minifying, combining and deferring options on, in fact they always have. It’s the new “Delay JavaScript Execution” that causes some problems with the Avia before|after animations, while the sliders are unaffected. Clearly this is something that can be fixed without excluding all of the Avia animations.


    Sorry I don’t have any ideas on writing an exclusion for wp rocket, these were the js files that I found that contained animation scripts, the iconlist.js is the most direct for your element, but the other two also have before|after scripts, I imagine it would be a matter of trial and error.

    Best regards,


    “Delay JavaScript Execution” will likely become a common feature across the various caching plugins just like combining, minifying and deferring. The Enfold team should be working to insure compatibility.


    I have submitted this as a feature request to the dev team, I will reply when I hear back.

    Best regards,

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.