Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1404964

    Hi i’m having an issue with the anchor links on this page:

    Please see screenshot: https://www.loom.com/i/d9083acde2ed4c47b8936dc9e015fb06

    If you click on the milestone heading (for example: WET PIPE), it should open the accordion(Wet Pipe Fire Sprinkler Systems) below and scroll to that section. The only problem is that, the sticky header is covering the start of the accordion tab. Can you please help me fix it so that the header will not cover the accordion tab.

    Thanks

    #1405243

    Hey buzbuzzer,
    Thank you for your patience, I tested in Windows in Chrome, Firefox, & Edge and only Firefox had the offset wrong, is this where you see it also?
    I see that you added this script:

        (function($) {
            $('a[href*=#]:not([href=#])').click(function() {
                if (location.pathname.replace(/^\//, '') == this.pathname.replace(/^\//, '') && location.hostname == this.hostname) {
    
                    var target = $(this.hash);
                    target = target.length ? target : $('[name=' + this.hash.slice(1) + ']');
                    if (target.length) {
                        $('html,body').animate({
                            scrollTop: target.offset().top - 100 //offsets for fixed header
                        }, 1000);
                        return false;
                    }
                }
            });
        }(jQuery));

    But you are getting a jQuery is not defined do you have the option Enfold Theme Options ▸ Performance ▸ Load jQuery in your footer enabled? Try disabling it

    Best regards,
    Mike

    #1405398

    Hello Mike,

    Thanks for helping, I already disabled the Load Jquery in footer option but its still not working. Here’s a loom video:

    https://www.loom.com/share/2894f0f7dbe64e60b569620cc61de2f3

    Regards
    Christian

    • This reply was modified 1 year, 1 month ago by buzbuzzer.
    #1405458

    Hi,
    You are still getting an error on your script.
    Enfold_Support_1869.jpeg
    Please include an admin login in the Private Content area so we can check.

    Best regards,
    Mike

    #1405734

    Hello Mike,

    Sure here’s the login

    #1405755

    Hi,
    Thanks for the login, I found that you had Enfold Theme Options ▸ Performance ▸ Disable jQuery Migrate enabled, I disabled it for you now you don’t have the jQuery error. I also made some minor adjustments to the script, please clear your browser cache and check.

    Best regards,
    Mike

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.