Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1206511

    Hi guys,

    I put a contact form in my footer and created an anchor link in the main menu, named, well, Contact.

    When clicked on Contact, it scrolls down to the footer, no problem.

    But. In the main menu, the Contact menu link changes to the active state, the moment the user starts scrolling down. Without clicking the contact menu link.

    When you scroll down manually to the footer, the main menu Contact link does not activate. Weird.

    Question: It is possible to have the Contact menu link only change to the active state when clicked on and when the user reaches the contact form in the footer?

    Can you help me please?

    Sincerely,
    Morticka

    #1207237

    Hey Morticka,

    There is no id “contact” on the page, the form widget has a different id. Please add the proper id and see if the issue persists.

    Best regards,
    Victoria

    #1207718

    Hi Victoria,

    What do you mean?

    When I check the contact form, menu anchor link and footer widget, you see the “contact” id everywhere.

    I’ve enclosed screenshots and you can clearly see I’ve used the right id in all the right places?

    Please help?

    Sincerely,
    Morticka

    • This reply was modified 1 year, 1 month ago by  Morticka.
    #1207724

    Hey Barb!

    Hope you are doing well :)

    I tried logging in but credentials did not work for me. Could you please check them once again?
    Looking at your video, to me it seems like if you only insert “contact” as ID for the very last Color Section, it should work correctly. Please do not set custom ID for Contact Form itself.

    Best regards,
    Yigit

    #1207787

    Hey Yigit, great to see you! :D

    I checked, the credentials are correct? Did you forget to check the boxes again? :P

    I put the id in the grid row earlier, just before the footer. Ofcourse it works, but it’s not the solution I’m looking for. Because now I have to put in a color section on every other separate page (every blog post and every other page/course pages etc) with the contact id to make it work.

    Is there no way to anchor the footer widget?

    Sincerely,
    Barb

    #1207799

    Hi Barb!

    Yes, I forgot to check the box again :D

    I thought it was a Color Section element but it is actually in your footer so I edited your custom menu and simply changed the URL to #footer. Can you please review your website? :)

    Best regards,
    Yigit

    #1207811

    Hi Yigit,

    Hahaha, no problem.

    YES, it works!!! Such a simple solution, as always, you rock! <3

    You can close this ticket.

    Sincerely,
    Barb :)

    #1207814

    Hi,

    Always happy to help, Barb! :)

    Enjoy the rest of your day!

    Best regards,
    Yigit

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Anchor link in footer does not work right, please help?’ is closed to new replies.