Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #1232457

    I’ve been trying to figure out how to reduce the memory demand of Enfold.
    -I’ve added the WP Super Cache as was recommended.
    -Got my host to increase the PHP memory limit to 512.
    -Set the Enfold editor to Classic
    -Enabled debugging, but also looked through the server log.

    This is one of the most frequent alerts I receive when trying to navigate the back-end dashboard. However, they are not the only errors. I see many come from the Avia Layout Editor as well.

    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 20480 bytes) in xxxxxxx/wp-includes/plugin.php on line 182
    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 20480 bytes) in xxxxxxx/wp-includes/class-wp-fatal-error-handler.php on line 67

    What is the actual memory demand from Enfold systems? My host says that I should try and reduce the memory demand as it causes huge overhead for my users, however, I am also nearly unable to edit and post to my site.

    Furthermore, though I’m not sure how to test if this is also a memory issue, when I edit blocks often times the window loads blank. It’s incredibly tedious to have to open and close a block edit over and over until the window actually opens.

    I have no plugins enabled, only the Enfold theme. I did have a previous custom theme and website before I updated to this theme, however, I understand that once you enable a different theme, there should be little overlap in code and systems…


    Hey GaianHelmers, These are WordPress paths and so the error not in the theme.

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    When do you get the error or is it just in the logs?

    Best regards,



    Could you please post temporary admin logins here privately? It seems like your memory limit is set to about 42M instead of 512M.



    It seems with an upgrade to php 7.4 the memory leak stopped.



    So that fixed your issue? Did you need additional help with this topic or shall we close?

    Best regards,
    Jordan Shannon


    Yes I believe so.
    Thanks for your prompt and engaged responses.



    You are welcome! :)

    For your information, you can take a look at Enfold documentation here –

    If you have any other questions or issues, feel free to start a new thread under Enfold sub forum and we will gladly try to help you :)

    Best regards,

Viewing 7 posts - 1 through 7 (of 7 total)
  • The topic ‘Allowed memory size exhausted’ is closed to new replies.