Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1146203

    Hello,

    I am working on a dev site and getting it ready to go live. We have tested a change in domain name while also changing the media upload directory to a subdomain. Everything appears to be working fine except the icons are not showing and instead an empty square is in their place. All picture content is showing just not the icons. I have searched for a solution and have seen this as common but none of the resolutions have worked for me. I can see the icons in page editor so I know they’re there and I’ve checked the directory where they are located and everything is there. Updated to latest version.

    #1146372

    Hey xynapse,

    Try to do the solution posted on our documentation: https://kriesi.at/documentation/enfold/icon/#troubleshoot
    Hope this helps.

    Best regards,
    Nikko

    #1146400

    Hello Nikko,

    Yes I have tried it. I have also done a hard refresh and icons still show as squares. I put the url in the Private Content. You will see in the menu the icons are squares. Also in the top nav bar the Social icons are squares.

    I have already added to htaccess
    <FilesMatch “.(ttf|otf|woff)$”>
    <IfModule mod_headers.c>
    Header set Access-Control-Allow-Origin “*”
    </IfModule>
    </FilesMatch>

    This is Linux using Apache. I’ve never had this issue before but I’ve combed through all the support looking for a solution.

    Edit: I’ve added login creds and htaccess info.

    • This reply was modified 1 week, 2 days ago by  xynapse.
    #1146506

    Hi,

    Thanks for the update. I see that you are using an optimisation plugin. What happens if you switch off minification in that, or deactivate it altogether?

    Best regards,
    Rikard

    #1146863

    Hello Rikard,

    Happy to say I got it working. I must have setup the new media upload directory and subdomain wrong. After noticing a few issues I decided to rebuild the server from scratch. I think what happened was I pointed the subdomain to the default wordpress upload directory /public/wp-content/uploads in Apache. Yet in wordpress I added the subdomain as it is and should be in the upload url and the new upload path. You’d think I’d get redirect errors though. The images worked also which is strange. Just not the icons. I made a lot of changes troubleshooting and couldn’t remember them all so I started over from scratch and migrated the site again.

    Everything works great now. Thank you for the assistance.

    #1147120

    Hi,

    Great, I’m glad that you got things working and thanks for sharing your solution. Please let us know if you should need any further help on the topic or if we can close it.

    Best regards,
    Rikard

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.