Viewing 30 posts - 1 through 30 (of 39 total)
  • Author
    Posts
  • #236247

    Hi, I notice there is a new theme option to use the advance layout editor to build your own blog layouts. Unfortunately there is no additional information available there. I’ve looked on this forum and even on Google, but nowhere do I find information as to what this does and how to use it.

    It basically just says I should assign a page as the Blog page, but as soon as I do that the chosen page displays nothing. This is my “news” page: http://goo.gl/4sDl1z

    So at the moment I have chosen no page to show the blog on. If I choose this page as the blog layout I get results depending on which option of Blog Style I selected. Using Multi Author, Single Author or Grid Layout will show my blogs. Using this new option “Advanced layout editor …” the page turns empty.

    So clearly it disregards what’s inside my news page, because as soon as I deselect this page as Blog page, everything is visible again.

    #236689

    Hey DavyE!

    Did you select the option “Use the advance layout editor to build your own blog layout…” in the General Settings of the theme options?

    Missed your last sentence on the first read-through. What do you have in the layout of your custom page? You’ll need to have a blog element on that page in order to actually show any blog posts.

    Cheers!
    Devin

    • This reply was modified 10 years, 4 months ago by Devin.
    #236794

    Logically yes, but I do have a blog element on that page, that’s why I don’t understand why it isn’t showing anything. It just disregards everything in my layout. Here is the entire code of my News page:

    [av_textblock]
    <h1 style="text-align: center;">News</h1>
    [/av_textblock]
    
    [av_hr class='invisible' height='50' shadow='no-shadow' position='center']
    
    [av_one_fourth first][/av_one_fourth]
    
    [av_one_half]
    
    [av_blog blog_type='posts' categories='791,789,787,1' link='category' blog_style='single-small' columns='5' contents='title_read_more' content_length='excerpt' preview_mode='auto' image_size='entry_without_sidebar' items='10' offset='0' paginate='yes']
    
    [/av_one_half][av_one_fourth]
    [av_hr class='invisible' height='15' shadow='no-shadow' position='center']
    
    [av_font_icon icon='ue84d' font='entypo-fontello' style='' caption='' link='' linktarget='' color='#000000' size='40px' position='left'][/av_font_icon]
    
    [av_hr class='invisible' height='10' shadow='no-shadow' position='center']
    
    [av_sidebar widget_area='Sidebar Blog']
    [/av_one_fourth]
    
    [av_hr class='invisible' height='75' shadow='no-shadow' position='center']
    
    
    #237030

    hello,

    the same problem.

    thats the config:

    1
    2
    3

    #237046

    Had the same issue. This is how I fixed it:

    In Enfold Theme options set “Where do you want to display your blog” to nothing.

    Then go to Appearance > Themes > Customize (when you hover over theme) and then set Blog to nothing as well.

    Create your Blog/News page, add whatever elements you want in the Advanced Layout Editor (be sure to include the Blog Posts element and configure from within).

    Original Thread: https://kriesi.at/support/topic/editing-blog-homepage-outside-of-avia-layout-builder/

    • This reply was modified 10 years, 4 months ago by Thinkgate.
    #237087

    Thanks murphy88, but in my case it’s not about fixing a/the problem. I use it the same way you do, at the moment, and it works fine. I was just wondering what this new functionality offers and how it works.

    #237144

    Do you have the WordPress settings for blog/home page set or is it the “use latest posts” in Settings>reading ? The theme’s settings should be all that is needed and if both are set it could be causing the issue.

    #237509

    I have changed the seetings of Enfold (static page: News; static page: select; …) and the Customize settings of WordPress itself (static page: News; static page: select; …). Nothing changes the empty page unless both are set to “select”.

    Is there any example/video of how this is done and what it does? What’s the difference with doing it just the way I do now?

    #237516

    all set set to off worked for me.

    bis dann, marco.

    • This reply was modified 10 years, 4 months ago by netztaucher.
    #237837

    If you can provide admin credentials so we can log in and take a look we can try and get it sorted out. All the setting does is tell the theme and WordPress where the root blog is located and I’ve not had any issues with it like you are describing so seeing it first hand is the only thing I can think of at this point.

    #239703

    I am experiencing exactly the same issue.
    The only way to display the blog is by NOT using the new option “Use the advance layout editor to build your own blog posts ….”. If I select it, my blog page stays completely empty, even though I have the Blog element correctly inserted.
    In my case, I HAVE TO keep the correct blog page indicated in the settings, if I don’t the Blog link on each article will point to the home page rather than the blog page. This is the reason why keeping the blog page setting to “select” is no good (link to Blog takes to home page, which is wrong).

    And the reason why i would like to use the advanced layout editor is that I would like to only display certain categories of posts on the blog page. Whilst with the other settings it always displays ALL posts.

    Is there a solution to make the blog page work via the advance layout editor blog element?

    #239761

    So far I’ve not been able to re-produce the issue so for you as well if I can log into your installation and take a look at things first hand we can try and find out what is happening.

    #239992
    This reply has been marked as private.
    #240644

    Hi Devin, have you had a chance to look at the site and see what’s wrong?
    Cheers.

    #241680

    May I have an answer please?

    #241865

    Hey loyalzoo,

    I haven’t offered Devin a login yet as I mainly just wanted to see how this works. The way I use it now does the job fine, I was just curious what the difference/benefit is. Apparently I couldn’t get any information, so I’m left no wiser than before. :(

    #243195

    Hey!

    I’ll mark this thread for Kriesi.

    Cheers!
    Peter

    #244256

    I can’t get this to work either. Would be nice to try it out.

    #244341

    Hi!

    On the previous versions of Enfold, a lot of users are complaining about the “Where do you want to display Blog?” option. Whenever they set the page on this option then edit the blog page using the Advance Layout Builder, they don’t see the elements on the front end. It’s because setting the blog page on this option will force that page to use the index.php or basically the blog post overview page.

    The new option “Use the advance layout editor to build your own blog layout (simply edit the page you have chosen in Enfold->Theme Options as a blog page)” gives you the capability to edit the blog page to your liking using the Advance Layout Builder while correctly specifying the page as the blog on “Where do you want to display Blog?” option. For clarification it says “Use the advance layout editor to build your own blog”, that means you can only build the page using the advance builder and you can’t use the default editor when editing the blog page.

    Follow these steps:

    1.) Create a page then set it as the blog on “Where do you want to display Blog?” option.
    2.) Set the Blog Style to the new option “Use the advance layout editor to build your own blog layout (simply edit the page you have chosen in Enfold->Theme Options as a blog page)” .
    3.) Edit the new page using the Advance Layout Builder. :)

    Thank you for your understanding.

    Best regards,
    Ismael

    #244346

    Ismael,

    This is clear, but there is still a problem. If I do what you say, when I click on the “blog” link on the Breadcrumb navigation at the top of any article post, rather than taking me to the Blog page it sends me to the Home page!
    This is why I cannot (yet) remove it from “Where do you want to display Blog?” option.

    Can you tell me what’s wrong please?

    #244354

    Hi!

    Thank you for the feedback. :)

    I didn’t say anything about removing the blog page on “Where do you want to display Blog?” option. In fact I’m encouraging you to use the option along with the new blog style option. You don’t need to remove it on the “Where do you want to display Blog?” option. Also, please don’t set anything on Settings > Reading. Reset the settings on that panel to default if you’re using the theme’s Frontpage and Blog options.

    Cheers!
    Ismael

    #244357

    Ismael,

    If I do what you suggest (just selecting the “Use the advance layout editor for the blog page”), no matter what I put on that page, it stays blank! This is the problem that all the others are talking about here.
    You can try on my site (you have the logins), but please be careful as it is a live site with significant traffic.
    Cheers.

    #244359

    Just as loyalzoo said. Following those steps gives us a blank page, no matter what page we choose, it stays blank indeed.

    • This reply was modified 10 years, 4 months ago by DavyE.
    #244362

    Hi!

    I’m sorry about that but I tested this on my end and it works fine. Please remember to do unto others as you would have them do unto you. We ask that the tone be kept courteous (with a little fun on the side) inside the forum if that’s ok with you. I’ll check your website.

    Regards,
    Ismael

    #244364

    Hi!


    @loyalzoo
    : I logged in to your website but I don’t see the Theme Options. Did you disable it somehow ?


    @DavyE
    : Do you mind posting the login details here? We would like to check it. :)

    Cheers!
    Ismael

    #244366

    I’m not entirely sure what you mean by that, Ismael.

    #244369

    Hi!

    We’re asking for your username and password. You can create a new topic regarding the same issue then post the login details there as a private reply. :)

    Best regards,
    Ismael

    #244370

    I meant this:

    Please remember to do unto others as you would have them do unto you. We ask that the tone be kept courteous (with a little fun on the side) inside the forum if that’s ok with you.

    #244371

    Hi!


    @DavyE
    : Ah! I see. Sorry about that. That’s for @loyalzoo.

    If I do what you suggest (just selecting the “Use the advance layout editor for the blog page”), no matter what I put on that page, it stays blank!


    @loyalzoo
    : Please be patient with us as we’re trying our best to help you. :)

    Regards,
    Ismael

    #244372
    This reply has been marked as private.
Viewing 30 posts - 1 through 30 (of 39 total)
  • The topic ‘Advanced layout editor to build your own blog layout?’ is closed to new replies.