Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
    Posts
  • #566689

    Hi there,

    I’ve recently been having some major issues with the site. Basically, when I try to edit a page ( http://www.urbanessexcoalition.org/?page_id=2870 ), the normal wordpress edit page opens, but the advanced layout builder (where I’ve placed the text I need to edit in text boxes) won’t load. There’s the little spinning circle and it goes on for hours but never loads. This is happening across the entire page.

    Things I’ve tried that haven’t fixed it:

    1) Updating to latest Enfold version.
    2) Updating all plugins.
    3) Disabling all plugins and renaming the plugin folder something else
    4) Clicking the default editor button to try to switch back to the default editor (this doesn’t work. It doesn’t do anything)
    5) Updating WordPress
    6) Switching themes to one of the default WordPress themes (This let me edit the page while I was in the other theme, but when I saved the changes and switched back to Enfold, none of the changes were visible and the layout editor still wouldn’t load.)

    Any help would be really appreciated as my client is driving me crazy trying to get these changes made.

    Thank you.

    #566777

    Hi wingzfly,

    Removing your browser cache and reloading a few times usually helps, but please send us a temporary admin login so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Regards,
    Rikard

    #566846

    Tried clearing the cache out several times just now but that’s not fixing it. The never-ending load loop is happening on all pages, but here’s one as an example; you’ll see the problem when you get in on the WordPress side of it: http://www.urbanessexcoalition.org/?page_id=2870

    I’ve created a temp account for you with all of the information below.

    Thanks

    #566955

    Hi,

    You are using a very old version of the theme which is not compatible with newer versions of WordPress, please try updating to the latest version: http://kriesi.at/documentation/enfold/updating-your-theme-files/

    Make sure to back your site up in case something should go wrong during the update.

    Thanks,
    Rikard

    #663585

    I am having this same exact problem on my website: http://www.felixesquire.com.
    When I attempt to edit an existing page, the little circle keeps spinning. When I attempt to create a new page, the editor seems to load right up. I suppose I could copy and paste the code from the old page to a new one and then delete the old page, but that seems like a ton of work when I just want to update my office address and logo.

    Here are the things I have done so far:

    1. I updated WP to 4.5.3.
    2. I updated Enfold to current version.
    3. I turned off all plugins.
    4. I cleared the cache on my browser (Chrome v. 51.0.2704.103 m)

    I have not replaced the files with an FTP manual update, because that is a bit beyond my understanding. When I switched to the WP twenty fifteen theme, none of the editor problems existed. I was able to make manual text changes to the website. But when I switched back to Enfold, none of the changes survived.

    In addition to the ever-spinning circle, I also cannot make changes to any of the media in my media library, I cannot upload a new logo, and I cannot modify other small things on the page.

    I just changed offices, and I have not been able to modify the address on the webpage. I also changed logos, and I have not been able to update the logo.

    -Felix

    • This reply was modified 7 years, 11 months ago by fjpoggemann. Reason: Added further details showing attempts to use fixes from prior support forum discussions
    #663848

    Hi,

    Please try following the suggestions listed here: http://kriesi.at/documentation/enfold/my-enfold-layout-builder-is-not-loading-properly/

    Thanks,
    Rikard

    #664038

    I had taken all steps except the FTP upload, which I just finished.

    Now the website says this:

    Warning: require_once(config-events-calendar/config.php): failed to open stream: No such file or directory in /home/fjpoggemann/public_html/wp-content/themes/enfold/functions.php on line 427

    Fatal error: require_once(): Failed opening required ‘config-events-calendar/config.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/fjpoggemann/public_html/wp-content/themes/enfold/functions.php on line 427

    The rest of the website does not load.

    -Felix

    #664204

    Hi Felix,

    Please send us a temporary admin login so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #665488

    Login Information below.

    #666270

    Hi,

    There might be some corrupted files, so please delete all theme files completely via FTP, before installing a fresh copy from your themeforest account. Here is a short tutorial on how to install the theme via FTP, in case you are not sure how that works:

    Best regards,
    Andy

    #680405

    I’m having the same issues which started about a week ago. I can’t modify any pages now. I’ll try the above fix (annoying as it is) and post back an update.

    #680407

    Update: I deleted all the enfold files and uploaded a new copy from a fresh download. Still can not access the Advanced Layout Editor. I have not worked on my site since it was working last (maybe a week ago), so I can only assume it’s an update that was applied recently.

    Any ideas?

    #680408

    Sorry, another update: Now when I create a new page, the “Advanced Layout Editor” button does not do anything – as in does not change from basic editor.

    #680564

    I found MY solution to this problem – when “Quick Page/Post Redirect Plugin” was activated, Enfold Advanced Layout Editor did not work.

    #681160

    Hi @andrew_hambly,

    Great, glad you found the problem and thanks for sharing :-)

    Best regards,
    Rikard

    #802822

    I am facing the same problem on a multi-site build. It has been appearing on a sub-site built as a sub-folder. Currently, it only is happening on my front page of the site listed in the private content.

    I have done the following:

    • Completely deleted the Enfold folder from the themes folder and uploaded the latest Enfold download via FTP
    • Deactivated all plugins
    • Removed and extraneous functions.php code from my child theme

    None of these fixed the issue. I have tried refreshing the page, but this doesn’t solve it.

    I have found if I move back my revisions one step, I can at least get the Advanced Layout to show up and I can make ONE edit. Then the issue happens again.

    #802980

    Hi @ImageMagician,

    You are getting a 403 error on a WordPress file when I check the problem page, could you describe exactly what you did before that error happened? Also, does it only happen on that particular page?

    Next time, please open a new thread since it’s difficult for moderators to follow long threads like these with multiple users posting.

    Best regards,
    Rikard

    #803167

    Thanks, Rikard. My apologies. I thought commenting on the ticket with the same issue was the protocol.

    I am looking into the file permissions issue. This seems to be the culprit. I’ll comment back after my support team helps me solve the file permissions.

    #803282

    Hi,

    Ok, thanks for the feedback. Let us know if you should have any additional info for us, we’d like to know if the error happens on every page using the Layout Builder or only some.

    Best regards,
    Rikard

    #806238

    Rikard, I finally got my SysAdmin to change file permissions for all files and I’m still seeing the same 403 error for the admin-ajax.php file, but only on two of the four sites in my multi-site. The main site and the second site don’t throw this error, but my third and fourth do for every page.

    EDIT!!!!!
    I have discovered the trigger for this. ANY TIME I try to add an attribute to a tag in the “text” tab of the text editor, such as style=”font-size:24px” or class=”myClass”, it crashes the post. I have tried it with double quotes and single quotes. ANY type of attribute to a header tag or paragraph tag, etc., causes a 403 error to /wp-admin/post.php. Then, reloading the page gives you a 403 error to /wp-admin/admin-ajax.php.

    I never had this problem until the last few months.

    EDIT AGAIN!
    I’m finding other triggers that cause it to happen. That one is big, but there are others. I can’t for the life of me put together why it’s happening. I’ve made the temp admin account a super user and included the test page I’m using. At the state it’s in, it will save fine. The second I try to add anything else to it, it crashes.

    #807364

    Hi ImageMagician,

    Have there been any security changes on the server?
    Here is some reading on the possible issues.
    http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-403-forbidden-error-in-wordpress/
    http://www.devarticles.in/wordpress/wordpress-admin-ajax-403-forbidden-issue-fix/

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #814134

    Thank you all for your help. After pestering our support staff, they FINALLY looked at the server and noted that the security settings on the server were triggering a CAPTCHA every time a form fill was submitted to the wp-admin file when it isn’t the primary folder in the link, which is what happens on sub-sites using a sub-folder structure. They added an exception for this folder and my issue has been solved.

    I love support staffs that say “It’s your problem. It’s your problem. It’s your problem…oh, it’s our problem.” :)

    #814429

    Hi,

    Oh dear. :) We’re glad that the problem is fixed now, though! We’ll close this thread now. But if you have any other questions or issues about your theme, please feel free to post them here on the forum and we will gladly try to help you.

    For your information, you can take a look at Enfold documentation here – http://kriesi.at/documentation/enfold/

    And if there are features that you wish Enfold had, you can request them and vote the requested ones here – https://kriesi.at/support/enfold-feature-requests/

    Thank you for using Enfold!

    Sarah

Viewing 23 posts - 1 through 23 (of 23 total)
  • The topic ‘Advanced Layout Editor Stuck in Load Loop’ is closed to new replies.