Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #888009

    I am trying to set up the mobile view slide (the slider only has one slide) so that all of the elements of the slide load together right away. Right now only one element and the background load with the page. The rest of the elements only appear when l I tap screen or scroll. Thanks

    #888719

    Hey williamslyd,

    Thank you for using Enfold.

    The layer slider looks a little too small on mobile view. Please try to create a taller slider for mobile view. Add the following script to trigger the animation.

    // custom script
    add_action( 'wp_footer', 'ava_custom_script' );
    function ava_custom_script() {
    ?>
    <script type="text/javascript">
    (function($) {
    	function a() {
    		$(window).trigger('debouncedresize');
    		$(window).trigger('scroll');
    	}
    
    	a();
    })(jQuery);
    </script>
    <?php
    }

    Best regards,
    Ismael

    #891831

    Hello Ismael,
    What file and where in the file does your custom code snippet go? We are having a similar issue as williamslyd. On the mobile view of the advanced layerslider, only part of the slide renders in view. Once I start to scroll, the slide appears in full. I followed the templates provided by LayerSliderWP almost exactly to keep things simple.
    We upgraded to Enfold 4.2 and WordPress 4.9.1.
    Thank you!

    #891861

    Hi,
    Please add the code to the end of your functions.php file in Appearance > Editor or via FTP.

    Best regards,
    Mike

    #892062

    Hello Mike,
    Thank you for getting back to me so quickly. I added the code snipped provided by Ismael to the end of the functions.php, and it does render the <script> into the DOM, but it doesn’t seem to trigger the necessary response on mobile to resize the window to bring the layerslide in full view. We also used imported the “marketing pack” layerslider into the Enfold theme ‘as is’ and it doesn’t work properly in mobile within Enfold, but works fine outside of Enfold. https://layerslider.kreaturamedia.com/sliders/marketing-page-pack/

    Can you suggest any other options to try?
    Thank you!

    #892646

    Hi,
    I have tried logging in and looking at your sliders, but could not, please check login info. Testing on my Android shows that at mobile view (360px) the slider is mostly behind the header. Please see screenshot 1 in Private Content area.
    Yet when I hold my device landscape, (640px) the slider doesn’t show at all, Please see screenshot 2 in Private Content area. Do you have another slider for this size?

    Best regards,
    Mike

    #892722

    Mike,
    My apologies for the bad login. There is another account in the private content area. Per screenshot 1, yes that is the issue that the slider starts behind the header. I can’t figure out why. It then appears fully once you start scrolling.
    Ah, you are right that I am missing one for 640px. I will add that right away. Thank you for the catch.
    Thank you!

    • This reply was modified 6 years, 3 months ago by wcmetz. Reason: identified page the layerslider is on
    #893087

    Hi,

    Did you hide the layer slider on mobile view? A different content or section is displaying on smaller screens, which is better in my opinion, because layer sliders don’t work well on small screens in general.

    Best regards,
    Ismael

    #1130513

    i am having the same issue on with layerslider on my website and can’t seem to figure out why

    #1130546

    Hi,

    @nmckelvey
    sorry I do not see the same issue or your site, please explain further about your issue so we can be sure we are on the same page.

    Best regards,
    Mike

    #1130663

    Hi – on mobile (http://neci.army8dev.com/), you need to begin scrolling before any of the elements are visible. Not ideal user experience.

    #1130807

    Hi,
    Thanks for the feedback, please check the layerslider settings for the slide, it seems that it is triggered by a scroll.
    If you can’t find the setting please export the slider to DropBox and link to the Private Content area so we can examine it closer.

    Best regards,
    Mike

    #1131026

    Hi Mike, thanks for your help. I have exported the slider to Google Drive and posted the link in Private Content area.

    #1131150

    Hi,
    Thank you for the export, the slider works well on a clean install with only the woocommerce plugin.
    I see that you have a couple of warnings for “popupaqib” & “woo-category-slider-grid” Please see the screenshot in Private Content area. Please try disabling these and Then clear your browser cache and any cache plugin, and check again. I also see this error:

    MIME type ('text/html') is not a supported stylesheet MIME type, and strict MIME checking is enabled

    Please also test without the password on the page.
    An error on the page could cause the layerslider to stop working.

    Best regards,
    Mike

    #1131153
    This reply has been marked as private.
    #1131155

    Hi,
    I see that this is not your thread, so you can’t see the Private Content area. I will post publicly.
    https://i.postimg.cc/MTzhzfmM/2019-08-26-210633.jpg

    Best regards,
    Mike

Viewing 16 posts - 1 through 16 (of 16 total)
  • You must be logged in to reply to this topic.