Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1261031

    Hi,
    I created an Advanced Layer Slider, I added to one of my pages to test it and everything works fine (see bottom of page 1 in private content).
    The problem is when I add it to my homepage, it doesn’t work (see bottom of page 2 in private content).
    Could you please help me with this?
    Thanks a lot!

    If needed, you can find a link and credentials to my website in private content.
    Thanks a lot!

    #1261636

    Hi guys,
    Any help on this please? :-(
    This is very important for me to make it work quickly…
    Thanks a lot! ;-)

    #1261987

    Hi,
    Sorry for the late reply and thanks for the login, I copied your homepage to a test page with the Avia Layout Builder Debugger
    the layerslider also works on this page, I’m not sure why the layerslider on your homepage is returning an empty container, but I found this layerslider support ticket that suggests the issue is with jquery-migrate but this didn’t seem to help your site, I also looked in your functions.php for any scripts that might be causing this but I didn’t see any.
    Have you tried disabling all of your plugins? It is strange that this occurs only on the homepage without an error message.

    Best regards,
    Mike

    #1262050

    Hi Mike,
    Thanks for your reply.
    I already tried to copy the exact same content from my homepage to a test page and everything works correctly indeed.
    That’s the reason why I really don’t understand what happens here.
    So after receiving your feedback, i tried to deactivate all my plugins and it didn’t solve the issue. The only one I can not deactivate and check is WooCommerce, because by doing this my website has a fatal error.
    I also tried to install enable-jquery-migrate-helper plugin, but I think you tried it before.
    Nothing helped…
    The problem is I really need to make this slider work on my homepage :-(

    #1262053

    I tried one more thing: in WP settings I set my homepage to the other page with the Slider and the slider still works on the page, so I will try to duplicate my homepage and use the new one.
    I will come back to you after this to give you some news…
    Thanks Mike!

    #1262144

    Hi,
    Very good, we will wait for your reply.

    Best regards,
    Mike

    #1262210

    Hi Mike,
    It worked!
    I did not even need to duplicate my page. I only created a template of the content of my page, then deleted all ALB elements of my page and applied my saved template, and everything works perfectly now.
    Quite strange and a little bit worrying :-( but at least solved.
    Thanks for your help!

    #1262211

    Hi,

    I’m glad Mike was able to help! If you need additional help with this topic please let us know here in the forums.

    Best regards,
    Jordan Shannon

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Advanced Layer Slider doesn't work on homepage’ is closed to new replies.