Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #1115954

    I have been reading some of your old posts about adding Schema to my site. You had stated that there was a way through Enfold > Child Theme Options. However, there is no such option in my enfold version (4.5.7).

    #1116269

    Hey laptophobo,

    https://cl.ly/93cfcf1198b2 Are you referring to this option?

    Best regards,
    Victoria

    #1117043

    Oh, there it is. Thanks for directing me to the activation option.

    A couple of days ago, Yoast SEO updated their plugin that appears to be fixing the Schema issue on so many websites. So, my issue may be resolved.

    One other item though. In the Schema markup, it specifies my contact information (e.g.: phone number, etc.). Where are they picking that up? It’s at/near the activation checkbox you have directed me to.

    #1117468

    Hi,

    One other item though. In the Schema markup, it specifies my contact information

    Can you give us a screenshot of that? Did you add your contact information somewhere in the site?

    Thank you for the update.

    Best regards,
    Ismael

    #1117778

    You’ll see it in the view source (please see private content)

    #1118005

    Hi,

    I think you forgot the site URL. Please include it in the private field. Are you sure that you didn’t add that info anywhere? Is it attach to your email account or something like that?

    Best regards,
    Ismael

    #1118009

    oh, duh (slap forehead sound). please see private.
    thanks.

    #1118054

    I just activated the WP SEO Structure Data Schema plugin, which has added a schema below the one on line 28. (So, I know where that Schema content is coming from, but not the above one).

    #1118388

    Hi,
    I took a look at your page and the script on line 28 that has some of your info in it is in between the source code comments:

    <!-- This site is optimized with the Yoast SEO plugin --> ... <!-- / Yoast SEO plugin. -->

    and has the class “yoast-schema-graph” so I believe this is coming from your Yoast plugin.

    Best regards,
    Mike

    #1118440

    I finally found the spot in Yoast where they pull the Schema data from. It’s within the Search Appearance tools.

    Thanks for the help on this Mike.

    #1118449

    One final question. The new version of Yoast SEO plugin has a schema option, but only when the WP Block Editor is used. So, I’m wondering what would be the best companion plugin for schema markup for Enfold.
    I’m currently using WP SEO Structure Data Schema plugin, but it appears to not be fully compatible with Enfold.

    thanks again.

    #1118492

    Hi,
    Glad to hear you got it sorted out, sorry I have not looked into Schema plugins or seen any reviews in the forum.

    Best regards,
    Mike

    #1118732

    Hi Mike.
    Once I looked over several of my Enfold websites I’m seeing that there is a conflict with the new Yoast SEO schema markups and the theme. To give you an example, using an Enfold post from your website, i.e.: https://kriesi.at/archives/ (Purchase code hidden if logged out)(Purchase code hidden if logged out)(Purchase code hidden if logged out) -about-the-gutenberg-editor

    Now, if you paste that into the Google Structured Data Testing Tool: https://search.google.com/structured-data/testing-tool you will see errors.

    #1119014

    Hi,

    Thank you for the update.

    The theme provides very basic schema markup and so it’s up to the site owner to improve it. Unfortunately, we can’t help you with the schema markup generated by Yoast.

    You can actually install plugins that can generate schema.org JSON-LD syntax markup instead of the default inline schema markup, which is what the theme is adding to the template.

    // https://wordpress.org/plugins/wp-structuring-markup/

    You have to disable the theme’s schema if you chose to install the plugin.

    Best regards,
    Ismael

    #1119026

    Hi Ismael,

    Yes, using another plugin should do the trick. The problem right now seems to be coming from the upgrade at Yoast SEO. That is why I shared with you a link to your very own post (https://kriesi.at/archives/ (Purchase code hidden if logged out)(Purchase code hidden if logged out)(Purchase code hidden if logged out) -about-the-gutenberg-editor) where you can see for yourself (in Google Structured Data Testing Tool) the errors that is being produced–even within your own product example. ;-)

    #1119121

    I have isolated the problem on my site. I believe it is an Enfold bug that needs fixing. (Or not, you tell me.)

    To view the error, and to perhaps help me (and other Enfold users) how to work around it, please use this Post address within the Google Structured Data Testing Tool: https://dotorgwebworks.org/make-a-charity-website/

    Here you will see the errors appear. They are coming from the footer.

    Here is what’s happening:

    When I apply an iconlist within the footer of my website (using the feature in your Layout Editor to create a widget), i.e.:

    [av_iconlist position='left' iconlist_styling='' custom_title_size='15' custom_content_size='' font_color='custom' custom_title='#99cc00' custom_content='' color='custom' custom_bg='' custom_font='#ffffff' custom_border='' (Purchase code hidden if logged out) ='' (Purchase code hidden if logged out) ='' (Purchase code hidden if logged out) ='' av-medium-font-size='' av-small-font-size='' av-mini-font-size='' av_uid='' custom_class='' admin_preview_bg='']
    [av_iconlist_item title='Contact Us' link='page,5625' linktarget='' linkelement='both' icon='ue814' font='boat'][/av_iconlist_item]
    [/av_iconlist]

    it produces an “<article class>” tag before the item. Then the Structure Data Testing Tool expects that this is part of the post or something.
    So, I would like to be able to keep using the iconlist in my footer (column 1) widget, but not have it create the error message that you now are seeing.

    Can this be done?

    Thanks again,

    #1119350

    Hey!

    So, I would like to be able to keep using the iconlist in my footer (column 1) widget, but not have it create the error message that you now are seeing.

    Yes, that’s possible. Just disable the theme’s default schema markup — you can do that in the Enfold > Layout Builder panel and install the plugin that we suggested above. By disabling the theme’s schema, you get rid of error and with the plugin, you will be able to create a JSON-LD markup that’s not entwined with the template and will probably generate a more valid structure. Again, site data structuring or schema improvements is the responsibility of the site owner and/or developer, so it’s outside the scope of support.

    Cheers!
    Ismael

    #1119377

    Yes. This fixed it.

    I turned off the schema markup in Enfold > Layout Builder panel. Activated WP SEO Structure Data Schema plugin and entered the schema content and now it show no errors.

    Thanks for that.

    #1119866

    Hi,

    Great! Glad it’s fixed. Let us know if you need anything else.

    Have a nice day!

    Best regards,
    Ismael

Viewing 19 posts - 1 through 19 (of 19 total)

The topic ‘Adding schema to Enfold’ is closed to new replies.