Tagged: ,

Viewing 26 posts - 1 through 26 (of 26 total)
  • Author
    Posts
  • #330276

    I’m running a full SSL website on wpengine.com and per their advice the base URLs are http:// and the whole site is switched to https:// via a simple Regex pattern entered via their control panel. For background, this was running with no issues prior to changing to Enfold.

    I’m experiencing broken padlock syndrome on the Portfolio overview page though. Individual portfolio pages are currently set up with 1 image each (entered via the Enfold ALB image element option). The standard WordPress Featured Image option was used to select the same image, but I note your tutorial suggests a minimum of 700x700px, so have now uploaded different images for the featured image option. When viewed, the individual portfolio pages are not showing broken padlocks. The images were loaded via the WordPress media library from within the full SSL site.

    I’m using the ALB Portfolio Grid element on the /portfolio/ page. It’s set to use all portfolio categories, 4 columns, 16 portfolio items, no title or excerpt, auto grid image size, open entry on new page, display sort options, and show pagination. I haven’t found a combination of these settings that resolves the issue.

    As soon as more than 1 portfolio item is displayed on the /portfolio/ page, the page shows as insecure. With two portfolio items published, deselecting the featured images on one of the individual pages restores the /portfolio/ page to showing as fully secure. Why No Padlock and other advice sites I’ve tried always point at one of the images 260x185px size as the problem. One portfolio item can be displayed without triggering the insecure message, as soon as two are displayed the problem returns.

    I haven’t been able to find anything on your forums from others saying they have issues with the portfolio under SSL, so am wondering whether I’ve missed a setting, or perhaps this is somewhat specific to the wpengine hosting environment?

    Hopefully you can point me in the right direction to resolve this, as Enfold is by far the nicest theme I’ve ever worked with!

    • This topic was modified 9 years, 8 months ago by Sandie. Reason: Clarity
    #330616

    I’ve removed the 700x700px as using the same image twice doesn’t appear to have anything to do with the issue, and the other images look better.

    Has anyone experienced anything like this? I’m out of ideas, and could do with some advice.

    #330781

    I’ve removed ALL portfolio images and loaded them up again, this time through the core Media Library. The Portfolio overview page still shows a broken padlock.

    #330871

    Hey!

    Images show up fine on my end – http://i.imgur.com/u6Nu0sF.jpg
    I have checked your website on Firefox, Chrome and Firefox on OS X 10.9.5. Can you please flush browser cache and refresh your page a few times

    Regards,
    Yigit

    #330905

    Hi, you’ve missed my point. The images have always displayed. The broken padlock (insecure content warning) is the issue I’m concerned about.

    #330911
    #330964

    I don’t really see how that addresses the issue? I have no reason to migrate the database.

    The site was on full SSL with no issues before installing Enfold. The rest of the site is fine. The problem occurs when using the Enfold ALB portfolio element. Something about the implementation is causing one size of the images to then show up as insecure. If I use the same images in other ways, the pages do not become insecure.

    The image on the homepage, added to the website using the media library, and the ALB image element does not cause the page to appear insecure.

    How do I set up a portfolio overview page without causing my portfolio section to warn my users about insecure content?

    • This reply was modified 9 years, 8 months ago by Sandie.
    #330986

    OK, I’ve had WPengine review the site, and they can’t find any issue with the SSL installation.

    How do I set up a portfolio overview page without causing my portfolio section to warn my users about insecure content? Am I doing something wrong?

    #331013

    I’ve updated the theme to 3.0.1. The page using the ALB portfolio element is still showing as insecure, and when I link more portfolio items to it they start showing as insecure also.

    If I use the overwrite portfolio link setting on the individual portfolio item page, and use it to define a custom link to the https:// portfolio item, the pages still show as insecure.

    • This reply was modified 9 years, 8 months ago by Sandie.
    #331026

    Forgot to mention that this problem persists when I de-activate all plugins.

    How do I set up a portfolio overview page without causing my portfolio section to warn my users about insecure content? Am I doing something wrong?

    #331528

    Environment
    Host: wpengine
    WordPress: 4.0
    Enfold: 3.0.1
    Plugins: problem also occurs when all plugins are deactivate
    SSL: checked yesterday by wpengine and declared to be working as it should. No SSL issues occur when other themes are used on the same installation.

    Problem
    With only 1 portfolio item activated in the Portfolio, the SSL is fine (no insecure content warnings). As soon as I add a second portfolio item insecure content warnings appear. If I de-activate both items, and activate them in the opposite order the same problem appears. The same issue is viewed if I select 2 completely different portfolio items to make them active.

    The portfolio element seems to be calling an image via https for the first portfolio item, and all subsequent portfolio items by http. Please could someone review this?

    • This reply was modified 9 years, 8 months ago by Sandie.
    #331772

    I’m finding the forum incredibly frustrating as I can’t tell if or when my issue will get a response. Is there a support queue I can get into please?

    #331857

    *bump*

    #332189

    Hi!

    I’m sorry for the delay. Have you tried using this plugin? https://wordpress.org/plugins/wordpress-https/installation/

    Best regards,
    Ismael

    #332224

    My entire site is already forced to SSL via a Regex pattern. wpengine.com have reviewed the setup, and confirmed that it is correct. Please could you confirm that you have tested the ALB portfolio element on an SSL enabled site?

    #332433

    Hi!

    As i see Kriesi and Peter was notified about your thread. Please kindly wait to hear from them

    Cheers!
    Yigit

    #332439

    Thanks for the update Yigit.

    #332586

    Hey Sandie!

    Are you running a plugin like https://wordpress.org/plugins/wordpress-https/ on your site as well? The theme uses native wordpress functions to fetch those images so it should work well with the plugin. If that does not solve the problem:

    Would you mind posting me your login credentials for both, your wordpress installation as well as your ftp data so I can try to fix it directly and once I have found a solution add it to the next patch
    Regards,
    Kriesi

    #332634

    Hi Kriesi, thanks for taking a look at this.

    All my other SSL sites on wpengine run fine without the plugin so I’m not familiar with it and would prefer to play around with it locally and understand what it’s doing rather than let it near my live site ;-) I will sort access out now to allow you to investigate, and post again when the details are ready. If it’s not a quick fix I can drop that section of the site out of SSL and wait for the next release. My main issue with the broken padlock is that my typical customer isn’t very knowledgeable about them, and a broken padlock frightens them more than no padlock!

    BTW, the theme is amazing, I was particularly happy to find such a great theme with a good focus on SEO and on formats and I’m hoping to start using it a lot.

    Regards,
    Sandie

    #332638
    This reply has been marked as private.
    #332641
    This reply has been marked as private.
    #332679

    Hi!
    the posts are privat if they got a blue border around them, so everything worked fine :)
    Just try again ;D
    Regards,
    Kriesi

    • This reply was modified 9 years, 8 months ago by Kriesi.
    #332732

    Ah, the blue was a little too subtle on my screen! If you scroll up to the top of the thread, I added the info in the private post there (that one says ‘private data’ so I felt safer) :-)

    #333825

    Please let me know when you’ve reviewed as I’d really like to remove the SSL from that section until a resolution can be found.

    Thanks!

    #334301

    My host advised me to leave my WordPress Address (URL) and Site Address (URL) entries as http:// and to just use Regex to force https://. I can’t find any compelling reasoning for or against this, but moving to https:// makes more sense to me, and has resolved the issue raised.

    I believe the problem raised could be resolved by altering the theme code to call the images using a different method. This would hopefully prevent other users with sites on http:// that are forced to https:// experiencing the issue.

    Since my site no longer displays this issue, I’ve removed the access information.

    Please close this thread.

    #335375

    Hi!

    I am glad your issue was resolved.

    Best regards,
    Arvish

Viewing 26 posts - 1 through 26 (of 26 total)
  • The topic ‘Adding portfolio overview images causes insecure page on full SSL website’ is closed to new replies.