Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #904302

    Hi guys,

    I’m struggling with adding custom post types/custom taxonomies to my site.

    I already downloaded and activated the Toolset Types plugin (formerly Types) and while I successfully created a new custom taxonomy, the Avia Advanced Layout Builder and Side Bar Control is still a no show.

    Some posts in the forum suggest that to accomplish that, you would need to either modify the functions.php file of the child theme https://kriesi.at/documentation/enfold/use-the-layout-builder-with-any-post-type/ or the config.php file in the template builder folder, but none of this has done the trick for me.

    I also followed the procedure outline by Tamez https://kriesi.at/support/topic/procedure-for-adding-custom-post-type-and-enabling-it-for-use/ but this didn’t bring any joy either.

    I’m referencing these processes, so that users in the same position as I am, won’t waste their time following them. I reckon that they are just outdated and both the Enfold theme and the Toolset Types have been updated/upgraded multiple times since they were posted.

    So, now my question, how would I add the Avia Advanced Layout Builder and Side Bar Control functionalities to a custom taxonomy created with the Toolset Types plugin?

    Many thanks for any pointers. I truly appreciate your support.

    #904942

    Hallo Zusammen,

    gleiches Problem hier. Wie bekomme ich (und das hatte ich auch am Anfang – nach dem Update nun nicht mehr) den Avia Layout Builder wieder in die Toolset-Customs integriert?

    Brauche schnelle Hilfe

    #905151

    Hi,

    Can you please provide us with information so we can access your web site and try make it work out?

    Thank you

    Best regards,
    Basilis

    #905453
    This reply has been marked as private.
    #905473

    Hey guys, I guess YIGIT could help us out with that issue? Do you have any idea?

    #905500
    This reply has been marked as private.
    #905555

    Hey – I’ve fixed it myself.

    Thank you

    #905797

    @nicweb, how? If you would share your fix, then everybody, including future readers of this thread could benefit from it.

    Many thanks

    #905839

    Hey Nic, please share your experience with us. Would be really nice ;)

    #905859

    Hi,

    We are in touch with Toolset team. We applied necessary changes and currently they are testing it on their side. However if you guys are using Enfold 4.2.2 and still having issues, then clearly something is wrong.

    I assigned this thread to myself and will be sharing updates here. Thanks for your patience! :)

    Best regards,
    Yigit

    #905867

    Thanks for the update Yigit. Truly appreciate it.

    Just for you to know, I updated to Enfold 4.2.2 a few days and as of now, there’s still no sign of the Advanced Layer Builder on my installation.

    Thoughts?

    #906684

    Hi,

    @MadRhino: The ALB is accessible on @nicweb‘s custom post type “veranstaltung”. I would like to check yours but the login credentials above are not working.

    Best regards,
    Ismael

    #906761

    Good morning Ismael, thanks for getting back to me.

    Thanks for sharing Nikko’s solution, Ismael. I’ll be happy to check it out.

    It’s strange with the login information because I’ve been notified that somebody using that account has logged in twice and, just a few days ago, that the password has been changed.

    Either way, I’d appreciate it, if you could give it another try. I listed new login credentials below. I cut and paste them directly from the user account, so, if you do the same, it should work. I tried it and it worked.

    Many thanks for looking into this again, Ismael. I appreciate your help.

    #906818

    @ismael

    I tried looking up NicWeb’s solution, but the link you provided only points to his profile, where there’s nothing to be found that resembles “custom post type “veranstaltung”. All I can see is the 3 non-descript replies he created in connection with my forum post.

    Where am I going wrong here?

    #907584

    Hey, @Ygit, @ismael,

    I have to admit that I’m disappointed over your support on this issue.

    Although it’s quite obvious that this problem concerns more than just a single user, your responses have been somewhat indifferent and not really helpful to find a solution. For instance, what’s with this ominous NicWeb, who allegedly fixed the problem, but his fix is nowhere to be found? Or your unsuccessful logins to my site? It’s a bit strange to be honest.

    Anyways, if the Toolset Types plugin is at fault here, then, it’s probably evidence that they’re not off to a good start setting the stage for their paid plugin. If that’s the case and they’re dragging their feet, I would have expected to hear this from you, perhaps along with being pointed to a workable alternative. Otherwise, everybody is just wasting time while the folks over at Toolset Types are trying to reinvent the wheel.

    At this point, I’m inclined to uninstall the Toolset Types plugin again, because it’s not working.

    Maybe you have a few thoughts on this?

    #907651

    Hi,

    Thanks for sharing Nikko’s solution, Ismael. I’ll be happy to check it out.

    I’m sorry but I didn’t share a new solution because the default “avf_builder_boxes” filter should be working as is. We can now access the dashboard so we added the filter and then created an “editorial” post using the advance layout builder. ( see private field )

    Best regards,
    Ismael

    #907808

    Thank you Ismael, I can see that the Advanced Layout Builder works now.

    The problem that remains is that I still can’t incorporate any posts from this new custom post type (Editorial) into content elements such as the Masonry grid.

    I thought that I created the required custom taxonomy (articles), but it won’t show under available Categories, when working with the Masonry grid.

    Would you mind looking into that for me please? Many thanks.

    #907816

    Hey guys, maybe I’m just too blind, but how do I get it working?

    • This reply was modified 2 years, 7 months ago by  Chris.
    #908141

    @chris.

    No, you’re not blind Chris. They’re just rather cryptic about pointing to a solution for this issue. Don’t know why this is either. Ismael got my Advanced Layout Builder to work, but I don’t know how. At this point, I’m still struggling with the corresponding custom taxonomy. I thought that I set it up correctly, but it’s still a no show in the Masonry grid element. I reckon that this is more Toolset Types related.

    Thinking about moving to a multisite install now

    #908379

    Hi,

    They’re just rather cryptic about pointing to a solution for this issue. Don’t know why this is either. Ismael got my Advanced Layout Builder to work, but I don’t know how.

    @MadRhino: The solution has been provided in this thread all along. It’s in your functions.php file. Here’s how:

    // https://kriesi.at/documentation/enfold/use-the-layout-builder-with-any-post-type/

    You need to adjust the default value “post” to your own custom post type slug or name, which is “editorial”. The taxonomy “article” doesn’t have any terms yet so we created one called “Article 1”. We selected this taxonomy and term in a masonry element. ( see private field )

    @chris: Please create a new thread with the site url and the login credentials. We’ll check it there.

    Best regards,
    Ismael

    #909436

    Thanks Ismael. It works now.

    I’m sorry, but I didn’t see the post you mentioned in your reply. There are so many and, naturally, I was focusing on later posts in my research. Thanks. I appreciate your patience and hands-on help with this.

    #909793

    Hi,

    No problem. And sorry for the confusion. Please feel free to open a new thread if you need anything else. :)

    Best regards,
    Ismael

Viewing 22 posts - 1 through 22 (of 22 total)

The topic ‘Adding Advanced Layout Builder to Custom Taxonomy under New Toolset Types plugin’ is closed to new replies.