Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #977681

    Hi masters,

    i have added an URL to the “Product-URL” field in Product Properties:

    Product URL

    If i click on the “Add to cart” button on the shop main page, it works. Here the selected product will be added to the cart of my vendor Digistore24:

    Cart button on Shop main page
    Product added to cart

    But, if a click on the “Add to cart” button on the product page, i will be redirected to the sales page of my vendor, instead that the Product will be added to my cart like shown in the screenshot before:

    Cart button on product page
    Digistore Sales Page

    I thought, both buttons should be use the same URL but the behaviour/target seems to be different … can anyone help me here?

    thanks and regards
    Kai

    • This topic was modified 3 weeks, 2 days ago by  Neo130582.
    • This topic was modified 3 weeks, 2 days ago by  Neo130582.
    #977782

    Hey Kai,

    None of the screenshots you posted seem to be loading, could you check please? Also please post links to where we can see the actual problem.

    Best regards,
    Rikard

    #978192

    Hi Rikard,

    please look to my first post … now the Pics are visible .. sorry for that.

    thanks and regards
    Kai

    #979038

    Hi Rikard,

    do you need more details? i know, it is mabe not easy to understand what i mean.

    thanks and regards
    Kai

    #979120

    Hi,

    Yea, if you can would be much appreciated, we are not sure we know exactly what is going on here.

    Best regards,
    Basilis

    #980197

    Hi guys,
    ok, here it comes … i thought it could be a good idea to show you the problem via video :-).
    please have a look here:

    Button-Link problem

    Additional Info
    Digistore24 Java Snippet

    thanks and regards
    Kai

    #981234

    Hi Kai,

    Thank you for the video.

    The difference is that from the product list, the product is added to the cart via the ajax call and on the single product page the page reloads or redirects to the cart page or to the sale page that you have configured.

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #982422

    Hi Victoria,
    thanks for reply … here next video for you :-).
    Link-Difference

    regards
    Kai

    #982756

    Hi Kai,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look?

    Best regards,
    Victoria

    #982993

    Hi Victoria,

    ok, credentials has been sent.

    regards
    Kai

    #983096

    Hi Kai,

    I’m not sure where you sent them? Please post them in private in your reply so that all moderators have access to them.

    Best regards,
    Rikard

    #983137

    Hi Rikard,

    i have inserted all in the “Private Content” field below and made a tick on “Set as private reply”.
    I that not right?

    regards,
    Kai

    #983186

    Hi Kai,

    Where did you send them? Can you please share them here in private?

    Best regards,
    Victoria

    #983529

    Hi Victoria,

    see my question from yesterday:
    “i have inserted all in the “Private Content” field below and made a tick on “Set as private reply”.
    I that not right?”

    i have now posted a test text once again … please tell me if you have got it, then i will post the credentials again.

    thanks and regards
    Kai

    #983764

    Hi Kai,

    Do you see the screenshots in private below?

    Best regards,
    Victoria

    #983776

    Hi Victoria,
    yes i see.
    Ah, now i think i know whats the problem. I have to fill both fields … a normal text in the message box and then the private content in the private box .
    I have ONLY filled the private box.

    Now you shold see private content.

    regards
    Kai

    #984575

    Hi Kai,

    Yes, it is like that. The links are the same.

    Best regards,
    Victoria

    #984645

    Hi Victoria,

    sadly no. This java script error was not the problem. It was because of missing plugin-configuration … i have corrected it.
    The link problem is still present. The links are not really the same … as you can see in your screenshots the link on the product list page is:
    https://www.digistore24.com/cart/add/225064

    and the link in the shown code screenshot is:
    https://www.digistore24.com/add/225064

    Can you compare the functionality of the button on the “list page” with the function of the button on the “single page”? … any step in the functionality of the “list page” button (ajax call?) seems to modify the link before execution and redirects that to a different behaviour.

    thanks and regards
    Kai

    #984725

    Hi Kai,

    You might want to address this question to the WooCommerce forums as well.

    Best regards,
    Victoria

    #984766

    Hi Victoria,

    ok thanks. I will try to clear it there.

    regards
    Kai

    #984882

    Hi,

    Let us know if there is something else we can do for you!

    Best regards,
    Basilis

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.