Forum Replies Created

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • in reply to: LayerSlider problem with RTL in Enfold 4.4.1 #986790

    Just to elaborate on my previous post.
    The slider in frontpage is NOT in RTL.
    I’m sure you know that right-to-left direction is totally different from right alignment.
    Please check the front page again. I added some text under the slider to show how it should look like.

    in reply to: LayerSlider problem with RTL in Enfold 4.4.1 #986774

    I didn’t do anything to enable that. Just installed wordpress and enfold and inserted the shortcode and it worked.
    Apart from the shortcode problem, even using the advanced layout builder to insert the slider is not perfect. You can see that I used layout builder to insert a slider in the homepage, but the texts in the slider are not in RTL.

    in reply to: Blog next/previous arrows in RTL #986572

    Thank you
    The code worked perfectly.

    in reply to: CSS file merging does not work #986295
    This reply has been marked as private.
    in reply to: LayerSlider problem with RTL in Enfold 4.4.1 #986249

    The theme’s css/js compression is enabled, but enable or disabling that has no effect.

    in reply to: LayerSlider problem with RTL in Enfold 4.4.1 #986039

    Sorry for the late response. The website was not live so I could not post a url to that.
    I have uploaded it somewhere so you can see that. The url is in the private content section
    As you can see there are 2 pages in the menu bar.

    In the first page (the homepage), I have used the advanced layout builder to insert a layerslider. The second slide has some texts and you can see they are being displayed in ltr.

    In the second page, I used shortcode to insert the layerslider. You can see that in this page, not only the texts in the second slide are in ltr, but also the slider has messed up the rest of the page content and made them ltr too!

    • This reply was modified 2 years, 2 months ago by  rezaies.
    in reply to: LayerSlider problem with RTL in Enfold 4.4.1 #980364

    I don’t believe that it is solved. what I did was just a workaround. But I think this is an issue that needs to be addressed in the following updates.

    in reply to: LayerSlider problem with RTL in Enfold 4.4.1 #979929

    I had to add the following to the quick css:

    .rtl .ls-layers p,
    .rtl .ls-layers a,
    .rtl .ls-layers h1,
    .rtl .ls-layers h2,
    .rtl .ls-layers h3 {
    	direction: rtl;
    }
    in reply to: LayerSlider problem with RTL in Enfold 4.4.1 #979849

    Also, all other contents of the pages that contain a slider (even outside the slider) are in LTR. As soon as I remove the slider from those pages, the issue is fixed. So it seems that some CSS rules that belong to LayerSlider mess with the page content.
    I investigated a bit and it seems to be the following from enfold/config-layerslider/LayerSlider/static/css/layerslider.css

    	html .ls-container,
    	body .ls-container,
    	#ls-global .ls-container,
    	html .ls-container .ls-slide-transition-wrapper,
    	body .ls-container .ls-slide-transition-wrapper,
    	#ls-global .ls-container .ls-slide-transition-wrapper,
    	html .ls-container .ls-slide-transition-wrapper *,
    	body .ls-container .ls-slide-transition-wrapper *,
    	#ls-global .ls-container .ls-slide-transition-wrapper *,
    	html .ls-container .ls-bottom-nav-wrapper,
    	body .ls-container .ls-bottom-nav-wrapper,
    	#ls-global .ls-container .ls-bottom-nav-wrapper,
    	html .ls-container .ls-bottom-nav-wrapper *,
    	body .ls-container .ls-bottom-nav-wrapper *,
    	#ls-global .ls-container .ls-bottom-nav-wrapper *,
    	html .ls-container .ls-bottom-nav-wrapper span *,
    	body .ls-container .ls-bottom-nav-wrapper span *,
    	#ls-global .ls-container .ls-bottom-nav-wrapper span *,
    	html .ls-direction-fix,
    	body .ls-direction-fix,
    	#ls-global .ls-direction-fix {
    		direction: ltr !important;
    	}
    in reply to: LayerSlider problem with RTL in Enfold 4.4.1 #979839

    my html code did not work in the above post, but I think you know what I meant.

Viewing 10 posts - 1 through 10 (of 10 total)