Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #19790

    Here is a link to the thread describing the issue I’m having:

    Link to the form on my page:

    Basically, something in the shortcodes CSS is causing the styling of the form to be ‘filtered twice’ according to the developer of the plugin. I’ve tested with another theme and can confirm it’s Propulsion causing this and not another plugin. When I remove the shortcodes, the styling is fine. This is not only an issue with the form plugin, but appears to cause issues with the use of <h-> (webfonts) tags within the shortcode tags as well.

    A link to the home page showing the <h-> tag problem is here:

    All of the blue headings have the same <h3> tag as the headline ‘Do Not Remove’. Shortcodes start below the horizontal rule.


    Hi janeyj,

    Did you try their solution of:

    [raw][ formidable id=x ][/raw]

    The heading styling is what is styled when inside a column shortcode. You can target and change heading styles inside the columns with:

    #top .flex_column h3 {

    Using h1,h2 etc and whatever css you want for the style.




    I did try their fix. It does nothing and the [raw] tags display as regular content/characters. I’ve had to use that fix before on another site and it worked correctly. If I remove the column shortcodes from around it, everything works fine.

    Also…is there something I’m doing wrong that my Webfonts aren’t always displaying? On my laptop, they’re fine. On my desktop, they don’t display. Both Macs, both running the same version of Firefox. Only difference is I don’t have that font installed on the desktop.


    If the font isn’t installed on the computer, it won’t show up to the user. Typically Helvetica isn’t installed on most windows machines by default so it will revert to Arial just as an example.

    I’ll tag another of the support crew on the column+plugin issue as I’m not sure what from the theme would be adding additional breaks into the forms output.




    That’s interesting about the webfonts. I’d never heard that (and never used webfonts previously), but doesn’t it kind of defeat the purpose? I’d be better off to use cufon if I wanted it consistent for all users then, right?

    Thank you for tagging another crew member on the shortcode issue. I’m at a bit of a loss on that one and it’s a big problem.


    Well, let me re-phrase a bit so we are definitely on the same topic. There are a selection of Web Save fonts which are the standard set of fonts often found on most computers. Still no guarantee, but its generally going to be the same set or very close and you aren’t loading in a font.

    Otherwise, you can pick one of the google fonts to use.


    Right, and maybe I’m being misleading by saying webfonts. I understand the use of web save fonts, but I was referring to the GOOGLE FONTS for the headings. You’re saying they will only display if the user has the font installed?


    No, Google fonts should be loading in as long as the page is capable of pulling in the font file. However the heading font style is different for headings inside columns if that is the issue.


    Nope. That’s not the issue. Something isn’t right with Google font’s then. When I load the page on my work computer, the Google font isn’t loading (anywhere…slideshow, headings, etc.). But on my laptop where I’ve done all of the work for this, it’s fine.

    See here:

    Also…any word on the shortcode issue? Hitting the site aggressively tomorrow and anticipate launching in the next week or two.

    Thank you so much for all of your help!


    There could be something causing it not to load on that single computer. If its a specific browser/OS or system setup as often work computers have security settings that are more stringent there may not be anything we can do about it.

    You can try visiting the google fonts site on your work computer and see if it works there.


    Still hoping for a response on the shortcode issue??? Please!



    Try to add following code to css/custom.css:

    .frm_form_fields br{
    display. none !important;




    Nope. Still no luck. I think I’ve found a solution, though. Rather than using the shortcodes, I’m using class defined <div>s with the column specs out of grid.css. Just a heads up if anyone else has the problem. Thanks for your efforts!


    Glad you were able to find something that works for you :)

    Let us know if you have any other questions or issues.



Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Shortcode conflicts’ is closed to new replies.