Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #12048

    Hi there,

    Every time I create a new page, the default widgets appear in the sidebar. To get rid of them, I go to sidebar in the abundance theme options and select that new page to receive a new sidebar. It took me a while to figure out that every time I add this new sidebar to a new page, the sidebar on the page I had previously added to disappears. So, for instance, I just added a new sidebar to the “about” page and “the yarns” page sidebar reverted back to the default widgets in the sidebar and is no longer available in my list of widget areas. Am I going about this the wrong way?



    Oops forgot to add links, the site is, and the pages I’m talking about are and

    and actually, one more question. I like the width of the sidebar on the homepage. How can I apply this to all sidebars? I have this in the custom CSS to achieve the homepage ratios, but the homepage is a dynamic template with this customization, so not sure how to do it for the rest of the sidebar widths.

    grid8 {width: 600px;


    .grid4 {width: 300px



    OK, I added sidebars to the pages all at once (which erased ALL of the sidebars I had previously created, including the sidebars on the homepage which is a dynamic template) and this seemed to work aside from having to recreate all the sidebars that disappeared, but now what if I want to add another page with another sidebar? How do I add new sidebars without the other sidebars disappearing?


    Hi pollymac,

    Once you add any widget to the default sidebars, the default widgets will no longer ever appear which would prevent you from having to continually create more sidebars.

    Sidebars and widgets can be a little bit tricky in that they go in a numbered order, so when you move them around (delete, add etc) you can get circumstances like you are describing. I’d recommend planning it out and trying not to remove any unless you absolutely have to.

    as for the sidebar css question, Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    .content, #top .fullwidth .template-blog.content{
    width:690px !important;
    padding-right: 30px;
    .sidebar {
    width: 179px;




    Hi Devin,

    Not sure I’m following you here: “Once you add any widget to the default sidebars, the default widgets will no longer ever appear which would prevent you from having to continually create more sidebars.”

    In the theme options, I’m clicking “sidebar” then “Select a PAGE that should receive a new widget area:”. I select the page (which is set to the default layout) and save. This makes the widget areas on the homepage (a dynamic template) disappear, and in appearance–>widgets, I added the content to the new widget area I just created and the default widgets are appearing–not what I added.

    Are there theme docs somewhere? Couldn’t find them in the theme zip file.

    Thank you so much for your help!


    Hi pollymac,

    Try adding a single text widget to the widget area “Display Everywhere”. This should eliminate the widgets from appearing. The alternative is removing the code from the theme that introduces the widgets in the first place.

    The theme documentation is indeed in the main zip that you download from theme forest. There should also be the PSD folder, plugins, License and a version.rtf.



Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘widgets disappearing when I add sidebars to new pages’ is closed to new replies.