Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #955316

    When I update a page I get these errors…

    Warning: Cannot modify header information – headers already sent by (output started at /nfs/c01/h05/mnt/14872/domains/merrybower.co.uk/html/blog/wp-includes/functions.php:1476) in /nfs/c01/h05/mnt/14872/domains/merrybower.co.uk/html/blog/wp-admin/post.php on line 198

    Warning: Cannot modify header information – headers already sent by (output started at /nfs/c01/h05/mnt/14872/domains/merrybower.co.uk/html/blog/wp-includes/functions.php:1476) in /nfs/c01/h05/mnt/14872/domains/merrybower.co.uk/html/blog/wp-includes/pluggable.php on line 1216

    It seems to be pointing to the functions.php file, with the function wp_nonce_field the focus:
    function wp_nonce_field( $action = -1, $name = “_wpnonce”, $referer = true , $echo = true ) {
    $name = esc_attr( $name );
    $nonce_field = ‘<input type=”hidden” id=”‘ . $name . ‘” name=”‘ . $name . ‘” value=”‘ . wp_create_nonce( $action ) . ‘” />’;

    if ( $referer )
    $nonce_field .= wp_referer_field( false );

    if ( $echo )
    echo $nonce_field;

    return $nonce_field;
    }

    Line 1476 is “echo $nonce_field;” in the above listing.

    Any ideas? The page still saves correctly, but after hitting the Update button after editing, it’s annoying to see the error page rather than returning to the Edit Page.

    #955610

    Hey kopperdrake,

    Thanks for the description. Could you please provide us with a temporary admin login so that we can take a closer look? You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #956432

    Hi Rikard, thanks for getting back – details attached :)

    #956816

    Hi,

    Thanks for that, though I can’t find the login URL, could you post that as well please?

    Best regards,
    Rikard

    #956863

    Hi – I’ve posted the main website URL below and then also the page where the error occurs when I try to update it. The updates do make it through to being published, despite the errors, as far as I can tell.

    Cheers,

    kopperdrake

    #957314

    Hi,

    Thanks for that, though the login details are not working. Could you check and verify please?

    Best regards,
    Rikard

    #957404

    Hi Rikard,

    Sorted now – thanks for being patient!

    #957953

    Hi,

    Thanks for that, I get the same problem when I try to update the post. Could you try to update the theme to the latest version (4.1) to see if that helps please? If not then please try to deactivate all plugins to see if one of them is causing a conflict.

    Best regards,
    Rikard

    #958360

    Hi Rikard,

    I’ve updated to 4.1 and also WP to 4.9.6, but the problem still persists. Might it be WP Booking System that is used on that page? I’m unsure if I turn it off if I will lose all the data for bookings we have. If not then I can try deactivating it.

    #959225

    Hi,

    Can you please ask the plugin developer if it is safe to disable it so we can be able to check better?

    Best regards,
    Basilis

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.