Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #8034


    I’m trying to upload new images to a gallery page, that is presented on my site as a single ongoing gallery. I’ve been updating it periodically for a while, but just recently it won’t let me upload any new image files thanks to:

    The uploaded file could not be moved to /home/xxxx/public_html/xxxx/wp-content/uploads/2011/10.

    There are two issues here. Firstly, why no permission? (i’ve tried changeing chmod permissions to every open variable with no difference) But also I don’t neccesarily want the images to upload to 2011/10 i want them to upload to 2012/01 (which does exist as a folder). I have tried to trick the page by forcibly changeing the publish date to this month, but that made no difference.

    How can I fix this, and/or how can I force the gallery to upload to the most recent dated folder?

    This is a Flexible Grid Gallery in a Page with the Flashlight Theme.



    Any ideas? That it wants to upload to an outdated folder must surely relate to the theme, and not generic permissions issues? Are there settings for this anywhere or a file to edit?



    plase try to chmod the uploads folder itself (and include all its sub directories). I’d try 777 and 755.


    As stated in my opener, I’ve tried every chmod variable, which includes going right down the line, opening every containing folder and subfolder to both 755 and/or 777 temporarily making the whole thing wide open.

    It makes no apparent difference. What I think I’m really concerned about is forcing the gallery to upload to the new, more recent folders. Even though such folders have been automatically generated, it isn’t using them.


    Try to open up framework/php/class-htmlhelper.php and search for following code:

    $postId = avia_media::get_custom_post($element);

    Replace it with:

    global $post_ID;
    $postId = $post_ID;

    This will attach all images to the current post instead of the “hidden” attachment post.


    Cheers, but that made no difference. Does it matter for that fix that the gallery in question is in a ‘page’ not a ‘post’. Is there some inherent discrepancy preventing me from using a permanent page as a regularly updated/modified gallery over time?

    What specifically happens, and is continuing to happen is that if I try to upload an image (from the desktop) it starts uploading it then cuts out part way. If I upload two or more images it will make that same broken attempt to upload the first image, then cease and give me the above warning on the second image. So it’s like it tries, then realises it can’t. No idea if that makes any difference?


    Any ideas what, besides permissions, could be causing an upload to constantly fake out?

    I’ve changed/checked my chmod via both ftp AND Cpanel to ensure I have access and I have currently unchecked the ‘Organize my uploads into month- and year-based folders’ box in WP>Settings>Media to see if disabling the date function helped. It didn’t.

    The files are sorta-almost uploading, that is, depositing zero-k ghost files in the directory with appropriate file names, even generating ghosts of all the file size variables that Flashlight creates. Which suggests to me it’s not a permissions thing (and its not a connection thing, rest of my web service is fine). But basically not letting me upload.


    FYI, future readers; ‘resolved’ this by completely deleting the wp content folder, and restoring it from (completely identical) backup (stored only minutes earlier). Not especially elegant or logical, but worked for now.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Upload error, date related’ is closed to new replies.