Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #15428


    It’s my first time building a WordPress site from localhost on my computer rather than building from a remote host. I got everything up and installed and have MAMP running. I created an .htaccess file to direct the directory to Shoutbox’s index.php, and as of now what I see on my screen in the dashboard is like any other WordPress site I’ve built. However, I’m unable to upload any media from there. I’ve looked at other similar posts on the forum but they all say there’s a dialog saying they don’t have permissions and whatnot. Mine simply doesn’t do anything when I click the buttons “select files” or “upload”, and the post pages don’t have any toolbar in the Visual tab. In fact, I can’t write in the body of the post at all. Where’d I do wrong?

    Thank you,



    Hi Amy,

    First check to see if one of the default wordpress themes (twenty eleven for example) lets you do all the basic wordpress functionality. Try uploading an image, creating pages etc. If all goes well then we can narrow it down to something not meshing with your local set up and the themes needs. Otherwise, check with the MAMP documentation on getting things set up properly.

    If you can, post here what your local server set up is (php version, allocated memory etc) and we can try and figure out what might be the cause but without actually being there and seeing how everything is set up its a bit hard.




    Hi Devin,

    Thank you for your instructions. I switched over to Twenty Eleven, and there I was able to upload a header – but when I tried to upload media via the Media tab in the dashboard, or write text / add media in the Post tab, I was unable to do so, just like before. I switched back to Shoutbox to see if the logo had at least stayed in the uploads folder, but no luck.

    All of the themes for this site will let me create new pages, but I can’t write anything in the text boox, and the toolbar isn’t showing up.

    My PHP is 5.4.4 XCache, Apache port is 8888, MySQL port is 8889, and I have the root set to MAMPS htdocs folder. I have a copy of the same files in a file labeled WordPress in a non-application file structure elsewhere. I created a folder the site called WordPress on the MAMP’s PHPMyAdmin database, as per the MAMP instructions. It has 11 tables in it that it self-populated, but all are basic wp- tables. I do not know where to find info on its allocated memory…

    I’ve been searching throughout the Codex and generally to try to find some MAMP documentation about this issue, but haven’t yet found anything. The initial install happened pretty smoothly, though I did have to link the index.php manually via .htaccess.



    Hi Amy,

    I used MAMP about a year ago when I first started learning WP with Shoutbox. I had a few issues too at the beginning but I haven’t used it for ages so it’s a bit of a blur. Some of the things I do remember were:

    1. Install MAMP and WP properly. I used this video to help:

    2. I remember I had an issue with the permissions in the MAMP control panel. Click HOSTS (not SERVER) and you will see the ‘permissions’ button in the General options. You have to manually set them so you have permissions to do everything (check all the little check boxes and save it). This might be what is causing you problems.

    3. Make sure there is enough memory allocated to the php in MAMP and later when you go online. It can cause problems with the Template Builder if it is too small. I think the default is 16 or 32mb. I pushed mine up to 64mb or more. You change it by editing the php.ini file for the version of php you are using from: top menu /File / Edit Template / PHP.

    I changed these settings I think:

    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

    post_max_size = 64M ; Maximum size of POST data that PHP will accept.

    upload_max_filesize = 64M ; Maximum allowed size for uploaded files.

    Your database looks a bit small. Did you install the Shoutbox default template with the test images and test posts? I think the default phpmyadmin database should have about 24 tables.

    As Devin says, it’s a bit of a bugger to assist online because we can’t see what you have on the computer. Try some of these things (the permissions for example) and let us know what happens.

    rich x


    *BIG* sigh of relief.

    Rich, I don’t know what went wrong the first time – thought I had it, but there were so many errors even after trying to troubleshoot with your suggestions. Finally I just trashed the MAMP application I had and re-installed it and WordPress, exactly mimicking the tutorial you linked to (excellent find, by the way). It went smoothly until I uploaded Shoutbox, and then the same problem started out, so I switched back to 2010. I was really worried for a moment, because the permissions had all seemed alright by default, but the images and posts worked in 2010, and when I switched back to Shoutbox, it finally started working there as well.

    Thanks very much for your help! I sincerely appreciate it!





    I hope it works for you. It was probably just some stupid little thing, but it’s hard to explain or find what it could be when the files are all offline.

    Did you find how to fix the permissions?

    If you have any problems going online from the offline MAMP version (although it sounds like you know what you are doing), I did a quick guide thing for myself. I can send you it if you need it. Basically you have to remember to change ALL the urls, the wp-config.php file and export the database and upload it/restore it online correctly. I use a thing called WPtwin to back up and restore the site online. It works pretty well and their support team is also very good. I think you could use it to back up the offline one and then set up the online one from the cloned file. Check out their site.

    Any other issues, just post back here. The support team of Kriesi are fantastic. They helped me so much when I started.

    rich x


    Just a word of warning: WPtwin will not work if you try to transfer the website from a local sever (eg xampp server on Win7) to an external hoster. WPtwin just works with linux servers and thus you can only use it with some servers/hosters.

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Unable to upload images + posts: no dialog, just not working’ is closed to new replies.