Viewing 30 posts - 1 through 30 (of 51 total)
  • Author
  • #12122


    I’m unable to enter shortcodes via the magic wand button – the pop up window remains blank except for “Preview” “Insert” and “Cancel”.

    The theme I’m customising is Abundance.

    Second question: I cannot find out how to customise the footer – it shows ALL pages & categories. Is there a widget for it?

    Thanks a lot – the theme itself is great!


    I forgot to mention that I updated the 2 files “dialog.php” and “preview-shortcode-external.php” according to the suggestion in another support thread posted 3 days ago, by changing the code to

    foreach ($paths as $path)


    if(@file_exists($path.’/wp-load.php’)) {




    however without success.



    Please try to reload the theme for the shortcodes.

    About the footer, you can change it on Appearance > Widget. Look for footer columns.





    1. what do you mean by “reload the theme”? Shall I upload it again via ftp?

    2. Re. Footer: Solved! Thanks.

    3. Page “Blog” doesn’t show any posts, although the posts are shown on a page entitled “Archive for category: Blog” (cat=6). I have NO idea where that page is?

    How can I direct the posts to the “Blog”page I created for the menu?

    Or how do I set up the blog? I’ve set the page “Blog” under the Theme options as page showing the posts. But it doesn’t.

    Thanks for your support.


    Re. Question 3: Resolved! I could set the Blog page up in “Reading”.


    I’m having the same problem with shortcode button

    Using WP 3.3.2

    Abundance 1.3.1


    It seems to be quite a common problem. And it’s important to get this to work for a quicker workflow, but also for a non-tech client.

    Please help.


    I would be good to get this issue wrapped up… I have the same problem and a quick search for ‘shortcode’ also shows other having it too.


    Hello, anybody out there to help? It’s really urgent! Thanks.


    We are waiting for a solution! Really urgent as sumason please fix it!


    Hi All,

    There a number of different things that can cause the shortcode popup not to work. Here are the first steps you should all try in order.

    First, disable all plugins you have running and test the functionality again. If it works at this point you can being re-enabling them again one by one to find the offending plugin.

    Second, make sure the theme and wordpress are both updated.

    Third, ask your hosting provider to disable/modify the mod_security settings for your site as its causing a conflict. This is a common request specifically if you are using Host Gator so they should understand the request.

    Fourth, Try:

    Opening then modify




    search for following line to find the right code:

    foreach ($paths as $path)
    if(@include_once($path.’/wp-load.php’)) break;

    replace with:

    foreach ($paths as $path)
    if(@file_exists($path.’/wp-load.php’)) {

    Finally, if you are still having issues let us know. So far the issue where we are unable to solve the problem has been limited to a small handful of people but if we can identify a common thread there is a greater chance we can find a fix.

    If you need to use the shortcodes for creating a layout, create a new page in your site and paste this into your visual editor:

    Then save the page as a draft and use the shortcode layout as a reference since they all still work, just are not available as a pop-up.





    it works!

    I deactivated all my plugins, and the magic wand finally did what it should do.

    Then I activated one plugin after the other, always testing the magic wand in between – and suddenly all goes smoothly.

    I hope for the other sufferers that this does the trick for them too – or at least to find the culprit (which I didn’t!).


    SORRY – I was wrong.

    I got confused as I’m dealing at the same time with another template from Themedy – and their editor (= their “magic wand”) works fine… Unfortunately in the case of Abundance, even when I deactivate all plugins, the Magic Wand still doesn’t work.

    So, Devin, I’ll work my way down your list and I’ll update soon.

    Thanks anyway.


    I can confirm that I can’t get it working on Hostgator or – I don’t want to turn off the mod_security settings but I tried the other ways but no success


    No success too! We want a new theme update to fix that problem…



    1. I modified the 2 .php files (which I had done anyway, as you had recommended this in another support mail to another client).

    2. I’ve added a SecRule in the .htaccess file to filter the mod_security rule.

    3. All plugins have been tested – no success while deactivated either.

    The not-so-magic-wand still doesn’t work.

    So please, get this going very quickly.


    Hi All,

    Generally, there isn’t a way to create a magic fix for an issue we don’t have a root cause for. On a clean install of wordpress and the theme, the shortcode button should work without issue. Things like child themes, plugins, odd server configurations or incorrect versions of php can all always cause problems that we are unable to fix.

    @eddygame – The mod_security settings may be preventing the scripts from running properly. It was reported by another user that after having the settings changed by hostgator for TimThumb, the pop-up for shortcodes started working. If the settings are preventing the shortcode pop up to work I’m not sure there is anything else we can do.




    Hey Guys, since I cant reproduce the issue would you mind sending me your wordpress installation url and login data so I can take a look myself?

    You can use the contact form here: – If you start the message with “Shotcode Help” it will be redirected to my priority folder ;)

    Thanks for your patience and help!


    Hi Devin,

    I’m am still having that issue with shortcodes and glad it’s happening to others – I don’t feel so alone.

    I have taken all of the above steps for resolution except for the editing of the “dialog.php” part.

    I’m also confirming that it does work on another server but that hosting company will not share any configuration due to security.

    I have emailed Kriesi so I could be added to get a possible resolution after such hard work in trying to find a fix for this.

    I will keep watching the forum thread closely.




    Hey guys,

    Also having this similar problem.

    Did all the fixes as listed above and no change.

    Any help is appreciated!


    I have also contacted Kriesi and given him my login details. Hope very much he’ll find a solution.


    I am having the same issue, the pop up opens up and is blank.

    Also, I have no plugins activated and I am working locally using MAMP. Any ideas?


    Just another frustrated user here having the same problem with Propulsion theme. This is definitely a issue NOT limited to a small number of people. I, too, am getting see the error coming for display.php regarding missing parameter add_action(‘avia_shortcode_dialog’);.


    Hey Guys! I have received a number of helpful hints and login details so I can test it myself. I will let you know as sonn as I have a fix for this. Sorry for the problems and thanks for your patience!


    I, too am having this problem.


    Hey erveryone!

    This is probably the most weird bug I have ever encountered. the problem is definitely the dialog.php file. the funny thing is that the same file appears to work on some themes and absolutely wont on others.

    It seems there is a hidden character in there that somehow messes up the javascript loading.

    This is the dialog.php file that should work, would be glad if anyone could test it and replace their current dialog.php file with this one. If it works for you let me know so I can release bugfix updates.

    Thanks again for your patience and help!


    Hi Kriesi,

    Where does that file gets uploaded to?



    Found it


    Hey! You need to unpack the zip file, then upload the file to your webserver via ftp into the

    wp-content/themes/YOUR-THEME/framework/php/avia_shortcodes/tinymce/ directory and replace the existing dialog.php file


    Hi Kriesi,

    Problem remains. No change.


Viewing 30 posts - 1 through 30 (of 51 total)

The topic ‘unable to enter shortcodes via the magic wand button’ is closed to new replies.