Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #19727

    It’s appear the Twitter Widget has stopped working. All that appears is No public Tweets found.

    How do I solve this issue?


    you might want to try to remove the widget completely and add it again then. sometimes when you query the twitter api you dont get a result and since the theme caches the results it might be possible that this is just a cached result


    Still not working!


    Hey datahjelpen,

    If you have any plugins active, try deactivating them first. Then, remove the widget once again and make sure its removed on the front end as well.

    Once again, re-add in the twitter widget with your user name and see if its able to properly pull your twitter feed. It may have had issue before since your previous tweet (for the one on the 25th) was so long ago but i’m not completely sure :)




    Hi Kriesi, I’m having the same problem as Datahjelpen, and I’ve had the theme installed since 2010, so the Twitter widget has suddenly stopped working. I’ve followed your suggestion and that of Devin, but it’s not re-installing. I am assuming you’re talking about deleting it from within the WP admin panel though. Do I need to delete it off the server and reinstall?




    PS: I’m a really regular Tweeter for this site too, so I’ve only noticed it stopped working in the last two days.


    Yeah, it’s stopped working for me too. Has anything changed with Twitter’s API?

    EDIT: Eunoia theme

    UPDATE: It’s working again now.


    Hi Devin

    I’ve done all things you described, but it’s still not working:-(

    One thing I noticed is that the theme does not need a permission to connect to twitter like jetpack do. Why not?

    By the way the twitter plugin from jetpack does not work either.

    To me it seems to be a wordpress problem rather than a theme problem.

    What do I do now?



    A new theme update has been released. Try to download it on your themeforest account.





    The Twitter widget still don’t work after I updated Sentence theme to version 1.6


    Our twitter widget requires the wp_remote_get() function to query the data. Maybe your server does not support socket connections in general or it blocks the wp_remote_get() requests. You can try to contact your hoster – maybe they just need to change the server configuration a bit or you can use a javascript based widget (like )


    Hi Dude

    My provider does not support socket connections and they will not change the server configuration for me. They say it’s a service they don’t provide for their costumers:-(

    I’ve noticed that does not support gzip compression either. Does anyone have a recommendation to me for a provider that provides individual server configuration?

    Meanwhile i will use the javascript version.


    Hey datahjelpen,

    I always recommend the host I use:




    There is definitely an issue to the Abundance Tweet Feed plugin. It seems it has a compatibility issue with WP 3.5.1 since the problem only occurred since upgrading WordPress. While the tweets are showing up there is a massive CSS issue with the line spacing. Please see and scroll to the footer to see what I’m talking about. I look forward to your reply.



    Please place this on your custom.css

    #top .tweet {
    line-height: 21px;
    font-size: 11px;



Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Twitter widget not working’ is closed to new replies.