Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #2197

    Hey guys,

    Im trying to post each individual post in facebook so that it comes up on the wall with the individual posts image and description,

    But all I seem to get is a horrific gravatar logo instead.

    When I post the URL for the entire site (Not the individual posts) into facebook,

    I do get a selection of images, but no new, updated ones whatsoever.

    Any thoughts? Not sure if i’ve deleted something or there’s a way around it.

    Any help would be greatly appreciated.

    Many thanks



    This is most likely something that is on FB’s end. We can’t really control what image appears there. Normally FB gives you a list of images with arrows below them to cycle through and find the one you like, do you have the arrows?


    I am having the same problem. I try to share my post in Facebook and my only thumbnail option is the avatar. I tested a blog post on your demo site on Themeforest by sharing it on Facebook and I was allowed to choose any image on the page to use as my thumbnail. Is there a setting I am missing to allow me to use any image for sharing purposes?

    Never mind fixed it. Share and follow plugin conflict combined with Facebook image cache.


    Glad that you solved the problem :)


    Hi there!

    I would like to get my friends to share my website in Facebook, either by wall posts, or status updates but there are no images displayed next to the description of my website.

    Is there a way that I could work around it, or by predetermining which image gets displayed along with the description?

    Many thanks in advance.

    Charles :)


    oops sorry, i left my website out. its at

    Thank you!



    Yes, seo plugins like: allow you to add the required facebook meta tags to your website.




    Thank you so much DUDE! I’ll try to figure it out. :)


    If you need further assistance let us know.



Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Thumbnails will not show in facebook / No live update’ is closed to new replies.